Solved

Workflow in Sharepoint 2010

Posted on 2010-08-31
4
575 Views
Last Modified: 2012-06-27
I'm trying to add a workflow to a list in sharepoint 2010.  I'd like to have an email sent every time a new item is created.  So in sharepoint 2010 designer, I go to the list and add a workflow.  But when I add a new item in the list, the email does not get sent.  Any thoughts?
0
Comment
Question by:JLEmlet
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 15

Expert Comment

by:dp_expert
ID: 33575414
DId you configure the activity properly? Is your sharepoint configured to send e-mails? Do your alerts work? First check if SharePoint is able to send e-mails by creating an alert on the list. If this works check the configuration of the send e-mail activity and check workflow history and logs for errors.
Also - if you just want to get e-mail when new item is created better use alerts - much lighter and easier to configure.
0
 

Author Comment

by:JLEmlet
ID: 33575971
The emails work fine.  In fact, I can get the workflow to send the email if I run it manually through the web interace.  It's when I create an item that it doesn't run even though the settings are to automatically run when an item is created or changed.
0
 
LVL 15

Accepted Solution

by:
dp_expert earned 500 total points
ID: 33576705
But does the workflow start or not? If not then the problem is not with e-mail but with workflow start. What account are you using to create the item? Do you have any errors in SharePoint logs?
0
 

Author Closing Comment

by:JLEmlet
ID: 33577436
THanks for your help.  I found in the logs that the system account cannot trigger automated workflows.  That was the issue!
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last week I faced a strange issue recently, i have deployed SharePoint 2003 servers for one project and one of the requirements was to open SharePoint site from same server. when i was trying to open site from the same server i was getting authentic…
I recently came across an issue with a MOSS 2007 deployment where access into some sub-sites were denied, even for the MOSS farm administrators. A bit of background to the setup of this MOSS farm; this was a three server setup, consisting of a fr…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question