• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 893
  • Last Modified:

Wampserver - cannot get localhost to load.

I am running Windows Vista, SP 2 Home Premium. Installed Wampserver version 2.0, including  mySQL, PHP and Apache components all at once using their installation package.

When I visit http://localhost, my browser loads and loads but does not come up with the wampserver "homepage", indicating that the server is running. It just remains blank and stalls.

Things I have done to try to remedy this:

1) Made sure all services were running through the wampserver taskbar icon (the icon indicates it is running).

2) Restarted all services.

3) Tested which port is available for Apache to use by running "Test Port 80". The result is:

"Your port 80 is actually used by :

Server: Apache/2.2.11 (Win32) PHP/5.3.0"

I presume this means wampserver is the only program using port 80 at the moment.

4) Previously, I'd had IIS installed, but uninstalled it completely from my system then restarted my computer, then reinstalled Wampserver.

Interestingly enough, when I attempt to connect localhost through my browser, I can't load ANY other pages in other tabs. If I want to visit Google or any  other site while localhost is loading, it won't let me. When I exit out of the localhost browser window, I'm seemingly given back access to the internet.

Both localhost and phpmyadmin options in the wampserver taskbar dialogue box give me the same blank page issue I've mentioned above.

Your help is appreciated. Apologies if I left any essential details out.

  • 3
1 Solution
You hide to provide more details about the config files.. especialy apache  httpd.conf and the error logs

Try another browser (Firefox, Opera, Chrome)

If you have Skype installed, try to configure apache to run on another port (ex 8080)
(server_path/apache/conf/httpd.conf  Listen 80 change to Listen 8080)

You could try XAMPP from apachefriends.org
ShootFromtheHipAuthor Commented:
Thanks for responding.

I just changed the port to :8080 and tested it in IE, Firefox and Chrome - it works in Chrome just fine for some reason. Why doesn't it work in the other browsers?

By "work" I mean I'm able to use localhost and phpmyadmin now, but in Chrome only.

What should be altered to make it work in the other browsers?

Do you have an intranet/local browsing security rule set that keeps you from visiting local sites or, more likely, prohibits you from running local scripts?

On IE9 you can access these settings by going to Internet Options->Security->Local intranet.
ShootFromtheHipAuthor Commented:
Upgraded computer - issue is now resolved as a result.
ShootFromtheHipAuthor Commented:
Good responses.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now