Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Dynamics CRM 4.0 error - Reporting Error - Event ID 19969

Posted on 2010-08-31
16
Medium Priority
?
3,066 Views
Last Modified: 2012-05-10
Hi

I am receiving an error in MS Dynamics CRM 4.0 when generating reports through the reporting services:

"Reporting error. The report cannot be displayed".

The error seems to be happening for all reports. I checked the event viewer - application log and it has the following error:

Event ID 19969

Web service request SetParameters to Report Server http://esolutio-ffeadb/reportserver failed with SoapException. Error: The permissions granted to user 'TIREWEB\IUSR_ESOLUTIO-FFEADB' are insufficient for performing this operation. (rsAccessDenied)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

And a warning:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 8/31/2010 6:12:24 PM
Event time (UTC): 9/1/2010 1:12:24 AM
Event ID: f5566006485a48bfa63821a69bb88f9b
Event sequence: 13474
Event occurrence: 10
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/2/ROOT-1-129277190477656250
    Trust level: Full
    Application Virtual Path: /
    Application Path: C:\Program Files\Microsoft Dynamics CRM\CRMWeb\
    Machine name: ESOLUTIO-FFEADB
 
Process information:
    Process ID: 1080
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: CrmReportingException
    Exception message: The permissions granted to user 'TIREWEB\IUSR_ESOLUTIO-FFEADB' are insufficient for performing this operation. (rsAccessDenied)
 
Request information:
    Request URL: http://esp.tireweb.com:5555/CRMReports/rsviewer/reportviewer.aspx 
    Request path: /CRMReports/rsviewer/reportviewer.aspx
    User host address: 124.168.244.109
    User: {ab660bc1-1400-df11-bd7d-001321b3b0fe}
    Is authenticated: True
    Authentication Type: CrmPostAuthentication
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at Microsoft.Crm.Web.Reporting.SrsReportViewer.ConfigurePage()
   at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
 
 
Custom event details:

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


The server is a Windows Server 2003 machine with MS SQL 2005 and MS CRM 4.0. All services operate from the same machine.

Any ideas?

Thanks for your help
0
Comment
Question by:kevtrains
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
  • 3
16 Comments
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 33574325
PLease have a look at my troubleshooting article on this: http://www.experts-exchange.com/Database/Software/CRM/A_3552.html

and let me know at what point things fail.

0
 

Author Comment

by:kevtrains
ID: 33574381
Hi feridun, thanks for the comment

I tried out the steps in your article, it failed at step 6 after clicking one of the reports

Error is Execution 'bjfpi345p4qaahjfq24kcqqh' cannot be found.

Thanks
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 33574435
Hmm.  I've usually seen that error when CRM and SQL are on different computers but you say that everything is on the same server.

I wonder if there is a deeper problem with Reporting Services. Are you using Reporting Services for anything else? and did it ever work for CRM reports?

If not and no I'd be tempted to reinstall Reporting Services OR double-check the Reporting Services Configuration using Reporting Services Configuration Manager to ensure there are no issues.

Just thought: check whether anonymous access is enabled for the reports virtual directory in IIS. If it is, disable it.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 11

Accepted Solution

by:
rakeshAgarwal earned 1000 total points
ID: 33574473
Error is Execution 'bjfpi345p4qaahjfq24kcqqh' cannot be found.

 just  install reporting services  data connector
 
 and  change the  report source it will work
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 33574479
If all services are on the same computer, the reporting services data connector isn't needed.
0
 
LVL 11

Expert Comment

by:rakeshAgarwal
ID: 33574489
I know that  but I have seen this error on same box and was able to resolve by installing dataconnector . For IFD  You need it

rakesh
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 33574496
For IFD I agree.
0
 

Author Comment

by:kevtrains
ID: 33574525
Hi - we are not using reporting services for anything else - it is a new CRM installation and it has not worked before for CRM reports.

I tried changing some settings regarding anonymous access and now getting another error:

Web service request SetParameters to Report Server failed with SoapException: Error The path of the item '/ESP_MSCRM/4.0/' is not valid. The full path must be less than 260 characters long; other restrictions apply. If the report is in native mode, the path must start with a slash.
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 33574555
OK. Would you mind running through my article again to see where the reporting fails please?

0
 

Author Comment

by:kevtrains
ID: 33574635
still failing at the same place with the same message, do you think a reinstall of reporting services is worthwhile?
0
 
LVL 30

Expert Comment

by:Feridun Kadir
ID: 33574643
Maybe not yet, did you run the  Reporting Services Configuration Manager on the SQL Server?
0
 

Author Comment

by:kevtrains
ID: 33574837
i installed the reporting services data connector and it seems to work now. our install is not IFD though so I am not sure why we need it?
0
 
LVL 30

Assisted Solution

by:Feridun Kadir
Feridun Kadir earned 1000 total points
ID: 33574848
No I don't know why you need it. It does seem to solve various authentication issues though.

However, I have set up many CRM installations on a single server with SQL without the data connector succesfully.

At least you have something working now.
0
 

Author Comment

by:kevtrains
ID: 33574855
yes i'm happy about that, thanks for your help! very greatly appreciated.
0
 

Author Closing Comment

by:kevtrains
ID: 33574861
thanks
0
 
LVL 11

Expert Comment

by:rakeshAgarwal
ID: 33574921
I feel happy that I was able to happy thanks
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction Earlier I wrote an article about the new lookup functions (http://www.experts-exchange.com/A_3433.html) that ship with SQL Server 2008 R2.  In this article I’m going to show you another new feature of SSRS 2008 R2, this time in the vis…
In this article we will get to know that how can we recover deleted data if it happens accidently. We really can recover deleted rows if we know the time when data is deleted by using the transaction log.
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question