Solved

l2tp vpm

Posted on 2010-09-01
9
638 Views
Last Modified: 2012-05-10
we are not connect l2tp vpn pls help me

config details: This is a config of port forwarding.

-A PREROUTING -d 12.12.12.2 -i eth0 -p udp -m udp --dport 1701 -j DNAT --to-destination 192.168.200.1

-A FORWARD -p esp -j ACCEPT
-A FORWARD -p ah -j ACCEPT
-A FORWARD -p udp -m udp --dport 1701 -j ACCEPT
-A FORWARD -p udp -m udp --dport 500 -j ACCEPT
-A FORWARD -p udp -m udp --dport 4500 -j ACCEPT
0
Comment
Question by:gopigops
  • 5
  • 4
9 Comments
 
LVL 3

Expert Comment

by:gremwell
ID: 33576516
You should describe your setup in more details. The config of iptables you are troubleshooting -- is it on the vpn client host, or an intermediate router?
0
 

Author Comment

by:gopigops
ID: 33576826
we have one server for windows 2003 act as a vpn server
we have one server for redhat act as a firewall
we are unable to connect vpn using l2tp, but pptp vpn works fine

this is a config

-A PREROUTING -d 12.12.12.2 -i eth0 -p udp -m udp --dport 1701 -j DNAT --to-destination 192.168.200.1

-A FORWARD -p esp -j ACCEPT
-A FORWARD -p ah -j ACCEPT
-A FORWARD -p udp -m udp --dport 1701 -j ACCEPT
-A FORWARD -p udp -m udp --dport 500 -j ACCEPT
-A FORWARD -p udp -m udp --dport 4500 -j ACCEPT
0
 
LVL 3

Expert Comment

by:gremwell
ID: 33577942
I would suggest you to sniff the traffic on both interfaces of the firewall and see what packets get blocked when you try to establish the VPN. Check if IKE (UDP 500 or 4500) and IPSEC (ESP).

By the way, UDP 1701 packets travel encapsulated in IPSEC and are invisible to IPTABLES, the corresponding statements in your policy have no effect on L2TP. If you need DNAT, can try to apply it to IKE/ESP traffic.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:gopigops
ID: 33584543


we are unable to connect till now,pls tell me the above config correct or not.If not pls give me a correct config .

And then we have checked the traffic the show ony the isakmp and UDP
0
 
LVL 3

Expert Comment

by:gremwell
ID: 33586317
Please provide more details about your setup.

What OS do you use as a client? Does the L2TP client software support NAT-T (nat traversal)?
What is IP address of your client?
What IP address your client tries to connect to?

What is the IP address of the interface of your router facing L2TP client?
What is the purpose of DNAT statement, what address translation you are trying to achieve?
What is the IP address of the interface of your router facing L2TP server?

What is the IP address of the L2TP server?
0
 

Author Comment

by:gopigops
ID: 33586676
ok i give

1.windows vista
2.public ip (internet work no issues)
3.public ip 12.12.12.2 (example)
4.12.12.12.2
5.
6.12.12.12.2
7.192.168.200.1 (windows 2003 server)
0
 
LVL 3

Accepted Solution

by:
gremwell earned 500 total points
ID: 33587679
Assuming eth0 is your internet-facing interface, you have to apply the following:
# pass IKE traffic
iptables -t nat -A PREROUTING -i eth0 -p udp -d 12.12.12.2 --dport 500 -j DNAT --to 192.168.200.1
iptables -A FORWARD -i eth0 -p udp -d 12.12.12.2 --dport 500 -j ACCEPT

# pass IPSEC packets encapsulated in UDP datagrams
iptables -t nat -A PREROUTING -i eth0 -p udp -d 12.12.12.2 --dport 4500 -j DNAT --to 192.168.200.1
iptables -A FORWARD -i eth0 -p udp -d 12.12.12.2 --dport 4500 -j ACCEPT

Open in new window

You don't need iptables rules you have posted earlier.

Some people say that running IPSEC servers behind NAT is bad idea http://support.microsoft.com/kb/885348/:

"... the default behavior of Microsoft Windows XP has changed with Service Pack 2 (SP2). IPSec NAT-T security associations to servers that are located behind network address translators are not recommended for Windows XP SP2-based computers. This change means that a Microsoft Windows Server 2003-based virtual private network (VPN) server that uses Layer Two Tunneling Protocol with IPSec (L2TP/IPSec) cannot be deployed behind a network address translator without additional configuration for Windows XP SP2-based VPN clients.

If you require IPSec for communication, we recommend that you use public IP addresses for all servers that you can connect to directly from the Internet. Windows-based client computers that support IPSec NAT-T can be located behind a network address translator. ..."

See http://support.microsoft.com/kb/947234 for instructions how to configure your Vista to allow connections to the VPN server located behind NAT.

0
 

Author Comment

by:gopigops
ID: 33589514
we understand the IPSEC servers behind NAT.thanks..
0
 

Author Closing Comment

by:gopigops
ID: 33589526
thanks..
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Like many others, when I created a Windows 2008 RRAS VPN server, I connected via PPTP, and still do, but there are problems that can arise from solely using PPTP.  One particular problem was that the CFO of the company used a Virgin Broadband Wirele…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question