Solved

How do I make my cisco soho 91 router's communicate with d-link router on different subnet?

Posted on 2010-09-01
14
785 Views
Last Modified: 2012-05-10
Hi...

I've tried this for hours :) hope to get an expert response from anyone that is willing to help me out. "I'm not a cisco guy, first week playing with it" so be gentle.

I have a Cisco SOHO 91 router and a D-Link WBR-1310 (wireless).
I've successfully setup them to run on the network, but both without communicating with one another since they are in different subnets. "I want them to be able to communicate".

Cisco IP: public ip via dhcp (wan) and 10.0.0.1 / 255.0.0.0 (lan)
D-Link IP: 10.0.0.11 / 255.0.0.0 (wan) and 10.20.30.40 / 255.255.255.0 (lan)

If I set the d-link LAN side subnet to 255.0.0.0, on the WAN side of d-link I get DHCP Client Disconnected (wan) as its shown, and no IP is assigned to the WAN port.

When I connect with a wireless laptop I cannot ping or communicate with any PC on the cisco's ip network and vice-versa.

Here is my Cisco's # show run
...
!
no aaa new-model
ip subnet-zero
no ip domain lookup
ip dhcp excluded-address 10.0.0.1 10.0.0.9
!
ip dhcp pool lan_dhcp
   network 10.0.0.0 255.0.0.0
   default-router 10.0.0.1
   dns-server 68.87.xxx.xxx 68.87.xxx.xxx     <---- ISP's DNS
!
!
!
interface Ethernet0
 description LAN Interface
 ip address 10.0.0.1 255.0.0.0
 ip nat inside
!
interface Ethernet1
description WAN Interface
 ip address dhcp
 ip nat outside
 duplex auto
 no cdp enable
!
ip nat inside source list 1 interface Ethernet1 overload
ip classless
no ip http server
no ip http secure-server
!
access-list 1 permit 10.0.0.0 0.255.255.255
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
!
end


Setup:

Moden -> Cisco -> D-Link -> Switch
                   |               |               |
                x pc         x pc         x pc

x = any number of computers

If I add, ip route 0.0.0.0 0.0.0.0 eth1, on my cisco, I cannot access the public internet " I saw people referring to that on some forums"

Can anyone guide me through how to make the two different subnet communicate, would be happy even if you want to give me a lesson on subnetting and it works :)

I can change things around to try new stuff as well, but I want different subnet.

If more information is needed let me know, I will try to provide as much as I can.

Thank you in advance.
0
Comment
Question by:rr100
  • 6
  • 5
  • 2
  • +1
14 Comments
 
LVL 21

Expert Comment

by:from_exp
ID: 33574601
hi!
first of all you don't need mask of 255.0.0.0. It is HUGE subnet. It would be sufficient to have 255.255.255.0 mask.
only after that we can take subnet 10.0.0.0/24 (/24 means 255.255.255.0 in CIDR notation) and use it for PCs behind cisco eth0. Eth0 with ip of 10.0.0.1 will be dafault GW for all PC behind him.
access list 1 leave as is.

D-link router can have 10.0.0.11/24 as wan address, and let's say 10.0.1.1/24 as lan address. so wireless clients will get addresses from 10.0.1.2-254 subnet.

now the tricky part, you have tried to do, but with no success: you need a static route on cisco to 10.0.1.0/24 subnet.
ip route 10.0.1.0 255.255.255.0 10.0.0.11 should do the thing.

after that your cisco will be able to privide internet to both wifi and wired PCs and your wired PC will be able to access wifi PCs.
0
 
LVL 2

Author Comment

by:rr100
ID: 33580567
Thanks for the reply.
Ok, so I changed the dhcp network address to: 10.0.0.0 255.255.255.0
Then, I changed Eth0's IP to 10.0.0.1 255.255.255.0
Then, I added ip route 10.20.30.0 255.255.255.0 10.0.0.11 (since I want all D-Link to have 10.20.30.XXX address)
Access-list, still: access-list 1 permit 10.0.0.0 0.255.255.255 (as you said to be the same)


But that did not work. If I add the ip route command, I do not get internet access on the Wireless network from d-link, so its not going public.

Did I do something wrong?

I want that when I go to http://10.20.30.40, that is my wireless router, just the way it is now, but communicating with cisco's nework.


Thanks let me know what I did wrong or any other options.
0
 

Expert Comment

by:hostarica
ID: 33582920
Hello rr100:
If what you want is to have the Wireless PCs  sharing the same LAN segment with the PCs connected to the router then try this:

Let's say your cisco router has the following ip: 10.0.0.1 mask: 255.255.255.0
* Connect to your wireless device (D-Link) and manually configure the IP: 10.0.0.254 mask:  255.255.255.0

* now, connect the router to your D-link, but DO NOT use the WAN interface, connect it to the LAN ports (it has 4) in this way, the d-link will work as a switch only.

* connect your wireless PC, it will get a DHCP address from your cisco and not from the d-link.

it will be connected in this way:
Modem -> Cisco <-------> (LAN PORT)D-Link ---------> Switch
                   |                                               |                        |
                x pc                                         x pc                 x pc

in this way all the PCs will be sharing the same segment, and you will be able to access them back and forth.  

PD. the IP assigned to your dlink (.254) is in case you want to access it later.

regards.
0
 
LVL 2

Author Comment

by:rr100
ID: 33583459
Thank hostarica,
I've done that in the past, but unfortunately thats not an option for me at this moment.
Will have to figure out the subnet commutation, with the 10.20.30.40 d-link to the 10.0.0.1 cisco device, some how there is an answer.

---
I don't want to change wireless LAN IP, I want it to stay as 10.20.30.40, and it has DHCP which is assigning from 41 to 60.


Let me know if you have something else I can try.


Thank you both so far.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 33583834
hi rr100, my apologize, but to my solution I have forgot to mention, that you have to disable NAT on d-link. so yes, you are using dlink's wan port to connect it to cisco, but you don't use NAT (Network address translation).
do you have default gw on d-link configured to 10.0.0.1? what mask do you have on d-link's wan address?
0
 
LVL 2

Author Comment

by:rr100
ID: 33584348
hey from_exp:
got a little confused there....

but, here is my D-Link's information:

LAN :
IP Address :       10.20.30.40
Subnet Mask :       255.255.255.0
DHCP Server :       Enabled

WAN:
Connection :        DHCP Client Connected  
IP Address :       10.0.0.11
Subnet Mask :       255.255.255.0
Default Gateway :       10.0.0.1
DNS :       68.87.xxx.xxx 68.87.xxx.xxx

I don't believe much else is configured.

let me know.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 33584519
rr100, I've got manual for  D-Link WBR-1310 now and it seems there is no option to disable NAT. It means PCs from behind cisco will be unable to reach wireless PCs. If you still don't want to use hostarica solution, then then only thing we have to solve here - is internet availability for wifi users.
btw, right now, wifi users should be able to ping 10.0.0.1 and PCs behind cisco.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 21

Expert Comment

by:from_exp
ID: 33584527
please also post current cisco config, please
0
 
LVL 2

Author Comment

by:rr100
ID: 33586000
thanks from_exp.

Not sure if there is anything else wrong, but from Wireless I cannot ping 10.0.01 or pcs on cisco's network as you said. Maybe because the ip route command didn't work for me.

Here is the current cisco config.

...
!
no aaa new-model
ip subnet-zero
!
ip dhcp pool lan_dhcp
   network 10.0.0.0 255.255.255.0
   dns-server 68.87.xxx.xxx 68.87.xxx.xxx
   default-router 10.0.0.1
!
interface Ethernet0
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet1
 description WAN
 ip address dhcp
 ip nat outside
 duplex auto
!
ip nat inside source list 1 interface Ethernet1 overload
ip classless
no ip http server
no ip http secure-server
!
access-list 1 permit 10.0.0.0 0.255.255.255
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
!
end


Thanks.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 33595691
if you have connected everything correcly, you should be able to ping 10.0.0.1 from d-link....
0
 
LVL 21

Accepted Solution

by:
from_exp earned 250 total points
ID: 33595696
at present time you have NAT on d-link, so now you can change access list to:
access-list 1 permit 10.0.0.0 0.0.0.255
0
 
LVL 5

Expert Comment

by:BooSTid
ID: 33632460
As has been described here, I don't know that you can get this to function the way you want. You can certainly use the Dlink as an access point on the same network, but you can't segment it out. You probably could with a different router (cisco), but I'm pretty sure that Cisco doesn't allow multiple networks to be configured behind it (i.e. subinterfaces). Quick test of that would be to try:

Router(conf)# int ethernet1.1

If so, you could setup sub interfaces, set the dlink to AP mode, and assign your ranges that way... but I doubt it.

Otherwise, without static routes or a dynamic routing protocol, you won't be able to setup routing between networks that are behind separate routers.
0
 
LVL 2

Author Comment

by:rr100
ID: 33633973
I've come to the conclusion that this cannot be done, but since you helped me all these days I wanted to thank you for the effort. Will be getting a second cisco soon.

Thank you all.
0
 
LVL 5

Expert Comment

by:BooSTid
ID: 33637637
You rewarded points for incorrect answers? Points for effort I guess.
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

Suggested Solutions

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now