Broken Exchange 2007 OWA after SSL Install

I was following instructions online after unsuccessfully installing a renewal SSL cert for exchange 2007 owa.  It had me run a command to overwrite the default SMTP cert by using this "certutil -repairstore" command.  After I ran that, I went from users getting a cert error to a 404!  Anyone have any ideas how I can get my OWA back up and running?

Running SBS 2008 with Exchange 2007
SteveMat11Asked:
Who is Participating?
 
Tony JConnect With a Mentor Lead Technical ArchitectCommented:
Wow...what a complete pig of a problem.

For anyone else in the same boat, I followed steps to recreate the OWA virtual directory from within EMS but it didn't work.

In the end, we ended up agreeing to bite the bullet and put Exchange SP2 on - for anyone else who needs to do this on SBS 2008, the easiest way is as follows:

Update Windows Installer to 4.5
Download Exchange 2007 SP2
Download the SBS Exchange 2007 SP2 Installer
Extract the SP2 files
Install and run the SP2 installer and follow the instructions

Ensure that the default website has nothing bound for https / 443.

At this point, I needed to tell the SBS Applications Website to use the correct certificate as it had reverted to using the self-installed one.

Reboots may be required after MSI 4.5 and Exchange SP2.
0
 
Tony JLead Technical ArchitectCommented:
I would remove the certificate (assuming you still have a copy of it from your CA) and go through the following steps:

How To-Enable SSL on Exchange 2007 services.

Step 1: Obtain a SSL certificate- E.g. www.thawte.com or www.verisign.com
Step 2: Import the SSL certificate and copy thumbprint.
- Run the following command where “c:\newcert.cer” is the location and name of your certificate: Import-ExchangeCertificate -path c:\newcert.cer
- Copy the thumbprint by doing the following:
- Open the Exchange Management Shell.
- Run the following command: dir cert:\LocalMachine\My | fl
- Locate the certificate you just imported and copy the Thumbprint property to the Windows Clipboard.
Step 3: Enable the certificate on the Default Web Site:
- Open the Exchange Management Shell.
- Run the following command: enable-ExchangeCertificate -thumbprint [value you got from above] -services “IIS,IMAP,POP”
0
 
vickzzCommented:
Do you have SP2 for Exchange on SBS machine?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Shreedhar EtteCommented:
Does the Exchange 2007 is updated with the latest servicepacks? If not, update it. It will fix the problem.

Hope this helps,
Shree
0
 
SteveMat11Author Commented:
Tony, I tried those exact instructions.  It asked me if I wanted to overwrite, I said yes.  I still have nothing.  I am using a GoDaddy SSL Cert.  Thanks for any help you can give.
0
 
SteveMat11Author Commented:
Not sure if this matters but the cert file extension is .crt not .cer
0
 
Tony JLead Technical ArchitectCommented:
Hmm. Can you see the certificate in the cert manager snapin?

Start -> Run -> MMC -> File -> Add/Remove Snapin -> Certificate -> Computer Account -> Local Computer

Can you confirm the certificate is there and has a private key?
0
 
SteveMat11Author Commented:
yes, it is showing and says I have a private key.  Interesting though, our owa address is "maildotcihvadotorg.  If I access it now with a https:// instead of a http://, im getting something but still not owa.  Any ideas?
0
 
Tony JLead Technical ArchitectCommented:
Ah yes - OWA in 2007/2010 has to be via HTTPS

What are you getting now?
0
 
SteveMat11Author Commented:
Error 403
0
 
Tony JLead Technical ArchitectCommented:
I'm seeing 503 when I look (when I reread, I saw your owa address!) - service unavailable.

Has anything else changed? Any other software installed?
0
 
Tony JLead Technical ArchitectCommented:
If you're getting 403, I suspect you aren't adding /OWA to the end of the web address?

i.e. https://address/owa
0
 
SteveMat11Author Commented:
nothing, i believe you got the 503 when I was restarting iis.
0
 
Tony JLead Technical ArchitectCommented:
Ha yeah that'd do it :)

This is weird because your cert looks ok from here although once we get this going we maybe need to talk about SAN/UC certs down the line.

Anything in the event logs?
0
 
Tony JLead Technical ArchitectCommented:
If you run the Get-ExchangeCertificate command, what do you get back?
0
 
SteveMat11Author Commented:
nope, checked there.  Basically what I did right before it broke was did a -repairstore on the cert per instructions I had found line since I was getting an error while trying to install it.  It said something about private key missing and the instructions said to use the repairstore command if that happened.  As soon as I did that, it stopped working.  
0
 
SteveMat11Author Commented:
i get back the following:
mail.cihva.org (this is what I purchased from godaddy) Services are "WS"
livewire  - no services
remote.cihva.org "IPWS"
WMSVC-WIN-SOMETHING.... No services
sbsserver.cihva.local "IPS"
Sites "IPS"
CIHVA-SBSSERVER-CA ..... No services
0
 
Tony JLead Technical ArchitectCommented:
Try this:

enable-ExchangeCertificate -thumbprint [value you got from above] -services “IIS,IMAP,POP,SMTP”
0
 
SteveMat11Author Commented:
tried that, nothing
0
 
Tony JLead Technical ArchitectCommented:
I'm getting the address rewrite in the IE address bar now but it just times out.

Can you have a quick look through the event logs?
0
 
Tony JLead Technical ArchitectCommented:
mail.cihva.org (this is what I purchased from godaddy) Services are "WS"

W = Web
S = SMTP

That should be ok for what we're doing.

The only solution I can see for this appears quite drastic:


Uninstall IIS
Reinstall IIS
Uninstall CAS
Reinstall CAS
Reregister OWA in IIS

The following URL http://support.microsoft.com/default.aspx?kbid=320202
0
 
SteveMat11Author Commented:
Would you be opposed to rdping in and taking a look?  If not, email me at stevem11 at optonline dot net
0
 
SteveMat11Author Commented:
Still cant believe he figured this one out.  Thanks for all of the help!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.