Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

OWA Exchange 2007 Page Cannot Be Displayed

Posted on 2010-09-01
9
Medium Priority
?
956 Views
Last Modified: 2012-05-10
This last weekend we had a drive fail in out Exchange server. The drive was part of a RAID 5 array on which Exchange is installed. If may just be coincidental but around the same time our OWA and ActiveSync quit working as well. When you try to access OWA from internal and external, http and https, by hostname, fqdn and ip address, all users received the error below.

Internet Explorer cannot display the webpage
   
   Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.
 
   What you can try:
     Check your Internet connection. Try visiting another website to make sure you are connected.  
 
     Retype the address.  
 
     Go back to the previous page.
 
     More information

This problem can be caused by a variety of issues, including:

Internet connectivity has been lost.
The website is temporarily unavailable.
The Domain Name Server (DNS) is not reachable.
The Domain Name Server (DNS) does not have a listing for the website's domain.
If this is an HTTPS (secure) address, click tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.


I have tried many things to include removing CAS and IIS and then re-installing, running UpdateOwa.ps1 from the EMS, and anything else I thought promising from my searches here on EE.

Hopefully someone can give some insight on what would be causing this. If I do go to http://hostname I do get the standard Under Construction Page so I know IIS is running properly for basic services.

My next thought was that there could be an issue with .NET2.0 on this machine and possibly try reinstalling it.

Thanks in advance.
0
Comment
Question by:Lee Anderson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 33

Expert Comment

by:Busbar
ID: 33575058
can you remove the OWA virtual directory and create it using
get-owavirtualdirectory | remove-owavirtualdirectory
then
new-owavirtualdirectory
0
 
LVL 11

Expert Comment

by:JuusoConnecta
ID: 33575557
If you have reinstalled IIS and CAS you should have done the following as well:

Set-owavirtualdirectory
Set the existing Certificate
Configure IIS
Configure OWA in EMC
0
 
LVL 16

Expert Comment

by:uescomp
ID: 33576987
Check and see if any updates have been installed recently.  I installed an Exchange rollup update and had this same issue.  Removing the update should resolve it if this is the case.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:Lee Anderson
ID: 33586337
I have tried running:
get-owavirtualdirectory | remove-owavirtualdirectory
then
new-owavirtualdirectory
As well as:
Set-owavirtualdirectory
Set the existing Certificate
Configure IIS
Configure OWA in EMC

As far as hotfixes applied, we have Exchange 2007 SP3 (8.3.83.6) install will no Hotfixes showing in Add and Remove programs under the Microsoft Exchange Server 2007 entry.
0
 

Author Comment

by:Lee Anderson
ID: 33586354
None of the items in my previous post have resolved my issue.

Thanks for the suggestions so far.
0
 
LVL 33

Expert Comment

by:Busbar
ID: 33586379
are you sure that you are using the correct name to access the OWA, can you try from the server and use https://localhost/owa or https://servername/owa
0
 

Author Comment

by:Lee Anderson
ID: 33586809
Yes I am using the correct hostname and using localhost on the Exchange server itself.

I believe my issue may be a .NET 2.0 issue and in fact I just did the following to test this.
  1. Setup a new website on the Exchange server using port 81. Added two documents (.html and created a .aspx with the appropriate web.config file). I can open the test html page but not the .aspx page and I used version 2.0 when I established the .NET page since the Default website is set to using .NET v2.0.50727.
  2. I then moved these files to an IIS server running on my machine and set the APPPOOL to use .NET v2.0.50727 and both files run fine.
I think my next step would be to remove/reinstall .NET v2.0.50727.

Any thoughts or concerns that I should have in doing this?
0
 

Accepted Solution

by:
Lee Anderson earned 0 total points
ID: 33598566
I decided to go ahead and remove and then re-install the .NET 2.0 framework which resolved the issue. Just to recap I had already tried removing CAS and IIS and then re-installing IIS followed for CAS. Then I realized that this could be an issue with .NET. To test I created a .NET site that would not run on the Exchange server but it would run on IIS on my desktop. So below are the steps I took to re-install the .NET Framework 2.0:
  1. Uninstall .NET Framework 3.5 > 3.0 > and then 2.0 and then restarted the server.
  2. Reinstall .NET Framework 2.0 followed by the .NET 2.0 SP2 and then restarted the server.
  3. Once up and running again my ASP.NET test site worked, however it required that the default document be set back to the "default.aspx" which was also the case for all the Exchange Virtual Directories.
The OWA and Active-Sync sites started working again after performing these steps.

I do however have a problem with Free/Busy data in Outlook currently but Free/Busy data works in OWA. One problem down, one more to go. I will open another question for this though.
0
 

Author Closing Comment

by:Lee Anderson
ID: 33598581
Resolved the issue with the steps provided in my last post.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question