Solved

"The serialized data is invalid." SharePoint Search results

Posted on 2010-09-01
9
1,461 Views
Last Modified: 2012-05-10
Hello all,

SharePoint Search service is running, and indexing has been done, however, when I try to execute a search I am always getting the following error:

The serialized data is invalid.   at System.Web.UI.ObjectStateFormatter.Deserialize(Stream inputStream)
   at System.Web.UI.ObjectStateFormatter.Deserialize(String inputString)
   at System.Web.UI.ObjectStateFormatter.System.Web.UI.IStateFormatter.Deserialize(String serializedState)
   at System.Web.UI.Util.DeserializeWithAssert(IStateFormatter formatter, String serializedState)
   at System.Web.UI.HiddenFieldPageStatePersister.Load()

Any ideas?  I have seen this error all over the Internet and have tried some web.config changes but to no avail.

Thanks!
-Geoff
0
Comment
Question by:GeoffHarper
  • 5
  • 4
9 Comments
 
LVL 8

Expert Comment

by:MelMc
ID: 33579092
Do you have search customizations?

Checkout this EE question
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_23240265.html

This link suggested that you remove and re add the webpart as it may be correupt.
http://sharepointers.blogspot.com/2008/08/webpart-error-argumentexception.html

0
 
LVL 4

Author Comment

by:GeoffHarper
ID: 33579289
Thanks, but I did see those links previously.  I am a programmer and have been tasked with getting this thing working.  The Web Part is the "canned" search box which I am told gets created with the "template" page being used.
This is probably of no help, but, originally no one here could get the Search service running and I changed "Windows Authentication" to use "SA" user and password and SharePoint started up the Search service.
Besides the above, the Search box on the page is "out-of-the-box."
0
 
LVL 8

Expert Comment

by:MelMc
ID: 33579323
Have you tried dumping the current index and doing a fresh crawl?
0
 
LVL 4

Author Comment

by:GeoffHarper
ID: 33579844
Well, I don't know how to do exactly that in SharePoint, but I stopped the service and went through the "Configure Windows SharePoint Services Search Service Settings on server..." configuration with a new database name.  I still get the same error when I try the search box after all this,
I can set up the indexing schedule, but nowhere can I find anything which says the site has been indexed, or it's currently indexing the site, etc.
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 8

Expert Comment

by:MelMc
ID: 33580542
1. Open central administration

2. Select your SSP from the menu on the left under "Shared Services Administration"

3. Under the search header, select "Search Settings"

4. Within the page that loads (Configure Search Settings) you can do 1 of 2 things. Either select "Reset all crawled content" or skip this and head directly into "Content sources and crawl schedules". This is where you can fire off a new full or incremental crawl.

Did the SSP get rebuilt after you utilized a new db? Have you run the preupgrade check to make sure that it's not still associated with the old db, sometimes things can get orpahned if you don't prepare the environment for a change like that.
0
 
LVL 4

Author Comment

by:GeoffHarper
ID: 33581067
I see nothing like "Shared Services Administration" in Central Administration.  Therefore I don't see "Search Settings."
Maybe I should have said up front it's "Windows SharePoint Services 3.0" ?  I don't know if that makes a difference as to the menu (?).
I certainly appreciate your willingness to help.
0
 
LVL 8

Expert Comment

by:MelMc
ID: 33581277
That definitely makes a difference.

To reset the index, go to Central Administration -> Operations -> Services on Server. For "Windows SharePoint Services Search" click on the Stop link, wait for it to stop then click on the Start link.

http://wiki.threewill.com/display/enterprise/WSS+Search
0
 
LVL 4

Author Comment

by:GeoffHarper
ID: 33581447
Ok, so then that's what I did before (see earlier comment).  I've just done it again (and several times today) and I still get the same results.
0
 
LVL 4

Accepted Solution

by:
GeoffHarper earned 0 total points
ID: 33894353
It turned out that the machine had been configured to use the Windows security setting "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing."
By default Windows 2008 uses AES but with that setting enabled it uses 3DES.
Apparently, regardless of that setting, SharePoint 3.0 uses AES.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have just recently built a new SharePoint 2007 farm on a complete Windows 2008 R2 server platform and part of my standard build procedure is to implement a warm up routine, usually in the form of a script that is scheduled every morning to launch …
The Scenario: Let’s say you have a quote worksheet in Excel that you use to work up sales figures and such for your clients. You utilize SharePoint to manage and keep track of these documents. You would like values from your worksheet to populate Sh…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

1 Experts available now in Live!

Get 1:1 Help Now