Solved

Clipboard Redirection with Remote Desktop Services

Posted on 2010-09-01
5
1,918 Views
Last Modified: 2012-05-10
Upgrading active directory to 2008 R2, we are decommisioning obviously the old DCs.  Helpline needs to use a new set of tools off the new DCs so we made a terminal server for them and made them a custom snapin with all the MMC tools that they need.  We don't want them to log on to the server, we want them to use the RemoteApp that we set up for them.  The catch....The need to copy and paste and they can not.  

Have tried this... RemoteApp clipboard redirection:  Computer Configuration \ Administrative Templates \ Windows Components \ Remote Desktop Services \ Remote Desktop Session Hosts \ Device and Resource Redirection \ Do not allow clipboard redirection.  Disabled this GPO setting but still no go.

Yes it does work if we RDP into the terminal server but they and we don't want them to do this.

You guys and girls rock,

Thanks
0
Comment
Question by:malcatt
  • 3
  • 2
5 Comments
 
LVL 8

Expert Comment

by:SylvainDrapeau
ID: 33578934
Hello !

have you tried to kill and restart RDPClip to rebuild the clipboard chain, just in case ?

Syldra
0
 
LVL 8

Expert Comment

by:SylvainDrapeau
ID: 33579061
You don't mention what version of Windows your users are using but are you using Remote Desktop Connection 7.0 ?

Syldra
0
 

Author Comment

by:malcatt
ID: 33579387
Yes, unfortunately Clients are Still using XP SP3, will try restarting RDPClip

Thanks *
0
 

Accepted Solution

by:
malcatt earned 0 total points
ID: 33627381
http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/5c0b1609-908d-4497-9eba-9210fc988b64/#24e2e605-eab5-46db-8c30-eb4c5c51cdcd

Found the answer thanks for responses.  It was a simple.

-From RemoteApp manager click Change from RDP Settings

-From the common RDP Settings TAB, check Clipboard then apply

This should do it though some may think you may have to recreate RDP shortcut but I have the opposite to be the case.

 

RPDCLIP.exe was running though I also restarted it to verify.

interesting to note: if you edit the rdp shortcut in notepad you should see this redirectclipboard:i:1, 0 if it is not enabled

Thanks Again *

 
0
 

Author Closing Comment

by:malcatt
ID: 33627400
Found the answer thanks for responses.  It was a simple.

-From RemoteApp manager click Change from RDP Settings

-From the common RDP Settings TAB, check Clipboard then apply

This should do it though some may think you may have to recreate RDP shortcut but I have the opposite to be the case.

 

RPDCLIP.exe was running though I also restarted it to verify.

interesting to note: if you edit the rdp shortcut in notepad you should see this redirectclipboard:i:1, 0 if it is not enabled

Thanks Again *

 
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was asked if I could set up a fax machine so that incoming faxes were delivered to people's Exchange inboxes and so that they could send faxes from their desktops without needing to print the document first.  I knew it was possible but I had no id…
I had a question today where the user wanted to know how to delete an SSL Certificate, so I thought that I would quickly add this How to! Article for your reference. WHY WOULD YOU WANT TO DELETE A CERTIFICATE? 1. If an incorrect certificate was …
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question