Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Problem of copy filename with tftp on cisco switch 2950 or router 2500 serie

Posted on 2010-09-01
10
1,033 Views
Last Modified: 2012-05-10
Hi




-I'm using Hyperterminal for the console
-I'm using SolarWinds tftp server or ciscokits tftp server and ip address available is 192.168.1.111

Switch#copy running-config tftp
Address or name of remote host []? 192.168.1.111
Destination filename [switch-confg]?
%Error opening tftp://192.168.1.111/switch-confg (Socket error)
Switch#


Can you help me?

Thanks.
Francis.
0
Comment
Question by:francisbenoit
10 Comments
 
LVL 9

Expert Comment

by:pcchiu
ID: 33582415

Also what's the OS the tftp services running on?  Also make sure the firewall is not running on the computer...

try to load the fttp software to another machine and try and see if the same thing happens?
0
 
LVL 8

Expert Comment

by:Saineolai
ID: 33582434
Can you ping 192.168.1.111 from the switch?
0
 
LVL 24

Accepted Solution

by:
rfc1180 earned 500 total points
ID: 33582476
do you have a management IP configured on the switch?
Is IP enabled, interface enabled, etc?
Can you post the config?

Thanks
Billy
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 4

Expert Comment

by:andrewglendean
ID: 33583705
does you tftp computer have multipule nics?
if possible to disable the nics that are unused. Socket error to me suggests the tftp application on the pc is having the issue.

 
0
 

Author Closing Comment

by:francisbenoit
ID: 33588707
Hi,

I'm using Hyperterminal for the Console, and Pc connected to Switch by console cable.No switch interfaces connected and here is my config


Switch#show running-config                          
Building configuration...                        

Current configuration : 738 bytes                                
!
version 12.1            
no service pad              
service timestamps debug uptime                              
service timestamps log uptime                            
no service password-encryption                              
!
hostname Switch              
!
!
ip subnet-zero              
!
!
spanning-tree mode pvst                      
no spanning-tree optimize bpdu transmission                                          
spanning-tree extend system-id                              
!
!
!
!
interface FastEthernet0/1                        
!
interface FastEthernet0/2                        
!
interface FastEthernet0/3                        
!
interface FastEthernet0/4                        
!
interface FastEthernet0/5                        
!
interface FastEthernet0/6                        
!
interface FastEthernet0/7                        
!
interface FastEthernet0/8                        
!
interface FastEthernet0/9                        
!
interface FastEthernet0/10                          
!
interface FastEthernet0/11                          
!
interface FastEthernet0/12                          
!
interface Vlan1              
 ip address 192.168.1.111 255.255.255.0                                      
 no ip route-cache
!
ip http server
!
line con 0
line vty 5 15
!
!
end

Switch#copy running-config
% Incomplete command.

Switch#copy running-config tftp
Address or name of remote host []? 192.168.1.111
Destination filename [switch-confg]? switchconfig1
.....
%Error opening tftp://192.168.1.111/switchconfig1 (Timed out)
Switch#
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33588852
I am confused, is your issue resolved?
0
 

Author Comment

by:francisbenoit
ID: 33588982
Hi rfc1180,
No my issue is not resolved......
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589026
>interface Vlan1              
 ip address 192.168.1.111 255.255.255.0                                      
 no ip route-cache

why are you trying to tftp to the local switch; do you have a local tftp server on the network?

What is it that you are trying to accomplish?

Billy
0
 

Author Comment

by:francisbenoit
ID: 33589501
Expert rfc1180

Hi ,Billy

Here that I am trying to accomplish?


I want copy filename with tftp on cisco switch or router

-I'm using Hyperterminal for the console
-I'm using SolarWinds TFTP server with ip address available is 192.168.1.111 (automatically delivered)

Switch#copy running-config tftp
Address or name of remote host []? 192.168.1.111
Destination filename [switch-confg]?
%Error opening tftp://192.168.1.111/switch-confg (Socket error)
Switch#

I have many difficults of this subject, in particular the necessary architecture  to resolve this problem all this is not clear for me.

I have materially routers  and  switches and no server TFTP.On the other hand I have software server software TFTP (SolarWinds, Ciscokits) installed on my PC.

That have to I make?

Thanks.
Francis.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589524
If the tftp server is 192.168.1.111, then you will need a different Ip in the interface vlan:

interface Vlan1              
 ip address 192.168.1.112 255.255.255.0                                      
 no ip route-cache

assuming 192.168.1.112 is available, if not, choose an available IP.

Billy
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SIP / Streaming - real time communications testing 8 92
Configuring local auth. list 1 28
Best alternatives to Solarwinds 14 64
software inventory tools 3 36
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question