Solved

web access and outlook won't work - exchange server 2010

Posted on 2010-09-01
12
945 Views
Last Modified: 2012-05-10
hi - I have a question here about exchange server 2010, it is in a test environment.

server1: windows server 2003 standard SP2, exchange server standard 2003 SP2. it is a DC with a mail server on it. for sure also with dns, dhcp and wins. mail flow is fine with internal and external.

I would like to replace this server with 2008R2 and exchange 2010. so
I install a 2008R2 server, join the domain, make it a DC. then dcpromo it to a DC. then demote the server1 to a regular server. on the new DC( server2), I raise the function level of domain and forest to 2008R2. and also move the dns and dhcp to server2. at this moment, everything is still fine: internet access, user login, mail flow...

then on server2, i installed exchange 2010. I can move mailbox from server1 to server2. I can see both servers in exchange system manager.
for these mailbox still in server1, I can access them either from http://server1/exchange or from outlook 2003.
but i can not access these mailbox in server2 through https://server2/owa or outlook 2003.
I tried these moved mailbox or new created mailbox, neither doesnot work.

on the OWA, it says 'The user name or password you entered isn't correct. Try entering it again.'
on the outlook, it says 'unable to open your default email folders. The microsoft exchange server computer is not available. either there are network problems or the microsoft exchanger server computer is down for maintenance'

the exchange 2010 installation seems a straight through. i do not know why it does not let me access the mailbox, anyone can help?

thanks.
Robin
0
Comment
Question by:robinyanwang
  • 7
  • 3
  • 2
12 Comments
 
LVL 6

Expert Comment

by:PACSAdmin
ID: 33582960
Have you configured outlook web app
From EMS

Set-OwaVirtualDirectory -Identity "YOUREXCHANGE2010SERVER\owa (Default Web Site)"
-ExternalUrl "https://mail.yourexternalurl.com/owa"
-InternalUrl "https://server2/owa"
0
 
LVL 6

Expert Comment

by:PACSAdmin
ID: 33582989
From the GUI
Configure Settings on Virtual Directories
Perform the following steps from the computer that has the Exchange 2010 Client Access server role installed.
1.      In the Console tree, navigate to Server Configuration > Client Access.
2.      In the Result pane, select the Client Access server you want to configure.
3.      In the Work pane, click the tab that corresponds to the virtual directory whose settings you want to configure (Outlook Web App, Exchange Control Panel, Exchange ActiveSync), and then click the virtual directory.
4.      In the Actions pane, under the virtual directory name, click Properties.
5.      Edit any of the settings on the tabs. (If you need more information about the settings, click F1 while you're on a tab.) Common settings to be configured are:
External URL   This is the URL used to access the Web site from the Internet. The value for this URL should have been set during installation of the Client Access server role.
Authentication   You can specify a variety of authentication options, as well as specify the sign-in format and sign-in domain.
Public Computer File Access   For Outlook Web App, you can configure direct file access settings for users who choose the public or shared computer option when logging in.
Private Computer File Access   For Outlook Web App, you can configure direct file access settings for users who choose the private option when logging in.
Exchange2003URL   This parameter is only necessary when you have users with mailboxes on Exchange 2003 at the same time as users with mailboxes on Exchange 2010. In that case, set this parameter to the legacy DNS endpoint, for example, http://legacy.contoso.com.
Click OK to confirm changes
0
 

Author Comment

by:robinyanwang
ID: 33583591
thanks and will get back to you tomorrow morning.
0
 
LVL 14

Accepted Solution

by:
Kaffiend earned 400 total points
ID: 33583874
For the Outlook 2003 issue, configure the client and make sure that "Encrypt data between Microsoft Office Outlook and Microsoft Exchange Server" is checked.  (You will find this in the "Security" tab)

Or, I suppose you could (this is the opposite of a "Best Practice", btw) turn off the encryption requirement on the Exchange 2010 server.
0
 

Author Comment

by:robinyanwang
ID: 33588990
Hi, Kaffiend.

by checked the 'Encrypt data between Microsoft Office Outlook and Microsoft Exchange Server', I can access it through outlook 2003.

do you know how to turn off the 'encryption requirement on the Exchange 2010 server'?

thanks.
0
 

Author Comment

by:robinyanwang
ID: 33589342
hi, I use 'Set-RpcClientAccess –Server Exchange_server_name –EncryptionRequired $False' in EMS and i can use outlook 2003 without  checking the 'Encrypt data between Microsoft Office Outlook and Microsoft Exchange Server'

but I still can not see this through owa, I am wondering if it is a SSL issue? I tried IE 8 and chrome

in IE8, when I tried https://server2.domain.com/owa, it comes out a webiste security certificate problem warning, and I choose continue to this website, then I can see the outlook web app, but just wont let me login.

in chrome, also the same thing.

the IIS seems working, I do not know why I can not using the web access.

by the way, mail flow using outlook 2003 for these new created user in server2 is fine.
0
 

Author Comment

by:robinyanwang
ID: 33592596
updates -

I installed the SP1 and there are some requirements for iis 7. I follow the steps and got the owa up and running for login.

thanks guys.

robin
0
 
LVL 6

Expert Comment

by:PACSAdmin
ID: 33592611
Well Done,

Default install of IIS misses some key requirements for sure.
0
 

Author Comment

by:robinyanwang
ID: 33632458
hey, sorry for not closing this question.

i have a new question regarding to this exchange upgrade issue.

incoming email is now go through the exchange 2010 - server2, i modify the static route in our firewall, make the public Ip address mapping to the server2 ip address.

but looks like the outgoing email still need server1. if the server is shut down, i can not send email out (from these mailbox in server2 for sure.) I know in 2003, outgoing email is about the smtp connection.

I have a smtp 'send connector' - the default one in the 'organization configuration' 'hub transport'.  i am not sure why it still goes out through the old exchange 2003 - server1.

any suggestions? thanks.

Robin
0
 
LVL 14

Assisted Solution

by:Kaffiend
Kaffiend earned 400 total points
ID: 33632912
Check the settings on your Send Connector.

Source server: make sure the new server is listed here (and not the Ex2K3 server)
Things like address space - (should be " * ")
Make sure there is no Smart Host

0
 

Author Comment

by:robinyanwang
ID: 33642577
updates -

can not modify the default smtp one via server2

but i can create a new outbound smtp connector and add server2 in the list.

the outbound email is working now without the help of server1/

thanks.
0
 

Author Closing Comment

by:robinyanwang
ID: 33642593
thanks.
0

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now