Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

FastCGI error after upgrading to PHP 5.3.3

Posted on 2010-09-01
19
Medium Priority
?
1,407 Views
Last Modified: 2013-12-13
Server: Windows 2003 Server, IIS 6
Everything worked fine until I have upgraded from PHP 5.1 to 5.3.3 and now when I try to access a php website II get this error:

FastCGI Error
The FastCGI Handler was unable to process the request.
--------------------------------------------------------------------------------

Error Details:

•The FastCGI process exited unexpectedly
•Error Number: -2147467259 (0x80004005).
•Error Description: Unspecified error
HTTP Error 500 - Server Error.
Internet Information Services (IIS)
0
Comment
Question by:evo_x
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 4
  • 3
  • +1
19 Comments
 
LVL 9

Expert Comment

by:javajws
ID: 33583576
You need to switch to the non-thread safe version of PHP.  See:
http://forums.iis.net/p/1151022/1876417.aspx
0
 
LVL 2

Author Comment

by:evo_x
ID: 33583605
I did that, but nothing changed.
I can't find the php5isapi.dll file in the PHP distribution ZIP, also the installation did not installed that file.
0
 
LVL 9

Expert Comment

by:javajws
ID: 33583756
See the discussion here:
http://boardreader.com/thread/IIS_6_PHP_in_FastCGI_Error_0x80004005_9t83Xotyh.html

Better yet, follow Microsoft's recommendations for installing PHP at this link:
http://blogs.iis.net/donraman/archive/2009/10/07/installing-php-on-windows.aspx
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 4

Expert Comment

by:contactrobol
ID: 33583811
Use this link to install php. remove previous versions installed

http://php.iis.net/
0
 
LVL 9

Expert Comment

by:shalabhsharma
ID: 33583981
You PHP process is crashing you have to revere to earlier version (if you have backup restore it) or reinstall it again.

0
 
LVL 2

Author Comment

by:evo_x
ID: 33583985
I have uninstalled PHP and installed from php.iis.net which is an older version (5.2) but I still get the same error.
0
 
LVL 4

Expert Comment

by:contactrobol
ID: 33583991
open cmd and go to c:\php
and then type php-cgi.exe or php.exe and press enter wht messege you get ?
0
 
LVL 2

Author Comment

by:evo_x
ID: 33584016
I don't get any message, just a cursor prompt
0
 
LVL 2

Author Comment

by:evo_x
ID: 33584031
The PHP is installed in Program Files\PHP and in C:\PHP I have two DLL files ISAPI_FCGI.DLL and NSAPI_FCGI.DLL and PHP.ini
I hope this is not a problem
0
 
LVL 4

Expert Comment

by:contactrobol
ID: 33584834
add read and write permission on php folder
0
 
LVL 2

Author Comment

by:evo_x
ID: 33588214
setting the permission did not help
0
 
LVL 9

Expert Comment

by:shalabhsharma
ID: 33589297
go to command prompt
C>cd c:\program files\php
C:\program files\php>php-v

what out put it show.
0
 
LVL 2

Author Comment

by:evo_x
ID: 33589515
I don't have any file called php-v
0
 
LVL 9

Expert Comment

by:shalabhsharma
ID: 33589549
It is not a php file it will show the php version and display the error if any with php
0
 
LVL 2

Author Comment

by:evo_x
ID: 33590015
ok, I did that and the php never returns, and the file is 0 bytes
0
 
LVL 9

Expert Comment

by:shalabhsharma
ID: 33590136
Which file with 0 bytes you refering?

I assuming that your php path is c:\program files\php

I will suggest you to Install PHp from the begining

delete PHP folder from C:\PHp and c:\program files\php
delete any php.ini from windows\system32

Configure the php using any one URL as per your choice.
http://www.visualwin.com/PHP
or
http://www.iisadmin.co.uk/?p=4
0
 
LVL 2

Author Comment

by:evo_x
ID: 33590177
the output file is 0 bytes php-v
ok,I will try that
0
 
LVL 2

Author Comment

by:evo_x
ID: 33590539
ok, I did that (also re-installed the FastCGI) but now I get page not found when I try to access the php site.
The problem is not in the PHP installation, but in FastCGI settings,I don't have php5isapi.dll file !

Here is a list of server modules shipped with PHP 5:

     * sapi/php5apache2_2.dll - Apache 2.2.x module.
     * sapi/php5apache.dll (php5apache.dll) - Apache 1.x module
     * sapi/php5apache2.dll (php5apache2.dll) -  - Apache 2.0.x module.
     * sapi/php5isapi.dll - ISAPI Module for ISAPI compliant web servers
       like IIS 5.0 or newer. However the FCGI SAPI is recommended with
       IIS

I can't find any of these files in the PHP installation !
0
 
LVL 2

Accepted Solution

by:
evo_x earned 0 total points
ID: 33590773
I have followed this tutorial to configure fastcgi and now it works :)
http://learn.iis.net/page.aspx/247/using-fastcgi-to-host-php-applications-on-iis-60/
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lync server 2013 or Skype for business Backup Service Error ID 4049 – After File Share Migration
This article discusses four methods for overlaying images in a container on a web page
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will learn how to create a basic form using some HTML5 and PHP for later processing. Set up your basic HTML file. Open your form tag and set the method and action attributes.: (CODE) Set up your first few inputs one for the name and …
Suggested Courses

597 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question