Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1528
  • Last Modified:

Infopath forms - Do you want to allow redirection?

Gday Everyone,
I have created some forms for use in IT for new accounts, security changes etc in Infopath.
All of the forms have a connector to Sharepoint Server (does not have forms services), to pull down their information to autopopulate some fields. Then it also contains a drop down list of managers names for authorisation.
Problem is on all computers (except mine where forms were made), there is a pop-up before opening the form (as attached)
Warning: This form is attempting to redirect itself to a potentially unsafe location
xxxx .....
Do you want to allow redirection?

It is all on the same Domain and has been published to the server it is trying to "redirect itself to".
I am a little lost. Any help would be great
Untitled-1.jpg
0
LWBIT
Asked:
LWBIT
  • 2
  • 2
1 Solution
 
melli111SharePoint Administrator / DeveloperCommented:
You need to setup your form as "Full Trust"  (in Tools > Form Options).  You also need to sign your form with a coding-signing certificate.  Then your users will receive a different message (just the first time they use this form after the change) that allows them to choose "trust all documents from this publisher"
0
 
LWBITAuthor Commented:
Is there no other way to get around this? No Intranet IE settings that can be tweaked. Really don't want to have users seeing any pop-ups as being the Service Desk Team leader I can see us getting hammered with really annoying calls...
0
 
Clay FoxDirector of Business IntegrationCommented:
You should not need full trust, you should be able to have domain trust, however you need to make sure that the url's of the data connections and sharepoint server need to be explicitly put into you local intranet or trusted security zones in IE.  Play with this but that should work.
Otherwise getting a cert from your domain and signing the forms works, the user just has to trust your cert once.
0
 
LWBITAuthor Commented:
Hi Clay,
What is strange is that on my computer it works fine (I created the forms), however everyone else it does not work.
We all have the same secrutiy settings in IE and the same zone assignments.
Our sharepoint server and the location where the forms are posted are all apart of 10.30.*.* which is a trusted zone...
Any reason why it is working on mine and not anyone elses?

Cheers
0
 
Clay FoxDirector of Business IntegrationCommented:
One thing, looking at the error, you are publishing the form weird, instead of an http: it is doing a file to the IP. So I think the issue is not the SharePoint data connection but the actual publish location.
Why are you not using the name of SharePoint?

Why are you not publishing to a library?
My guess is that the syntax of your security is not matching what it was published with.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now