Solved

Windows Server 2008 R2 remote desktop  user login problem

Posted on 2010-09-01
7
1,069 Views
Last Modified: 2012-05-10
I had few users that used to log in into the server machine running a special program with remote desktop connection. Everything worked fine until i installed on the server Active Directory so i can assign private folders to the users and i added them to the domain controller under active directory. At installation active directory asked the remote connection license server to be restarted which it did. After reboot the users can't log in anymore with remote desktop connection. I verified if they are members of the remote desktop connection and they are. When they log in they get the attached screen.


Untitled.png
0
Comment
Question by:dexter40000
  • 4
  • 2
7 Comments
 
LVL 5

Expert Comment

by:helpnet
ID: 33583720
Open a console with Active Directory users and computers, create a group for the users that need access to terminal services on the domain controller, and add the users.

Go to the container where Domain controller is and open the default domain controllers policy.

Security Settings | Local Policy | User Rights Assignment.

Find the setting, allow logon through terminal services, and add the group you created above.

Make sure they do not have the right to Shutdown the system.
0
 
LVL 5

Accepted Solution

by:
helpnet earned 250 total points
ID: 33583726
Other rights may need to be added depending on the requirements of the application theyare running through terminal services.
0
 
LVL 3

Expert Comment

by:dontseme
ID: 33583727
Have you check the user account properties in AD to allow remote login?
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:dexter40000
ID: 33583864
how do i get to 'Security Settings | Local Policy | User Rights Assignment.' ?
0
 
LVL 5

Expert Comment

by:helpnet
ID: 33586871
Sorry the location for group policies has changed in Server 2008.

Click on Start | Administration Tools | Group Policy Management

In the console that opens

Expand Forest, Expand the Domain, and go to group policy objects.

Open the Defaul Domain Controllers Policy.

In here it is
Computer Configuration\Windows Settings\Local Policies\User Rights Assignment

And on Server 2008 it is "Allow log on through Remote Desktop Services" that you need to change.
0
 
LVL 5

Expert Comment

by:helpnet
ID: 33586904
Terminal Services = a type of RDP (Remote Desktop Protocal) service.
0
 

Author Comment

by:dexter40000
ID: 33588141
found it  at the end.

Thank you
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This article shows how to deploy dynamic backgrounds to computers depending on the aspect ratio of display
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question