application pool needs to be restarted always


i have a problem with my web application, it always fails because of the application pool time out

my web application is accesses by many users

i use windows 2003 as a host server

please answer me urgently
Who is Participating?
Jerryuk007Connect With a Mentor Commented:
Did you do an "iisreset /restart"? Sometimes this helps...

Am I correct in assuming that you are using MSIIS 6?

Go to the AppPool properties, and check the box "recycle worker process" and set in to 12000
Go to the Performance Tab and check the box "Shutdown worker process..." and set it to 10 minutes.
What is the value of "Max number of worker processes"? If 1, consider increasing it to 3 to see if that makes a difference. If above 3, consider reducing it...

On the "Health" tab, check the box "enable rapid-fail protection" and allow 20 errors in 5 mins.

Change the Startup and shutdown Time Limit to 120 instead of the default of 90.

On the Identity tab, I would recommend to use a proper Domain Account and not something like "Network Service" if possible.

Hope this helps.

StephanLead Software EngineerCommented:
I have a feeling somewhere in your application is a giant leak/bug that causes the pool to overflow and fails. (maybe an endless loop?)
Create a new application pool for websites and configure web-garden for this new pool.
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Did you check the event Log for what is the cause of the timeout?
Check the ApplicationPool Settings.
By default, it would be configured to recycled every 29 hours... I often change this to recycle every 12 Hours instead or sometimes I just force it to recycle out of normal Office Hours at night.

It's also better to have a separate ApplicationPool by Web Applications.
If you have a Web Application with a Web.Config, and under it another folder which also contain a Web.Config, I would recommend to put the sub-folder in a separate ApplicationPool as it causes sometimes unexpected results.

Check the IIS Logs for your Web Application. It should give you some clues as to what is taking "too long" (if the duration column is not there by default, add it first of course).

Hope this helps.

spirit32Author Commented:
i put it in a seperate qpplication pool but still works for a while and stop, and sometimes it runs by itself again

"Timeout expired.  The timeout period elapsed prior to obtaining a connection from the pool.  This may have occurred because all pooled connections were in use and max pool size was reached. "

this is the error i get when this problem happens

i put the recycle time at 100 mins and still not fine

the server is a little bit old maybe this what makes the problem ?

spirit32Author Commented:
Jerryuk007: i put the app pool setting as you suggested, lets see what will happen

thanks all
Any news?

spirit32Author Commented:
it is fine now,

sorry for being late for the answer
James MurrellProduct SpecialistCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.