• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 488
  • Last Modified:

Problem with search field in Windows 7 Start Menu

Dear all,

I have a problem that my search field in the windows start menu is not longer working.
It returns only categories but no results:
 screenshot
and if I select one of them I get the following error message:

[Window Title]
Windows Security

[Main Instruction]
These files can't be opened

[Content]
Your Internet security settings prevented one or more files from being opened.

[Expanded Information]
Programs

[V] Show details  [Close]

[Footer]
Why can't these files be opened?
0
taz112
Asked:
taz112
  • 5
  • 5
1 Solution
 
Willy Van den HoutenNetwork and Security AssistantCommented:
Did you try a system restore ?
0
 
TimAllanCommented:
I had the same issue
The problem is a permissions one so heres what i did.
1. go to my computer and right click your c drive and go to properties,
uncheck the bottom box: allow files on this drive to blah blah.
click apply and wait for windows to complete the update of your files it mat take a few minutes.

2.  go to the security tab of the properties window,select your useraccount/name and click advanced.
click the owners tab ( your account will already appear) click edit
in the opened window select your account and check the box : replace owner on subcontainers blah blah and click apply and ok
this aslo will take a few minutes. once done close all windows

3. Click your start button/orb and in the search pane type folder options and hit enter,
click on the search tab
in the "what to search) field check the bottom box : always search the names and contents etc
in the "how to search" field check the top two boxes ONLY:
i:include subfolders in search etc and
find partial matches.
in the "when searching non indexed locations" field select the top box: include system directories.
click apply and ok.

4. Click your start button/orb and in the search pane type indexing options and hit enter,
click "modify" and check all items you want to be able to search in and click "ok".
click "advanced"
click the file types tab
check the : index properties and file contents box.
click the index settings tab,
click rebuild. clcik ok.
exit all windows.
restart your system and give it ten minutes to rebuild the index the search away.
notes:
if you still have no results or some results but not all

5. go to my computer and open your c drive select all folders and right click select properties,
(do not select any hidden folders) check the read only box and click advanced check
the top option only: check folder is ready for archiving.

some of these settings may already be correct on your system if so go through all steps
0
 
taz112Author Commented:
Thank you, I followed all steps, but without success. I have still the same problem.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Willy Van den HoutenNetwork and Security AssistantCommented:
Click  the Start button, click Control Panel, click Programs, and then click  Turn Windows features on or off. If you are prompted for an  administrator password or confirmation, type the password or provide  confirmation.
To turn on a Windows feature on, select the check box next to the feature (in this case Windows Search). Click ok.

Find the Windows search feature, if already on, turn it OFF.  Reboot.

Repeat the steps above to turn it back on.  Reboot again.

0
 
taz112Author Commented:
This did not help, too :-(
0
 
Willy Van den HoutenNetwork and Security AssistantCommented:
If you're having problems locating specific files, folders, or other  items on your computer, try using the Search and Indexing troubleshooter  to fix the problem. It makes sure that the Windows  Search service is running, and checks to see whether you have the  correct permissions to search all the directories on your computer.
0
 
Willy Van den HoutenNetwork and Security AssistantCommented:

This  issue can be caused if an invalid registry key for the Start Menu  grouping values gets written to the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}\TopViews\{00000000-0000-0000-0000-000000000000}
 
The incorrect registry value is the GroupBy value,  the  incorrect value is most often “System.Null” but can appear as other  values. The correct value should be “System.StartMenu.Group”
 
You can resolve the issue by follow one of the methods below:
 
Method 1: Delete the entire key:
To browse to and delete the registry key follow the steps below:
 
1.       Click Start
2.       In the Search programs and files box, type regedit
3.       In the Programs list, click regedit.exe
 If you are prompted for an administrator password or confirmation, type the password or click Continue.
4.       Browse to and click to select the following registry subkey:
5.       HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}
6.       In the left side of the window right-click GroupBy and click Modify
7.       Change the value to System.StartMenu.Group and click OK, then close the registry editor
 
You'll need to reboot your computer for this change to take effect.
 
Method 2: Add the correct value of GroupBy value:
Follow the steps below to add the correct value to the GroupBy value:
 
1.       Click Start
2.       In the Search programs and files box, type regedit
3.       In the Programs list, click regedit.exe
 If you are prompted for an administrator password or confirmation, type the password or click Continue.
4.       Browse to and click to select the following registry subkey:
5.       HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}\TopViews\{00000000-0000-0000-0000-000000000000}
6.       In the left side of the window right-click GroupBy and click Modify
7.       Change the value to System.StartMenu.Group and click OK, then close the registry editor
 
You'll need to reboot your computer for this change to take effect.
0
 
taz112Author Commented:
neither the troubleshooter found anything nor the registry key is incorrect
0
 
Willy Van den HoutenNetwork and Security AssistantCommented:
this worked for XP, I wonder if it will work for 7

Put your Genuine Original Windows DVD inside

into command prompt : sfc /scannow


0
 
taz112Author Commented:
The command ran for about 2 hours but did not solve the issue, too...
0
 
taz112Author Commented:
Finally I found the solution:

http://support.microsoft.com/kb/977380/en-us/
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now