Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Goldsync service crahes on server during sync

Posted on 2010-09-02
5
Medium Priority
?
1,162 Views
Last Modified: 2013-11-15
Two remote users have this problem.  The sync process starts out fine but fails in the end and stops the goldsync service on the server.  I uninstalled and installed the service again (from GM) but that doesn't fix the problem.  The other 4 users are able to complete the sync just fine.

Both are showing the same error.  Goldmine version is 7.5 (recent upgrade from 7.0)

First remote user (part of log):

0[2-0] Downloading file: TSAA0388.gts (54K bytes)...
1[2-0] Tsaa0388.Gts downloaded successfully.
0[2-0] Downloading file: TSAA0389.gts (5K bytes)...
1[2-0] Tsaa0389.Gts downloaded successfully.
0[2-0] Downloading file: TSAA0390.gts (71K bytes)...
1[2-0] Tsaa0390.Gts downloaded successfully.
3[2-0] WaitOnSocketLine() failed.
3[2-0] sData did not start with '+FILE'
3[2-0] Tsaa0390.Gts download failed.
3[2-0] Lost connection with remote.
0[2-0] Sync Task  [Ended 8:22 am - 9/2/2010; Dur: 1:46]
0[1] Sync-Wizard Process  [Ended 8:22 am - 9/2/2010; Dur: 1:46]

Second user:

0[2-0] Uploading file: TSAA0008 (4K bytes)...
1[2-0] TSAA0008 uploaded successfully.
0[2-0] Uploading file: TSAA0009 (3K bytes)...
1[2-0] TSAA0009 uploaded successfully.
0[2-0] Uploading file: TSAA0010 (4K bytes)...
1[2-0] TSAA0010 uploaded successfully.
0[2-0] Remote is creating transfer set...
0[2-0] Receiving  transfer set(s)...
0[2-0] Downloading file...
0[2-0] Downloading file: TSAA0004.gts (194K bytes)...
1[2-0] Tsaa0004.Gts downloaded successfully.
0[2-0] Downloading file: LDAA0004.gts (15K bytes)...
1[2-0] Ldaa0004.Gts downloaded successfully.
3[2-0] WaitOnSocketLine() failed.
3[2-0] sData did not start with '+FILE'
3[2-0] Ldaa0004.Gts download failed.
0[2-0] Ending connection...
0[2-0] Sync Task  [Ended 10:56 am - 9/2/2010; Dur: 2:41]
0[1] Goldmine IMI  [Ended 10:56 am - 9/2/2010; Dur: 2:42]
0
Comment
Question by:rwottowa
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 12

Expert Comment

by:GMGenius
ID: 33588459
This has happened to me on a GoldMine PE install.
The issue was the remote user was on the wrong version, and this caused the service to crash and then that broke the connection for all other users giving the same error your seeing.
I suggest you check all remote users Help > About and make sure they are all the same version as the server.
0
 

Author Comment

by:rwottowa
ID: 33589334
Thanks for the tip, I'll check with the users.
0
 

Author Comment

by:rwottowa
ID: 33666345
All remote users are on the same version.
0
 
LVL 12

Accepted Solution

by:
GMGenius earned 2000 total points
ID: 33669868
Try running sync using a shortcut instead, turn of the service for a while so you can monitor
Create a copy of the GoldMine shortcut and alter it as follows
....gmw7.exe /u:user /p:password /s:goldsync
set your GoldMine sync user and password
Then run it, you will be able to right click on the idon in the system try and open the process monitor
Watch what happens and copy the logs here if you see anything odd
0
 

Author Comment

by:rwottowa
ID: 33703977
We have been running Goldsync as an application for a few days.  Besides a few errors at the beginning, now all the remote databases are synching correctly.  So it definitely seems there is something wrong with the Goldsync service that isn't fixed when it is re-installed.

I must mention we have been having issues with the server for a while.  Because of memory leaks, it needs to be rebooted every night.  This never seemed to affect the Goldsync but perhaps it had to do with the upgrade from 7.0 to 7.5.

I definitely like to be able to see the Goldsync process on the screen, as described in your previous post.

I think we are good for now until we can move Goldmine to a new server soon.  The only thing that needs to be done is restarting the Goldsync application after each reboot.

Thanks GMGenius!  Never would have figured this out without you.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I showed you how to use console view (HERE (http://www.experts-exchange.com/articles/18379/Getting-Started-and-Using-the-Salesforce-com-Console.html)) -– but how do you set it up on the admin side of Salesforce? Note that you have to have Admin leve…
Salesforce.com is a cloud-based customer relationship management (CRM) system. In this article, you will learn how to add and map custom lead and contact fields to your Salesforce instance.
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question