Solved

cisco 2900 x series unable to ping

Posted on 2010-09-02
32
394 Views
Last Modified: 2012-05-10
I'm unable to ping this switch is there something missing in the config file?

here is the current configuration:

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Switch
!
enable secret 5 $1$7qhU$vlXkU9VUkuillnoFFHv5Y/
enable password 7 051E0E002E5C460C1C
!
username pbutler privilege 15 password 7 10590D4C060719
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
 spanning-tree portfast
!
interface FastEthernet0/2
 spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface VLAN1
 no ip directed-broadcast
 no ip route-cache
!
interface VLAN2
 ip address 192.168.2.10 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password 7 105B01160A071A0E09
 login local
line vty 5 15
 login
!
end

Switch#

I think I'm missing the gateway here and I would like to access it via http

what config changes do I need and how do I make them

Thanks
0
Comment
Question by:cp361
  • 18
  • 14
32 Comments
 

Author Comment

by:cp361
ID: 33588537
Forgot to mention other devices are reachable on the 192.168.2.x subnet vlan2
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589049
try:
interface VLAN2
no shutdown
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589058
you are also going to need to add the switchports to that vlan as well:

interface FastEthernet0/1
switchport mode access
switchport access vlan 2



0
 

Author Comment

by:cp361
ID: 33589059
Ok I will run accross the street and give it a try...
0
 

Author Comment

by:cp361
ID: 33589089
rfc1180:
this switch is actively running and supporting some critical devices. By doing:
interface FastEthernet0/1
switchport mode access
switchport access vlan 2

This won't take my network down? And does
"interface FastEthernet0/1" refer to port 1? what if something is plugged into it
that won't cause a problem will it?

Thanks
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589104
please post:

show int status

Billy
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589111
if all your interfaces are on vlan 1, then move the Ip to vlan 1 interface:

interface VLAN1
 ip address 192.168.2.10 255.255.255.0
 no ip directed-broadcast
 no ip route-cache

Billy
0
 

Author Comment

by:cp361
ID: 33589136
I think vlan2 is the one being used 1)because the config file shows 192.168.2.10
as the IP of switch and ping I do 'angry ip' (ipscan) of the subnet 192.168.2.1 -255 I'm able to ping and telnet into some of the devices connected to the switch.

0
 

Author Comment

by:cp361
ID: 33589188
Ok I will post int status in just a sec have to run accross the street
0
 

Author Comment

by:cp361
ID: 33589288
here is the 'sh int vlan1 and vlan2'

Switch#show int vlan1
VLAN1 is up, line protocol is up
  Hardware is CPU Interface, address is 0001.4247.3400 (bia 0001.4247.3400)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:12, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 1000 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     10117725 packets input, 2866708192 bytes, 0 no buffer
     Received 10117725 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     550209 packets output, 188170641 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Switch#show int vlan2
VLAN2 is administratively down, line protocol is down
  Hardware is CPU Interface, address is 0001.4247.3400 (bia 0001.4247.3400)
  Internet address is 192.168.2.10/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  ARP type: ARPA, ARP Timeout 04:00:00
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589305
i need:

show int status

Thanks
0
 

Author Comment

by:cp361
ID: 33589335
sec
0
 

Author Comment

by:cp361
ID: 33589398
this is what I get if I don't specify 'valn'

Press RETURN to get started.







Switch>show int status
                    ^
% Invalid input detected at '^' marker.

Switch>enable
Password:
Switch#show int status
                    ^
% Invalid input detected at '^' marker.

Switch#
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589434
what type of switch is this, 2950?
0
 

Author Comment

by:cp361
ID: 33589439
2900 x series
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589446
as vlan1 is up,

just add the ip to vlan 1:

interface VLAN1
 ip address 192.168.2.10 255.255.255.0
 no ip directed-broadcast
 no ip route-cache


see if that works:

This will not cause the network to go down (assuming .10 is not used on your network)

Billy
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:cp361
ID: 33589471
Ok running back across (spelled correctly this time) the street to give a try. It is a beautiful day here in Woodinville ,Wa so it is nice to get out
0
 

Author Comment

by:cp361
ID: 33589513
Ok finished have a steady Ip from my PC and still no love no ping response
0
 

Author Comment

by:cp361
ID: 33589520
steady ping that is to that ip address
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589543
what port is plugged into the 2900.
what IP are you pinging from?
Also it would be nice to know the make/model (show int status should have worked); please post:
show version

Billy
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589561
sorry, what port is the PC (The system you are pinging from) plugged into the 2900.
0
 

Author Comment

by:cp361
ID: 33589589
my PC is showing

10.1.98.18
255.255.0.0
10.1.2.1

and just a note I can ping every other device connected to that switch.

I ran over to the other bldg and the config change did not take do you think it has anything to do with the fact that both Vlan1 and Vlan2 will have the same address if I were sucessful and configuring vlan1 to 192.168.2.10?
0
 

Author Comment

by:cp361
ID: 33589624
simply put I'm not using any port on the 2900 to ping to/from
the only thing I'm connected with is the management cable to a laptop in order to configure the device
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589630
yea, so you do need a gateway, I just assumed that the PC was directly connected to the switch

do you have a network diagram that depicts your network. You will need to set:

ip default-gateway x.x.x.x

A router that handles routing for your 10.1.0.0/26 network
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589639
10.1.0.0/16 rather
0
 

Author Comment

by:cp361
ID: 33589693
Ok so when I find the gateway I will do the following

no interface vlan1
interface VLAN1
ip address 192.168.2.10 255.255.255.0
ip default-gateway x.x.x.x
no ip directed-broadcast
no ip route-cache

does this look correct?
0
 
LVL 24

Accepted Solution

by:
rfc1180 earned 250 total points
ID: 33589710

no interface vlan2
interface VLAN1
ip address 192.168.2.10 255.255.255.0
no ip directed-broadcast
no ip route-cache
exit
ip default-gateway x.x.x.x
exit
wr mem
0
 

Author Comment

by:cp361
ID: 33589799
Ok sounds good I will track the gateway down and update here after lunch

thanks again
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33589803
yeah, me lunch too!

Good luck
0
 

Author Comment

by:cp361
ID: 33590449
OK I think this will work if I can determine the gateway so I will go ahead and close this..

Thanks for your help

Best

Dana
0
 

Author Comment

by:cp361
ID: 33590637
Was able to test with a gateway of 192.168.10.1 and all is well
I can telnet and http to the switch life is good!
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33590645
Nice! Glad to hear

Billy
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Article by: IanTh
Hi Guys After a whole weekend getting wake on lan over the internet working, I thought I would share the experience. Your firewall has to have a port forward for port 9 udp to your local broadcast x.x.x.255 but if that doesnt work, do it to a …
Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now