Quickbooks 2009 not using default email address

Just upgraded from Office 2007 to 2010. We use numerous email addresses in the office. We use a SBS 2008 server, but just have Exchange set as a .local. Default address is set to use company external address. We just use Exchange for storage and calendaring mainly. Quickbooks would use in Outlook 2007 whatever we had set as our default address to email. Now with the 2010 upgrade it always defaults to trying to use the .local address of the Exchange user. We manually change it no big deal, but I'm going to encounter this issue with some of my accountant clients when they upgrade MS Offfice, so looking for answers now.
Who is Participating?
MONSTA2008Connect With a Mentor Commented:
Make note of the following from Intuit.

Currently, QuickBooks is not technically designed to work with Office Outlook 2010.

When you email or edit the email preference through QuickBooks, you receive one of the following errors:

You must choose a profile first to use Outlook to send email.
There is no option to select Outlook in the Send Forms tab in Preferences.
Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client.

warsawtechConsultantAuthor Commented:
Thanks, I stumbled across that later on Google. Seems my whole setup isn't suppose to run with things the way I have them. QB 2009 data on 64bit SBS server, QB running on Windows 7 Pro and Office 2010. I'm doomed, but things are working otherwise. Guess I'll wait till QB 2011 comes out the upgrade.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.