Link to home
Start Free TrialLog in
Avatar of Nana Hemaa
Nana HemaaFlag for United States of America

asked on

IIS7, Windows standard 2008, 404error

Upgraded to Win 2008 and IIS7, and I get the following error message.
404 - File or directory not found
It works fine with IIS 6 on Win 2003 server
I do not get the same error when I browse the site from the server?   I only get the error when I browse from client PC.
The file that I am looking for exists.  Any inputs?
Avatar of Brad Howe
Brad Howe
Flag of Canada image

Things we can try to find out what is happening.
First enable Detailed error logging and browse locally. I would guess the extention is denied.


1.  Recreate a new Virtual Host. This may correct your settings if the host was configured before .net was added.

2. In order to configure IIS 7.0 to serve .aspx pages, you must install the ASP.NET feature for IIS 7.0.  To install  ASP.NET, Go to Control Panel/Programs and Features, then select "Turn Windows Features On or Off". Once you're into the Windows Features interface, navigate to Internet Information Services | World Wide Web Services | Application Development Features | ASP.NET and make sure it is checked and click OK.

3. Enable Static and Dynamic Content. Once you're into the Windows Features interface, navigate to Internet Information Services | World Wide Web Services | Common HTTP Features and ensure that "Static Content" is checked.
  * Note that the "static content" service is responsible for serving the Static contents like images, scripts , style
    sheets file, .... Sometimes know for causing 404 errors.

MORE TROUBLESHOOTING If the above fails.

4. Disable IE "Friendly HTTP Error Messages"
Go to “Tools > Internet Options”, choose the Advanced tab, and clear the “Show friendly HTTP error messages” checkbox.  Then, close the browser, open it again, and re-request the page.

5. Detailed error logging
http://learn.iis.net/page.aspx/267/how-to-use-http-detailed-errors-in-iis-70/
Try the following. From IIS Management, selecting your website/application/virtual directory in the left-hand tree view, clicking on the “Error Pages” icon, clicking “Edit Feature Settings” action, and then selecting “Detailed Errors”.

6. Failed Request Tracing
http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis-7/
Requires - Tracing (under World Wide Web Services - Health and Diagnostics - Tracing)

Hope it helps us diagnose further. Let us know.

Cheers,
Hades666
Avatar of Nana Hemaa

ASKER

will try but I am serving coldfusion pages
then it sounds like you are missing the .cfm mime type to have IIS server them. The detailed error logging will give you the full issue.  - Hades666
the .cfm mime type is there.  "I get file not found "for details But the file is there.  I copied the same folder to c:\inetpub\wwwroot\CFIDE  and I am able to browse ok from the server as well as client pcs.  
so:::

c:\inetpub\wwwroot\CFIDE\FolderA\index.cfm               ---------      works fine
http://Testserver1/CFIDE/FolderA/index.cfm                   ---------      works ok from client pc

but get error  404 - File or directory not found --when I place folderA anywhere else on the server
c:\inetpub\wwwroot\TestSites\FolderA\index.cfm         ---------.    gives the 404 error
http://Testserver1/TestSites/FolderA/index.cfm               -------    gives the 404 error

Also,
I am also able to browse the admin site ok from server and client pc  as well
http://Testserver1/CFIDE/administrator/index.cfm

Any inputs appreciated.  pulling my hair on this
Hi,
Could you post the detailed error report please. IIS7 has this built in. Place a blank .cfm file in a different root and browse the site. Post the results here.
I am willing to bet this is a script mapping error.
Best Regards
-Hades666
http://Testserver1/CFIDE/blank.cfm ---- works fine

What is special about CFIDE.....when I copy the folders into this specific folder everything works fine. Maybe this can give a clue.... FYI this is a developer version.  I am not sure if this permission issue

I place blank.cfm in another folder Test and get error below.----
http://Testserver1/Test/blank.cfm
--------------------------------------------
The web site you are accessing has experienced an unexpected error.
Please contact the website administrator.

The following information is meant for the website developer for debugging purposes.

Error Occurred While Processing Request
File not found: /Test/blank.cfm


Resources:
Check the ColdFusion documentation to verify that you are using the correct syntax.
Search the Knowledge Base to find a solution to your problem.


Browser Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; GTB6.5; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322; InfoPath.2; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Remote Address XX.X..XX.XX
Referrer
Date/Time 14-Sep-10 10:00 AM

Stack Trace (click to expand)


Please post the following.
1. Open IIS Manager, In the connection pane, select SITES then your website. Provide screenshot of your Handler Mappings, MIME Types for .cfm files.
2. Browse to http://Testserver1/Test/blank.cfm and provide the IIS log entry %systemdrive%\inetpub\logs\logfiles\<SITEID>. I want the sub status code as well.
3.  Install ISAPI Extentions and IIS Metabase and IIS6 configuration compability.
Lastly, you have not provide the Coldfusion version you have installed? And when you installed it, did you have the above modules added before?
I would install the above modules and RE-RUN the "Add Web Server configuration Utlity"
Let us know,
-Hades666

 
pls. see attachment.  
--can you pls show how to.  Should they have been automatically installed with CF 9.
3.  Install ISAPI Extentions and IIS Metabase and IIS6 configuration compability.

Cold fusion 9 is the  version
MIMETypes.docx
Under Server Manager, select Roles and then Web Server (IIS)
Right Click and select "Add Role Services"
Make sure Application Development\ISAPI Extentions and Management Tools\IIS6 Management Compatibility\IIS6 Metabase Compatibity are checked. If they are not, please check them to install.
Next, open START Menu and chose Macromedia\ColdFusion9\Web Server configuration Utlity
Run the configuration and try again.
cheers,  Hades666
Hi,
This can happen IF you installed CF after IIS and missed those modules or the Utility was not run to configure CF extentions server-wide.
Configure IIS for CF
Start ,Programs ,ColdFusion 9, Web Server Configuration Tool.
Click Add.
In the Server pop-up menu, select the host name and the server or cluster name to configure.
In the ColdFusion server configuration, the server name is always coldfusion.
In the Web Server Properties area, select IIS and specify the website. For the entire IIS Server, you specify All.
Select the Configure web server for ColdFusion applications option, and click OK.

 Let us know, Hades666
Opps. wrong image. LOL
-Hades666

image-thumb-2-.png
I did all that right after installation so I am good on that.  i just double checked and everything still looks good.
Sorry. What looks good? cfm files are compiling and loading now? - Hades666
no.. I meant I did all that already.  cfm files are compiling and loading good on the server itself as always but cfm files cannot load and compile ok when I browse from client pC.--on the actual server everything works great.
In and outside of ALL virtual paths. - Hades666
not sure what you mean by In and outside of ALL virtual paths  but ..

http://Testserver1/Test/blank.cfm  works fine on the server  with iis and coldfusion(installed on) but gives 404 file cannot be found error when I browse  the same from any pc on the network
Check the IIS W3SVC log for this site and post the error and sub status code.
I am looking for 404.4 404.1 404.3 etc...
 
Hades666


2010-09-14 14:27:40 XX.XX.XX.XX GET /blank.cfm - 80 - xx.xx.xx.xx Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.5;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET+CLR+1.1.4322;+InfoPath.2;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3) 500 0 0 296
2010-09-14 14:29:57 XX.XX.XX.XX GET /blank.cfm - 80 - xx.xx.xx.xx Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.5;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET+CLR+1.1.4322;+InfoPath.2;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3) 500 0 0 62
2010-09-14 14:37:03 XX.XX.XX.XX GET /blank.cfm - 80 - xx.xx.xx.xx Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.5;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET+CLR+1.1.4322;+InfoPath.2;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3) 404 0 0 2578
ASKER CERTIFIED SOLUTION
Avatar of Brad Howe
Brad Howe
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
just found something..in app log

the binding XX.XX.XX.XX:80 is assigned to another site.  if you assign the same binding to this site you will only be able to start one site....

so it looks like it is looking at another exisitng site whose binding has been assigned to the ip address of the server ----this causing the file not found error

how can the 2 different sites use the same ip address of the server
got it fixed
AH... .
ColdFusion has its own web server that you can use to develop ColdFusion applications. This is the J2EE Server. I think you should remove CF and re-run the installer again.
Chose Server Configuraiton, enter your Key, Install for IIS Websites, (Now that you have the required modules isntalled) and try again.
Simple test, Create a "Index.cfm" and place it in your web root C:\wwwroot or whatever yours is.
<cfscript>
    writeDump(server):
</cfscript>
Browse to it and you should see Server Info.
-Hades666

ee1.GIF
ee2.GIF
Excellent. What did you do? -Hades666
thx