[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

How do i remove hptrr from FreeNAS (FreeBSD)

Posted on 2010-09-02
10
Medium Priority
?
1,411 Views
Last Modified: 2013-11-22
I have found a few posts like: http://webcache.googleusercontent.com/search?q=cache:i6oaW3QIjdUJ:sourceforge.net/apps/phpbb/freenas/viewtopic.php%3Ff%3D38%26p%3D14493%26st%3D0%26sk%3Dt%26sd%3Da+disable+hptrr&cd=2&hl=en&ct=clnk&gl=uk

Referring to: http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig-building.html

But i can't seem to find the /usr/src

I have FreeNAS 7.2 installed (and i'm confident i chose the full install options).

Hope you can help!

Thanks
L
0
Comment
Question by:tickett
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 
LVL 62

Expert Comment

by:gheist
ID: 33595073
Get FreeNAS customized kernel sources, build kernel without hptrr

But normally it causes no problems unless broken device is present.

I do not know much about FreeNAS but on normal FreeBSD you can use "dmassage" to leave only kernel drivers present in system.
0
 
LVL 11

Author Comment

by:tickett
ID: 33596771
Sorry- i should have given a bit more information but i posted yesterday when my laptop battery had about 30seconds remaining :)

I have 2x AOC-SAT2-MV8 (8 port, supermicro sata controller) which is incorrectly detected by the hptrr driver. After some google research it appears i can fix this by removing/disabling it.

I've seen the posts i highlighted about which are very similar to your "get the kernel source + build without hptrr" but i'm fairly newbish when it comes to *nix/bsd... so I really need step by step on the commands and what i need to download from where?

Thanks

L
0
 
LVL 62

Expert Comment

by:gheist
ID: 33597559
Only OpenBSD has "config" tool to permanently edit kernel image.

I am unsure if FreeNAS has same boot chain, but on factory FreeBSD you can disable device:
http://www.freebsd.org/cgi/man.cgi?query=loader&sektion=8

And please report a bug to FreeBSD
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Author Comment

by:tickett
ID: 33723509
This link seems to confirm it's possible but i'm just not quite savvy enough to understand the vague instructions:

http://sourceforge.net/apps/phpbb/freenas/viewtopic.php?f=65&t=3008&start=0&st=0&sk=t&sd=a

0
 
LVL 62

Expert Comment

by:gheist
ID: 33723538
run command

# echo hptrr_load=\”NO\” >> /boot/loader.conf
# reboot
no kernel config necessary
here it goes....
0
 
LVL 11

Author Comment

by:tickett
ID: 33723545
i think i tried that already (actually used nano or pico)
will give it another go in a mo and report back
0
 
LVL 62

Expert Comment

by:gheist
ID: 33723631
please attach dmesg (as code)
0
 
LVL 11

Author Comment

by:tickett
ID: 33725762
Thanks
$ dmesg
Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.3-RELEASE-p2 #0: Fri Jul 30 19:22:29 CEST 2010
    root@dev.freenas.org:/usr/obj/freenas/usr/src/sys/FREENAS-amd64 amd64
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Opteron(tm) Processor 250 (2393.20-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x20f51  Stepping = 1
  Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
  Features2=0x1<SSE3>
  AMD Features=0xe2500800<SYSCALL,NX,MMX+,FFXSR,LM,3DNow!+,3DNow!>
  AMD Features2=0x1<LAHF>
usable memory = 8575631360 (8178 MB)
avail memory  = 8273465344 (7890 MB)
ACPI APIC Table: <A M I  OEMAPIC >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 1.1> irqs 0-23 on motherboard
ioapic1 <Version 1.1> irqs 24-27 on motherboard
ioapic2 <Version 1.1> irqs 28-31 on motherboard
wlan: mac acl policy registered
kbd1 at kbdmux0
cryptosoft0: <software crypto> on motherboard
acpi0: <A M I OEMXSDT> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, f9f00000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x5008-0x500b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci3: <ACPI PCI bus> on pcib1
ohci0: <OHCI (generic) USB controller> mem 0xfeafe000-0xfeafefff irq 19 at device 0.0 on pci3
ohci0: [GIANT-LOCKED]
ohci0: [ITHREAD]
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: <AMD OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 3 ports with 3 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xfeafd000-0xfeafdfff irq 19 at device 0.1 on pci3
ohci1: [GIANT-LOCKED]
ohci1: [ITHREAD]
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: <AMD OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 3 ports with 3 removable, self powered
vgapci0: <VGA-compatible display> port 0xb800-0xb8ff mem 0xfd000000-0xfdffffff,0xfeaff000-0xfeafffff irq 17 at device 4.0 on pci3
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <AMD 8111 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 7.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
pci0: <serial bus, SMBus> at device 7.2 (no driver attached)
pci0: <bridge> at device 7.3 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 10.0 on pci0
pci2: <ACPI PCI bus> on pcib2
bge0: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev. 0x002100> mem 0xfc9f0000-0xfc9fffff irq 26 at device 5.0 on pci2
miibus0: <MII bus> on bge0
brgphy0: <BCM5704 10/100/1000baseTX PHY> PHY 1 on miibus0
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bge0: Ethernet address: 00:0e:b6:28:d4:40
bge0: [ITHREAD]
bge1: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev. 0x002100> mem 0xfc9e0000-0xfc9effff irq 27 at device 5.1 on pci2
miibus1: <MII bus> on bge1
brgphy1: <BCM5704 10/100/1000baseTX PHY> PHY 1 on miibus1
brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bge1: Ethernet address: 00:0e:b6:28:d4:41
bge1: [ITHREAD]
pcib3: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci1: <ACPI PCI bus> on pcib3
hptrr0: <sx508x> port 0xa400-0xa4ff mem 0xfa500000-0xfa5fffff irq 28 at device 1.0 on pci1
hptrr: adapter at PCI 1:1:0, IRQ 28
hptrr1: <sx508x> port 0xa800-0xa8ff mem 0xfa600000-0xfa6fffff irq 29 at device 3.0 on pci1
hptrr: adapter at PCI 1:3:0, IRQ 29
amdtemp0: <AMD K8 Thermal Sensors> on hostb3
amdtemp1: <AMD K8 Thermal Sensors> on hostb7
acpi_button0: <Power Button> on acpi0
speaker0: <PC speaker> port 0x61 on acpi0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio0: [FILTER]
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
sio1: [FILTER]
ppc0: <Parallel port> port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
ppbus0: [ITHREAD]
ppi0: <Parallel I/O> on ppbus0
ppc0: [GIANT-LOCKED]
ppc0: [ITHREAD]
acpi_hpet0: <High Precision Event Timer> iomem 0xfec01000-0xfec013ff irq 0,8 on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
powernow0: <Cool`n'Quiet K8> on cpu0
device_attach: powernow0 attach returned 6
cpu1: <ACPI CPU> on acpi0
powernow1: <Cool`n'Quiet K8> on cpu1
device_attach: powernow1 attach returned 6
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xc8000-0xce7ff,0xce800-0xd4fff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ukbd0: <Dell Dell USB Keyboard, class 0/0, rev 1.10/3.01, addr 2> on uhub0
kbd2 at ukbd0
Timecounters tick every 10.000 msec
ipfw2 (+ipv6) initialized, divert loadable, nat loadable, rule-based forwarding disabled, default to accept, logging limited to 5 packets/entry by default
hptrr0: [GIANT-LOCKED]
hptrr0: [ITHREAD]
hptrr1: [GIANT-LOCKED]
hptrr1: [ITHREAD]
ad0: 976MB <TOSHIBA THNCF1G02PG 1.00> at ata0-master PIO4
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad0s1a
WARNING: / was not properly dismounted
WARNING: /mnt/cflash was not properly dismounted
bge0: link state changed to UP

Open in new window

0
 
LVL 62

Expert Comment

by:gheist
ID: 33725924
And what is inside /boot/loader.conf?
0
 
LVL 11

Accepted Solution

by:
tickett earned 0 total points
ID: 33726684
Yipeeeeeeeeeeeeee! I always get there in the end :) Found this post: http://old.nabble.com/Marvell-88SX7042-td28860159.html

Had to add to /boot/loader.conf

hw.hptrr.attach_generic=0

Voila! Thanks for the help all,

L
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lets start to have a small explanation what is VAAI(vStorage API for Array Integration ) and what are the benefits using it. VAAI is an API framework in VMware that enable some Storage tasks. It first presented in ESXi 4.1, but only after 5.x sup…
Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question