• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 714
  • Last Modified:

Printer queue in Remote Desktop Connection Disappear

Hi;

My user is using Remote Desktop Connection access to my Microsoft Terminal Service Application server to run application, and she print a lot onto her local printer through TS server; it was running fine until I shared her local printer with another user at her branch office, she complains that the printer queue inside the TS disappear and she has to reconnect back to TS server in order to let the connection resumed.  I use same printer driver on TS server and on her desktop computer, there is no problem to see it while connecting to Remote Desktop Connection.

I draft the layout for reference.

Branch office user computer -> local laser jet printer
Using Remote Desktop Connection for access to TS server
Run application on TS server and print it back to her local laser jet printer.

Any idea?
0
KANEWONG
Asked:
KANEWONG
  • 3
  • 2
1 Solution
 
lewisgCommented:
What kind of local printer and how is it connected?
0
 
KANEWONGAuthor Commented:
HP LaserJet 4050 via LPT1:

It was working fine until I share this printer with another user in branch.  Now, I have removed the share but still on and off show up in print queue.  Which means, once user connected to TS server via RDP, the print queue can be found but it disappeared suddenly.
0
 
lewisgCommented:
I'm not a big fan of sharing printers that are connected to computers. I have experienced the sort of problems you are having and the additional problems that come from sharing resources on a user PC (slowness, machine turned off when others are working, crashes).

As a result I connect printers to the network and then connect the user PCs to the printer via TCP/IP. If your 4050 has a network connection this is what I would recommend for connecting the printer to more than one user.

If you want to do this it is fairly simple:

1. Connect the 4050 to the network and assign it a static IP address.

2. Open the 4050 printer properties.

3. On the Ports tab click add port and add the port using the static IP address of the printer.

4. Click the Enable printer pooling check box.

5. Be sure both LPT1 and the TCP/IP port are both checked and press Apply.

You should now have reliable printing from as many computers you go through these steps on.
0
 
KANEWONGAuthor Commented:
this is one of the solution but not I want.
0
 
KANEWONGAuthor Commented:
this is one of the solution but not I want.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now