wordpress links don't work on IIS 6

I have installed wordpress on IIS 6 with PHP 3.3 and FastCGI 1.5
I can access the page like this http://blog.mariomercea.com/index.php
but this does not work http://blog.mariomercea.com and also any link from the blog is not accessible.

index.php is defined as default page in IIS documents
Who is Participating?
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Your links in your blog are going to 'www.mariomercea.com' instead of 'blog.mariomercea.com' which is why they don't work.
What does http://blog.mariomercea.com gives you try to access
evo_xAuthor Commented:
Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
check you website application pool its should not be stopped state. or

Create a new application pool and move the website in this pool and check your url again and see if the problem perisist.
evo_xAuthor Commented:
you are right I have changed the WordPress general settings and now it works. :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.