Link to home
Create AccountLog in
Avatar of Xeronimo
XeronimoFlag for Luxembourg

asked on

weird (Wordpress) folder permission problem in Windows Server 2008!?

Hi,

I've got a weird permission problem with some of my Wordpress folders in Windows Server 2008, more precisely some of the plug-in folders.

When I try to access or modify them I get an 'access denied' message, even though I'm the admin!? Also I can't take ownership of them ...

Anyone got an idea as to why this is and how I could change it??

Thanks a lot,

Jerome
Avatar of Adrian Cantrill
Adrian Cantrill
Flag of Australia image

You need to tell us a bit more information - how are you trying to access and modify them, from the server UI or in some other way ? what modifications are you trying to do ? and what are the NTFS permissions on the folders you are trying to modify.
Avatar of Xeronimo

ASKER

Hi,

From the server UI. I wanted to simply access the folders and/or to modify them. As the Domain Admin I should have all the necessary permissions, no? Yet I get 'access denied'.
Check the permissions on the folder, right click, properties, security. Check what permissions are assigned to the folder - its possible someone has remove the admin user.
It's very weird ... now I can get into them (although I've nothing changed) ... might have been because of Wordpress when it tried to upgrade the plugins??
Well if you tried to modify a plugin file while the upgrade was taking place, that would have caused it. Remember when its upgrading it locks a file... and that would of prevented you doing so.. but it wouldn't have prevented access to a whole folder.
The problem was that the update of the plug-in, from inside WP, failed because WP couldn't remove the old plug-in (why not?? It was able to install it ...). Yet the folder remained locked.

Now, for some reason, it's accessible again (although half empty). I restored the plug-in folder from the backup.
ASKER CERTIFIED SOLUTION
Avatar of Adrian Cantrill
Adrian Cantrill
Flag of Australia image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Ok, I've tried to update the plug-in again. I got this error message:
----
Downloading update from http://downloads.wordpress.org/plugin/google-analytics-for-wordpress.4.0.9.zip…
Unpacking the update…
Installing the latest version…
Removing the old version of the plugin…
Plugin upgrade failed.

An error occured while updating Google Analytics for WordPress: Could not create directory. C:/Websites/mysite/wp-content/plugins/google-analytics-for-wordpress/.

Disabling Maintenance mode…

All updates have been completed.
------
What user is WP using to perform this update?
Also the google analytics plug-in folder isn't accessible anymore right now ... and I can't see the security settings because I can't set neither the domain admin nor the local admin as the owner!?
Can you just show is the permissions of each folder above it, start with c:\websites, then c:\websites\mysite then c:\website\wp-content. Throw up a screenshot of each and we can determine where the permissions are coming from.

Me again ... still the same problem! Certain folders inside a certain plug-in folder in Wordpress simply can't be deleted because I don't have the permissions! Even though I am the Administrator!? I can't even take the ownership of those folders because my access get denied ...

Any other ideas? How can I force Windows 2008 to delete these files??

Thanks,

Jerome
screenshot.png
Update: after a while (and some fiddling like a restart of the web-server) the folders were suddenly accessible ... it's not clear though what exactly it was that did it. Or whether it was a time-out or something.

So now I was able to restore that plug-in folder. Yet I bet if I'd try again to upgrade the plug-in then I would have the same 'access denied' problem for a while!? :(
The problem was not really solved.