Link to home
Start Free TrialLog in
Avatar of unrealone1
unrealone1Flag for United Kingdom of Great Britain and Northern Ireland

asked on

SBS2008 - The imported certificate does not match your website etc

SBS2008 Server
I purchased a certificate from godaddy, but when I go to import the certificate it says "The imported certificate does not match your Web site. Verify that you selected the correct certificate file, and then try again"

My website in the SBS console is mail.mycompany.co.uk and mail.mycompany.co.uk is on the certificate as well?

Any thoughts?
Avatar of Nordicit
Nordicit
Flag of Denmark image

First of all, did you generate the certificate request from IIS7 of the SBS2008?

What you have to do, is "Complete certificate request" in IIS7 on the SBS2008, and then point it to the file received/downloaded from Godaddy. As far as I remember, you can also pull these files from your Godaddy Control Panel.

If you have done all that, then pls give more elaborate info.

Brgds

Thomas
Avatar of unrealone1

ASKER

Hi Thomas

I generated the certificate request in the SBS Console, uploaded certificate request to go godaddy, was authenticated. Then they sent me the certificates. I went back into the sbsconsole and attempted to import the certificate.

Is there anything else I need to do?
Did you either deliberately or accidentally include any illegal characters

http://technet.microsoft.com/en-us/library/cc546059%28WS.10%29.aspx 
Make sure you do not have any illegal characters in any of the fields in the CSR. Illegal characters are [! @ # $ % ^ ( ) ~ ? > < &;; / \ , . " ']

The SBS wizard pulls company name exactly the way it was entered during initial setup and does not check or warn about these characters (ie. O'Reilly Inc.). A certificate generated from that CSR will fail to install with "The imported certificate does not match your Web site. Verify that you selected the correct certificate file, and then try again."
Hi there,

No I havent deliberately or accidently included any illegal characters.

I imported the .crt file godaddy emailed, but it fails to import. My website in the sbs console is mail.mycompany.co.uk and the certificate has mail.mycompany.co.uk.
Avatar of Cliff Galiher
Simply repeat the process.
Regenerate a CSR using the "add trusted certificate" wizard.
Go to Godaddy and use their interface to "rekey" the certificate you purchased, and then use the "add trusted certificate wizard" to add the certificate.
For a certificate to be properly imported, not only must the name match, but the private key must match the public key (otherwise IIS can't decrypt data that browsers send it encrypted with the public key!) and the wizard checks to make sure this pairing works before completing the import. Either the private key was changed after he CSR was submitted (this would happen if you ran the wizard again and generaed another CSR and didn't submit it) or there was corruption when the private key was saved.
Either way, the cause is a relatively minor one. You simply generate a new CSR which will also generate and save a new private key. And then GoDaddy will give you a new public key (rekeying an existing cert is free) and then the wizard can make the pairing and will be happy.
-Cliff
 
Do what cliff says :)
@ cgaliher

I just ran the add certificate wizard, recreated CSR - went to godaddy and used the rekey option, saved it - I then downloaded the new certificate (exchange2007, this right?)
Imported that into the sbs console, but it comes up with the same error?
When you are requesting the certificate from godaddy you need to request iis cert not exchange cert
Use the "add certificate wizard" to complete the process of installing the certificate after you've downloaded it. It sounds like you are trying to import the certificate directly.
-Cliff
 
Thanks for your help with this guys.

@aoakeley, reran the add certificate wizard, rekeyed the CSR into godaddy again and downloaded the certificate for iis6 (thats whats installing on my sbs2008 server). Attempted to import it and again, I get the same error.

@cqaliher, Yeah I am using the add certificate wizard. I download it to my desktop first and unzip the folder its in.
Your SBS Server is uising iis7. Please use that one

Andy
Ok, I tried the IIS7 as well that doesnt work, the reason I tried IIS6 is because If I go into administrative tools > (I have) Internet Information Services (IIS) 6.0 Manager.

Sorry but I have only just been informed from someone else whos also involved with this server.  He has said that sharepoint was uninstalled recently?? Is this reason why its not working?
I am not sure what has happened, but I should have IIS7 and sharepoint installed shouldn't I?
Yes... if you do not have iis7 and sharepoint you probably have bigger issues....

Exchange OWA and lots of other things (including exchange itself) will not work without IIS7.
I am sorry I have wasted your time - I didnt realise it was in this state.

Installing IIS7 and sharepoint, whats the best way to go about this?
To get SBS back into a consistent state after this you are looking at a reinstall.

Are you sure IIS7 is uninstalled? I am fairly sure the SBS Console breaks if you uninstall IIS7? and I would not have though you would be able to generate the certificate request

what happens if you (on the server) do http://servername/ if IIS7 is installed you should get a image like the one below

Andy
iis7.png
I get this error, when I type my servername in. Please see attached image.
ERROR.jpg
ASKER CERTIFIED SOLUTION
Avatar of Andrew Oakeley
Andrew Oakeley
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thanks for all your help - we've come to a conclusion to wipe and start from scratch.
Thank you