Solved

Outlook 2010 prompts for username and password every time

Posted on 2010-09-03
15
28,779 Views
Last Modified: 2012-08-14
Hi,

I have some Windows 7 Pro client pc's, which are running in an environment with Microsoft Small Business Server 2008, Exchange Server 2007 and Outlook 2010 client. However the users get prompted for username and password every single time they open up Outlook both when working on the LAN and remotely through VPN. I've tried disabling cached mode, but that didn't help.

There are some Outlook 2007 clients as well, and for these machines the solution has been to modify the HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC registry key as described here http://support.microsoft.com/kb/956531. However this key doesn't exist in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\, which I assume is the registry entry for Outlook 2010.

Does anyone know the solution to this?

Thanks,
Ronnie
0
Comment
Question by:ronnie13
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 2
  • +2
15 Comments
 
LVL 15

Expert Comment

by:Dave_AND
ID: 33595159
Copied from my internal Wiki:

Before you do anything else close Outlook. You should also note that we'll be modifying system generated files here so proceed with caution or not at all.

Open up windows explorer window and then paste the following text into the address bar which should bring you to a folder with a single folder inside with a really long name.

%userprofile%\AppData\Roaming\Microsoft\Protect



What you'll need to do is just rename that folder to something else (I suggest appending -old onto the end of it so that you could easily rename it back if things go wrong)

Now re-open Outlook and then type in your password hopefully for the last time making sure to check the box to remember it. You should now see that the original folder was re-created again.

At this point Outlook should remember your passwords but you can close Outlook and reopen it to make sure. If you encounter problems with this" you can remove the new folder and then rename the -old folder back to the original name to put everything back the way it was

See if that helps.
0
 
LVL 4

Expert Comment

by:kenycl
ID: 33595171
normally is the ntlm authentication set against your outlook proxy server settings. if the machine is logged onto the same domain with the same username and password usually you can set these to ntlm instead of basic
CAS-NTLM-jpg.jpg
0
 

Author Comment

by:ronnie13
ID: 33595189
Hi,

thanks for the quick replies. I'll try those solutions when I'm in that office next week.

kenycl, the machines are logged onto the domain with the same credentials, but where do I change the client authentication method?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 4

Expert Comment

by:kenycl
ID: 33595208
it would just be under option, accounts, change account settings.
i dont have outlook 2010 on me right now so cant point you to exactly where it is sorry...
0
 

Author Comment

by:ronnie13
ID: 33595263
Can you describe this a little more as I can't find it? I assume it's in the Outlook 2007 client?
0
 
LVL 4

Expert Comment

by:kenycl
ID: 33595318
the above is for outlook 2010
for outlook 2007

it should look something like the below
if you go into tools, accounts, select the exchange account and click change, more settings, connection tab, exchange proxy settings, under proxy authentication settings check if there is any settings there, and see if it is ticked for basic or ntlm, it should be ntlm to pass whatever user's credential to logon to outlook without the password prompt
ap0835-08.jpg
0
 
LVL 28

Accepted Solution

by:
sunnyc7 earned 500 total points
ID: 33595562
0
 
LVL 2

Expert Comment

by:dufyd
ID: 33597915
You know I have gone through this a lot of times and found that my mailbox would sync and then it would ask me for my password, so I thought something was going on.

It was the case that I had another folder trying to sync. You can see the folders that are trying to sync on the left panel. You might have a sharepoint folder or some archive folders, if you get rid of those then only your inbox will sync and will stop asking for your password
0
 
LVL 4

Expert Comment

by:kenycl
ID: 33621639
how did you go with the testing?
0
 

Author Comment

by:ronnie13
ID: 33625903
I haven't had a chance to test it yet but will let you know.
0
 

Author Comment

by:ronnie13
ID: 33698918
Hi,

kenycl, the Exchange proxy settings are not ticked on the users pc as you can see in the screendump (even though Outlook is a Danish version).

Regards,
Ronnie
Outlook.jpg
0
 

Author Comment

by:ronnie13
ID: 33698933
Hi again,

Dave, renaming the folder didn't help either. I can see that a new folder is created, but I'm still being prompted for username and password every time.

Regards,
Ronnie
0
 

Author Comment

by:ronnie13
ID: 33699008
Hi,

there are no other folders than the users mailbox on the server that are trying to sync.

Where can I see if the server is running Exchange 2007 SP2/SP3 or no service packs at all?

Regards
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33699774
Ronnie
Can you try this

Password not saving - try this from workstation

It has to do with your global catalog server not being reachable through the proxy.

If “Remember my password” doesn’t work and you keep getting prompted: a) close outlook b) go to Start... Run and type 'control userpasswords2' (without the quotes) and press OK c) click on the Advanced tab and press 'Manage Passwords'
d) find the entry for your mail server and click ‘Properties’
e) erase the Server name and type in ‘S1’ or whatever the simple name of your global catalog server is (without the quotes)
f) leave the password blank and click OK
g) start Outlook, enter your password and check off ‘Remember my password’ one last time. It should not prompt again.

http://www.petri.co.il/forums/showthread.php?t=18808

--
Exchange version
Run this form exchange shell

GCM exsetup |%{$_.Fileversioninfo}
0
 

Author Comment

by:ronnie13
ID: 33718568
This was actually cause by the Exchange Server only running SP1. Upgrading the server fixed the issue.

Thanks a lot to all of you for your help.
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question