Solved

Dell Laptop and Wireless AP

Posted on 2010-09-03
34
656 Views
Last Modified: 2013-12-27
Hi

I have a Dell Vostro 1510 which connects to my wireless network at home no problems. When im in work i get connected to our Netgear WAG102 ok but it nevers gives me an ip address, it just sits there saying acquiring network address and never gets one.

There are other laptops connceting ok with no problem.

I have googled this and found various stuff but none fixed the problem

I am running Windows XP SP3.

cheers
0
Comment
Question by:kingcastle
34 Comments
 
LVL 10

Expert Comment

by:scriven_j
ID: 33595204
Try disaling your firewall while you initially connect.
Check the Netgear does not have a list of MAC addresses for access control and if it does, add your MAC address to the list.
Disable and reenable wireless network card and recreate the connection from scratch.
0
 

Author Comment

by:kingcastle
ID: 33595206
tried that and no joy and no mac filtering enabled.

0
 
LVL 11

Accepted Solution

by:
Coast-IT earned 500 total points
ID: 33595212
Yes, I have had a similar issue whereby DHCP just would not relay requests to some newer  machines.

Upgrading the firmware on the 102 did the trick (I changed the APIPA address to something on the range to resolve temporarily while I was fixing it)

http://kb.netgear.com/app/products/model/a_id/2555



0
 

Author Comment

by:kingcastle
ID: 33595221
its a WAG102 and i have the latest firmware installed and its local ip is on my lan range already.
0
 
LVL 11

Expert Comment

by:kaskhedikar_tushar
ID: 33595228
Hello,

Do one thing open my network places - wireless connection - check there number of connections is increase. So please delete the connections which not required. Assign a static IP address with DNS.
Also check the firewall settings.Restart your windows & check.

Regards,
Tushar Kaskhedikar
   
0
 

Author Comment

by:kingcastle
ID: 33595243
sorry i dont follow "check there number of connections is increase"
0
 
LVL 11

Expert Comment

by:Coast-IT
ID: 33595250
I dont mean the local IP of the device.  I mean because the client machine can't get an IP, it looks to APIPA for an alternate IP address, which is by default 169.254.x. , you can change this so it has an IP on the LAN for this error.

its a work around, but it works.

http://support.microsoft.com/kb/220874

If DHCP fails, this works ( as a workaround)
0
 
LVL 11

Expert Comment

by:Coast-IT
ID: 33595252
No need to set a static IP, as when you move the machine you are going to be stuffed.  just change the APIPA address as above.
0
 

Expert Comment

by:99charlie99
ID: 33595257
Hi,
0
 

Expert Comment

by:99charlie99
ID: 33595278
Hi, I am sure I have had this problem in the past, you could try going into the properties of  wireless network connections,wireless networks and tick the box to 'Use windows to configure my wireless network connections'
0
 

Author Comment

by:kingcastle
ID: 33595304
tried that charlie

on the APIPA where do i change from 169........
0
 
LVL 11

Expert Comment

by:kaskhedikar_tushar
ID: 33595342
Hello,

Go to the windows wireless connection manager & check the number of connections.

Regards,
Tushar Kaskhedikar
0
 

Author Comment

by:kingcastle
ID: 33595362
1 lan and 1 wireless
0
 
LVL 11

Expert Comment

by:kaskhedikar_tushar
ID: 33595401
Hello,

Right click on wireless connection - view available wireless connections & then check how many connections is there?

Regards,
Tushar Kaskhedikar  
0
 
LVL 3

Expert Comment

by:sayed_maher
ID: 33595421
If DHCP is enabled on your computer, and DHCP is disabled on the router, you will never acquire authentication that way. What you need to do is ask your network administrator if DHCP is enabled on the router, and if it is and your are not able to get anything from DHCP on your laptop, try this:

Open the wireless network connections in your system tray.
Go to advanced options,
click on the network (the one that you are using at work) and then click properties.
go to the security tab.
disable "smart-card authentication". (Just uncheck the whole option, you need regular authentication).
Disable the network card, and then re-enable it. It should now work.
0
 
LVL 9

Expert Comment

by:Gianpiero Rossi
ID: 33595476
I had a similar problem.
i can tell you that dell someimes has some problem, i've got an xps m1330, i've called dell several times and they changes my motherboard 3 times. at the third all is working fine :)
0
 
LVL 14

Expert Comment

by:luconsta
ID: 33595504
The others notebooks connecting are using DHCP?... maybe they are not - you can check one of the to see if is mentioned a DHCP server in the network status (or use IPCONFIG /ALL)
At work you are using a domain to log on - if YES - this could be a problem - if you are not authenticated agains a domain you will not reecive a DHCP address because server will not recognise you.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 24

Expert Comment

by:B H
ID: 33595541
i've seen this a lot with WEP encryption, changing it to WPA fixed it in most cases...

i think the previous comments about firmware (and the not said update the wireless driver) are good... firmware for the netgear, firmware for your wireless card, firmware for your bios.

you could also let your wireless card driver handle the wireless networks, most will let you specify an ip address to use per profile.

the wireless network at home, and at work, they don't have the same wireless network name, like 'netgear' do they?  if so change one
0
 
LVL 24

Expert Comment

by:B H
ID: 33595548
if all else fails, we could write two batch files you can put on your desktop icons... one that sets the laptop to dynamic (for everywhere else) and one that sets all the static info for work... so just a double click and you're good
0
 
LVL 4

Expert Comment

by:goyal_251
ID: 33595625
have you matched the encryption scheme on your laptop and access point.?
have you tried by assigning the static IP of the same rage what you have in your office.?
0
 

Author Comment

by:kingcastle
ID: 33595632
ok first off we have dhcp server on the network
all other laptops work fine and are dhcp
we use WPA-PAk with TKIP

0
 

Author Comment

by:kingcastle
ID: 33595636
static address works fine

if i change encryption does that mean everyone else will be disonnected and then they will all need resetup?

cheers
0
 
LVL 3

Expert Comment

by:sayed_maher
ID: 33595648
Open the wireless network connections in your system tray.
Go to advanced options,
click on the network (the one that you are using at work) and then click properties.
go to the security tab.
disable "smart-card authentication". (Just uncheck the whole option, you need regular authentication).
Disable the network card, and then re-enable it. It should now work.
0
 

Author Comment

by:kingcastle
ID: 33595672
above is already the case
0
 
LVL 11

Expert Comment

by:Coast-IT
ID: 33595680
did you follow the APIPA instructions as per my link?

As I said this is a workaround...

Sayed's option looks good.
0
 
LVL 14

Expert Comment

by:luconsta
ID: 33595714
Well kingcastle, in this case my gues may be correct (90%) - At work you are on a active directory domain and your PC is not joined into the domain (or was outside domain for few weeks and lost its connection wit the domain).
If your PC was working "once upon  time" at work you have to rejoion the domain (put your computer into a workgroup then back to the domain - you will need an account that has the right to join computers to the domain, or ask your administrator how you can do this).
If you are new to that work network - you have to ask your admin how you could join to that domain.
0
 

Author Comment

by:kingcastle
ID: 33595718
smart card option gaeyed out
0
 
LVL 3

Expert Comment

by:sayed_maher
ID: 33595724
Try this:

Control panel --> Network connections --> Wireless card (Right click properties). -- Scroll down to TCP/IP --> click "Use the follwing Ip address:" --> Fill in the IP Address (range that the DHCP usually assigns, ie, if your colleagues are 192.168.0.100, 102, 103, etc. try something like 118; Subnet mask 255.255.0.0, gateway should be the routers IP, ie: 192.168.0.1 and the preferred DNS should be the same. --> Disable the network card, re-enable the network card.

Good luck
0
 
LVL 20

Expert Comment

by:Jakob Digranes
ID: 33595744
What is your DHCP server?
and what is you DHCP lease time?

Here's a fun project for you.
Download and install Wireshark (www.wireshark.org) on your computer.
Start capture BEFORE you connect to wireless network at work.
Let it capture until you're disconnected - or several minutes have gone by without you connecting.

Then stop capture and sort by protocol and look for DHCP packets.
Here's how DHCP works.

Laptop connects to wireless and sends a DHCP DISCOVER broadcast packet looking for DHCP Server

DHCP Server responds with a DHCP OFFER packet, offering an IP-configuration

Laptop gets the offer, and responds with a DHCP REQUEST packet, claiming the offered address

The server finally gives an DHCP ACK packet to acknowledge the address lease.

If DHCP server is a Windows server, install wireshark on that server an look for the same sequence there.

moreover, make sure you've deleted the wireless profile and reconnected to confirm PSK is correct.
0
 

Author Comment

by:kingcastle
ID: 33595879
Dhcp is windows 2008 thought that maybe re adding was a good point but if I plug in LAN cable same dhcp server give  me ip on LAN card
0
 

Expert Comment

by:first_major
ID: 33595911
make sure you are also using the same wifi type, like G/N/A wirless G or N or A etcc...
0
 

Author Comment

by:kingcastle
ID: 33596127
We use g but I can't see anywhere to specify that
0
 
LVL 3

Expert Comment

by:sayed_maher
ID: 33597162
as long as you see the wireless connection; its the right type. Please refer to my previous post
0
 
LVL 2

Expert Comment

by:iceradish
ID: 33597976
Try download the latest wireless card driver from Dell; I doubt it's causing by incompatibility between Dell wireless card and Netgear access point.
0

Featured Post

Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

Join & Write a Comment

Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now