Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 564
  • Last Modified:

Typing delay in Visual Studio.Net application when connected to Network

On some computers using windows 7 or windows xp our application works fine on stand alone pc. If we run our application after connecting lan wire to PC, typing first time in any text box of any form (generally login form), second character appears after 2-3 seconds delay in text box. We could not find any solution to this problem. It appears on our development environment PC as well as on client PC, but not on all pc's.
0
MLGupta
Asked:
MLGupta
  • 2
1 Solution
 
MLGuptaAuthor Commented:
This problem is not related to typing. If we open any form and just close it, that also takes similar delay and after that typing in text box works fine.
0
 
kris_perCommented:

Open Task Manager and in Processes tab, find which process is taking more cpu usage when this issue occurs...This may give some clue to which process is delaying the whole process..based on that, can look for what to do next...
0
 
w00teCommented:
Well, first of all, VS is extremely processor intensive on load up.  I have run it on extremely fast dual core raid drive and high ram systems and there is still a significant pause the majority of the time when loading a form and/or loading pannels like the toolbox.  VS2010 seems to have improved this a bit over 2008, but the issue is definitely on all versions.  After loading something once though the problems should improve (each time you load VS mind).  As for the networking specific issues and getting worse, there's multiple things online with different solutions -- this one sounds like it might be the key if you're on a corporate server though (which I'm guessing you are the way you mentioned the network).
http://social.msdn.microsoft.com/Forums/en-US/vssetup/thread/bc778e26-9156-4924-a9ca-a57ef8ff6bcc/
"As an update, I found an even better fix so you dont' have to lose any functionality in VS 2008.  This also drastically improved performance (response time) for me in SQL server management Studio.
 
In Internet Explorer 7...
Tools->Internet Options->Advanced->Security Node->Uncheck 'Check for publisher's certificate revocation*'
 
Once I did this, like magic, VS 2008 works great even with 'Enable the Visual Studio hosting process'  checked and SQL Server Management Studio's response time was almost immediate.
 
It is a good day!
 
My theory is the corporate network I am in is blocking certain ports (out of my control), and thus certain 'behind the scenes' requests are timing out, causing the delays."
Good luck man,
-w00te
0
 
MLGuptaAuthor Commented:
Dear All,

It did not solve our problem. Actually same machine is working faster when we do not connect network cable to it. Just when we connect network cable (no internet is there) it starts working slow. We face this problem on some machines having windows 7 or windows xp. On the same network, there are many machines where we do not face this problem.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now