Solved

Adding Exchange 2003 SMTP Connector

Posted on 2010-09-03
17
530 Views
Last Modified: 2012-05-10
I currently have an SMTP connector on an Exchange 2003 server to go to an Ironport spam filter. All of my email goes through that connector. I have a Sharepoint server on my network with SMTP installed. I need to setup a connector to deliver messages from my Exchange server to it, so that those messages don't go to my Ironport box. When I setup a connector it gets queued, but not delivered. Oddly enough, the minute I set that connector up, the Queues view in Exchange System Manager starts showing the domains of external domains I am seding email to. Not sure why.
0
Comment
Question by:Greg27
  • 7
  • 6
  • 4
17 Comments
 
LVL 13

Expert Comment

by:George Sas
ID: 33595661
What domains do you have set up on your SMTP connector ? What costs did you set up on it ?
The reason your queue is growing is because you might have specified ALL domains plus added a cost lower than the SMTP connector that delivers to your spam filter.
0
 

Author Comment

by:Greg27
ID: 33595703
Just one internal domain auto.local. So, I have an SMTP connector named Exchange-Ironport that send all email to my Ironport. Cost is 1. I added an SMTP connector named Exchange-Sharepoint that sends email to sharepoint.auto.local. I originally set it up with a cost of 1 and then when things started queuing up I changed the cost to 2. No change.
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 50 total points
ID: 33595815
it sounds like the smtp virtual server for sharepoint is not accepting the connections from your exchange server
from the command prompt on your exhcange server try

telnet sharepoint 25
ehlo
mail from: you@domain.com
rcpt to: someone@sharepoint.auto.local
0
 
LVL 13

Expert Comment

by:George Sas
ID: 33595863
Are you using DNS to deliver your e-mails to the sharepoint ?
And what is the Address Space you have specified on this new connector ? I hope it's only "auto.local"
0
 

Author Comment

by:Greg27
ID: 33596030
Well, looks like someone turned off the SMTP virtual server. It is now back on. I am rebuilding the connector. When I originally setup the connector the address space I setup was sharepoint.auto.local. So, I shouldn't do that? These are the other settings I configured:

Use DNS to route each address space on theis connector
Local bridgeheads: Exchange
Address Space E-mail domain: sharepoint.auto.local
Cost: 2
Address Space Connector scope: Entire organization

Do I need to change anything or add anything to the configuration?
0
 
LVL 13

Expert Comment

by:George Sas
ID: 33596181
Yes , change the use of DNS and specify the IP address of the sharepoint of the FQDN of it.
0
 

Author Comment

by:Greg27
ID: 33596268
When I set it up to use DNS, I was concerned that the othr option is to "Forward ALL mail through this connector to the following smart hosets". Does that mean that all of my email will go through it? I do have an MX record for the sharepoint server in DNS with a server priority of 20. My Exchange server has an MX record with a server priority of 10.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33596286
exchange will go by the address space for routing mail
so as long as you specify the domain name only for sharepoint that is all the connector would be used for
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 13

Accepted Solution

by:
George Sas earned 450 total points
ID: 33596297
If you only specify the address space "sharepoint.auto.local" only mails for xxx@sharepoint.auto.local will be delivered to your sharepoint.
The smpt connector will only deliver e-mails for the specified namespaces specified under the namespace tab , so please don't add * there :)
0
 

Author Comment

by:Greg27
ID: 33596378
Ok, so i am going to change from "Use DNS to route to each address space on this connector" to "Forward all mail through this connector to the following smart hosts" and then set the smart host to sharepoint.auto.local. Correct? If I do this, should I delete the MX record for the sharepoint.auto.local  server?
0
 
LVL 13

Expert Comment

by:George Sas
ID: 33596924
Correct.
0
 

Author Comment

by:Greg27
ID: 33597011
Thanks. Ok, I set that up, sent a message to that server and it still went to my Ironport. Seems to be ignoring my new connector. I tried restarting the SMTP Virtual Server, but it still goes to my Ironport.
0
 
LVL 13

Assisted Solution

by:George Sas
George Sas earned 450 total points
ID: 33597091
Ok , to what e-mail address did you sent the message ?
What COST did you set on your connector ?
How does your namespace look like exactly ?

It should look something like this :
smtp1.png
smtp2.png
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33597241
check the settings for your server's default smtp virtual server
if you have this set to use a smart host all mail will route to the smart host
0
 

Author Comment

by:Greg27
ID: 33614038
GeoSs, I noticed that you had the new connector with a cost of 1. Should I change my connector that moves all other email to my Ironport to a cost of 2 or higher and have the connector to the Sharepoint server as 1?
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 50 total points
ID: 33614108
by specifying the unique address space for just the sharepoint smtp domain the cost doesn't matter unless the connector is down or you have multiple connectors with the same smtp domain
0
 

Author Comment

by:Greg27
ID: 33736099
This issue has a resolution. I am not sure if questions get closed after we accept a solution, but the points should be given out and then I guess whatever happens to a posted question after resolution should happen. I can't however ask a new question until this is taken care of. Can someone look into it asap? Thanks for your help.
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now