Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 512
  • Last Modified:

WCF Service stop working on SubDomains

I have created WCF service which is successfully running in domain like www.test.com. However, I have shifted to subdomain i.e. "test.test.com" and the service has stopped working. Whenever I try to run the service it gives error "Resource not found."

Hi experts,

Please remember that my application is hosted on shared hosting (goDaddy.com).

Thanks.
0
aplusexpert
Asked:
aplusexpert
  • 2
1 Solution
 
aplusexpertAuthor Commented:
Hi experts,

Please remember that my application is hosted on shared hosting (goDaddy.com).
0
 
Mohamed OsamaSenior IT ConsultantCommented:
Have you updated your service app.cofig file with the New URL for the service contract , to reflect the URL change ?


0
 
aplusexpertAuthor Commented:
We have solved the problem at own.

We have one domain and a more than one sub-domains. Sub-domain's directories resides in root directory of main domain.

i.e

Domain www.testsite.com
Root directory :testsite.com
Sub-Domain test.testsite.com
Sub directory :testsite.com/test

We have used www.testsite.com/test for get the WCF Service insted of test.testsite.com

Thanks for reply.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now