We help IT Professionals succeed at work.

Active Sync Issues with Iphone 4 and exchange 2003

843 Views
Last Modified: 2013-12-27
I am unable to get Iphones to connect to exchange 2003 server (no ISA or front-end server).  OWA works fine.  I have tried a TON of things including
Changing authentication types (integrated, basic)
SSL cert from godaddy, I installed both certs, and installed it on the imap protocol in ESM
I have reset IIS completely and still no luck
test exchangeconnectivity.com says the following:
ExRCA is attempting the FolderSync command on the Exchange ActiveSync session.
       The test of the FolderSync command failed.
Everything else passes (does say win mobile 5 and earlier wont work, but that's ok as I am working with iphone4 phones.
Comment
Watch Question

Top Expert 2010
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Done all of that, and then did the tutorial links below that.
The exhange VD .net version is 2.0.50727 - no drop down allowed to change it to 1.x.x.x - The active-sync VD DID allow me to change down to 1.x.x.x.

Author

Commented:
Another thing to mention is when choosing authentication I enter domainname, if I click the select button to see whats available it has domainname.local but I do not use that.
After resetting all IIS settings and having it all be re-created the default name that shows up (ONLY under the active sync VD) is olddomainname.
I did a domain rename about 3 months ago and find it odd that the olddomain keeps popping up once in a while, its also interesting that when I setup an outlook profile and type exchange server name and type the FQDN server.domainname.local, and click "Check" it underlines the servername but changes it to server.olddomainname.local - VERY strange as I cant even ping olddomainname.local or anything, but outlook works fine and has no issues!
Top Expert 2010

Commented:
how did you rename your domain ? using rendom ?

Author

Commented:
@Sunnyc, I will check version of iphones.  In my original post I mentioned using the testexchange website and posted the results that I get (500 error)
Top Expert 2010

Commented:
I need the verbose results with SSL checked.
Can you post that please.

Author

Commented:
User says its on 4.0 and "up to date"...

Author

Commented:
Here are results (what do you mean SSL checked?, ignore SSL?  I did not ignore because its a 3rd party godaddy cert).

An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the ActiveSync session
       
      Test Steps
       
      ExRCA is attempting to send the OPTIONS command to the server.
       OPTIONS response was successfully received and is valid
       
      Additional Details
       Headers received: Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Fri, 03 Sep 2010 13:46:50 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET

      ExRCA is attempting the FolderSync command on the Exchange ActiveSync session.
       The test of the FolderSync command failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       Exchange ActiveSync returned an HTTP 500 response.
Top Expert 2010

Commented:
it should be 4.0.2

4.0 has an issue with SYNC to Exchange
Apple released a fix
i will post back.
Co-Owner
CERTIFIED EXPERT
Top Expert 2011
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Alan HardistyCo-Owner
CERTIFIED EXPERT
Top Expert 2011

Commented:
The fix for the Apple iOS4 with Exchange is linked to in my blog for this problem:
http://alanhardisty.wordpress.com/2010/07/02/apple-ios4-issues-with-iphone-4-3gs-3g-and-exchange/ 
Top Expert 2010

Commented:
Alan - aha...
rhwimmers - there you have it > Alan's article.
That's the bible around here @ EE for troubleshooting iPhone issues.

4.0.2 is stable, I havent heard issues from that - if you can, please upgrade to 4.0.2

Author

Commented:
Have been going through that article or doing those things on and off for a week now.  hoping this iphone OS fix is it, although the testexchange things comes back bad and I wouldn't think that it would since its not running apple OS?
Alan HardistyCo-Owner
CERTIFIED EXPERT
Top Expert 2011

Commented:
If you have been through my article, KB883380 and then the additional fix for Error 500 and still no joy - then Microsoft is the next port of call I'm afraid.
Top Expert 2010

Commented:
although the testexchange things comes back bad and I wouldn't think that it would since its not running apple OS?
>> ExRCA (TestExConn) tests against the Microsoft Exchange Activesync - it doesnt test against the iphone OS.
It's a simulator to check if everything is working ok over there.

Author

Commented:
Still not having much luck - however...I DID notice that when I reset IIS (for the 5th time by now) that the virtual directory for active-sync authentication default is olddomainname - if I click the browse I see newdomain.local, but I have just been typing in newdomain (no .local) per the instructions ive seen several places...  This is bothsome and I feel it might have something to do with the issues...  I found this article
http://www.freelists.org/post/exchangelist/Exchange-2k3-Post-Domain-Rename
Which unfortunatley has NO responses because it is almost identicle to what im running into - I went to turn forms based authentication back on just as a hunch and then I got that same error...  I ran the netdiag and i DO see the old domain name

Registered Service Principal Names:
        XOsoftEngine/sbexch01.newname.local:25000
        exchangeRFR/sbexch01.oldname.local
        exchangeMDB/sbexch01.oldname.local
        HOST/sbexch01.newname.local
        SMTPSVC/sbexch01.newname.local
        exchangeRFR/sbexch01.newname.local
        exchangeMDB/sbexch01.newname.local
   
I would feel better if I didnt see the oldname anywhere, but cant seem to figure out how to remove it?
Alan HardistyCo-Owner
CERTIFIED EXPERT
Top Expert 2011

Commented:
Have you followed kb883380 method 2?  That might resolve the issue.
http://support.microsoft.com/kb/883380 

Author

Commented:
Yeah, ive actually tried all 3 methods at different times....
Top Expert 2010

Commented:
ExRCA is attempting the FolderSync command on the Exchange ActiveSync session.
       The test of the FolderSync command failed.
        Tell me more about this issue and how to resolve it

>> did you click on the tell me more link

Author

Commented:
Yes, it leads to the same links as everyone here has posted....
http://technet.microsoft.com/en-us/library/dd439375%28EXCHG.80%29.aspx
Alan HardistyCo-Owner
CERTIFIED EXPERT
Top Expert 2011

Commented:
Here is the closing comment from another question I worked on - it may be worth checking:
"So after talking to our good friends at Microsoft here's the solution:
As it turns out the in ability to authentication was do to.....
The exchange's servers virtual directory for the mailboxes was visible.
Which in turn throw an error preventing the authentication.
Here is the Registry entry: HKEY_LOCAL_MACHINE --> CurrentControlSet --> Services --> EXIFS --> Parameters --> DriveLetter=M
I removed "M" so now it empty or blank and BadaBing BadaBoom "Smart Phones" now sync. "
Failing that - Microsoft is the next port of call.

Author

Commented:
Well, Microsoft fixed the issue.  It DID have to do with my domain rename as I suspected - we did 2 things that seemed to fix things....
1.  Deleting the exchangeRFR/sbexch01.oldname.local from the registered SPN using setspn -d etc (neither of us knew if this actually did help, as it still lists the oldname in the setspn -L)

2.  I am 99% sure THIS is what actually fixed it...  Going into adsiedit utility then gong to configuration, configuration, services, exchange, first organization, administrative groups, servers, servername, rightclick and go to properties on the servername, then under attributes go down to network address...  It had ncacn_ip_tcp:servername.oldname.local - click remove, change to ncacn_ip_tcp:servername.newname.local
 - I guess something that didnt get changed during the domain name change project for whatever reason.
Whew, that was a tough one - 1st time ive ever had to call MS in over 10 years!

Author

Commented:
Thanks for the effort on this one - Alan, maybe add this to the guide in the small chance someone does a domain rename and has same issue?
Alan HardistyCo-Owner
CERTIFIED EXPERT
Top Expert 2011

Commented:
Thanks for the update, the fix and the points.  I will be sure to amend my article so that it may be helpful to others.

Glad you got it solved in the end.  Sorry you had to call Microsoft though.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.