SMTP Relay for Exchange 2010, Maximum emails from one sender over time period?

We just migrated from Exchange 2003 to 2010. We have an automated process that sends an email out to our customers that since we have migrated to 2010 has started timing out after a random number of emails have been sent.  This worked fine under exchange 2003.  

Is thier a setting in Exchange 2010 that says only allow X number of emails from a SMTP user/ip over a given time frame?
LVL 12
Gary DewrellSenior Network AdministratorAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Gary DewrellConnect With a Mentor Senior Network AdministratorAuthor Commented:
What we have found is that exchange accepts one email, sends it, then accepts the second email and sends it so forth and so on. This is apparently different behavior than in exchange 2003. Some times it took as long as 5 seconds for each email. The script was timeing out before all of the emails could be sent. We increased the time out value on the script. Not sure why it does not accept all the emials for delivery and que them up but....
0
 
sunnyc7Commented:
automated process that sends an email out to our customers
>> what software are you using to do this ?
Did you create a separate connector.

check this article which describes how to allow applications to relay off exchange.
http://msexchangeteam.com/archive/2006/12/28/432013.aspx

this was written for 2007, but applies to 2010 also.

Post back if you have any questions.
thanks
0
 
FDiskWizardCommented:
Did you change your anti-virus or anti-SPAM when upgrading? Maybe one of those is flagging them?
Are all of the emails the same? Different attachments maybe?
Could an instrusion system or firewall be getting in the mix?
We had a problem like that (IPS) with certain PDF file attachments.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
WeltenCommented:
Might actually be the local Antispam filtering in Exchange that kicks in.
Try temporary disable it or whitlist the local IP of the processingbox..

0
 
sunnyc7Commented:
That is quiet possible @ anti-spam
what anti-spam software are you using ?
0
 
Gary DewrellSenior Network AdministratorAuthor Commented:
Nothing on the exchagne server directly which is wear this is happening.  We have a third party anti-spam but that happens after the exchagne server.

I will have to ask one of our developers how they are actually sending the messages but my guess would be via VB code connecting directly to the 2010 server.  

Wonder if the Exchange server is just slower responding to the SMTP commands causing the vb script to run longer and eventually timing out.
0
 
sunnyc7Commented:
Those vb codes wony work. You will have to use exchange web services to send email. Can you ask your developer to explore that part
0
 
Gary DewrellSenior Network AdministratorAuthor Commented:
It is working somewhat. For example I had the create a webpage that allows me to enter a From, To, and Count so I can test. I can send 100 no problem, 200 no problem, but any thing above that and it starts failing about the 240 mark.
0
 
Gary DewrellSenior Network AdministratorAuthor Commented:
Found the answer on my own.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.