?
Solved

How to force Windows 7 to use 802.11n in preference to 802.11g.

Posted on 2010-09-03
11
Medium Priority
?
4,684 Views
Last Modified: 2013-12-09
So I just bought this router: http://www.newegg.com/Product/Product.aspx?Item=N82E16833162031
My laptop has a Intel WiFi Link 4965AGN
My laptop is running Windows 7

I have installed the latest version of DD-WRT that it supports.
I setup a wireless network in the N-Only mode to test my laptop with it.
Laptop connected and showed a rate of 130mbps (not the best.. but I can live with it)
Then I switched the router to mode NG-Mixed so that older clients on my network could connect to G, and my laptop could connect to N.
My laptop connects, but the rate is only 54mbps.

So how do I get my laptop to connect to the N signal instead of the G? I looked at the options in my wireless card's settings and the only mode I could actually disable was 802.11n (which seemed like a bad idea, considering what I'm trying to do here xD)

Thanks for the suggestions and advice in advance!
0
Comment
Question by:eturpin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
11 Comments
 
LVL 6

Assisted Solution

by:Nuttycomputer
Nuttycomputer earned 1500 total points
ID: 33597225
Make sure that WMM is enabled on both the Router and the Intel Wireless Adapter. For some reason running in mixed mode with this disabled causes the speed to drop down on N Devices.
0
 
LVL 3

Author Comment

by:eturpin
ID: 33597309
I can't seem to find WMM anywhere in DD-WRT.. though searching on Google seems to show it being in the QOS section. Any DD-WRT experts care to chime in?
0
 
LVL 3

Author Comment

by:eturpin
ID: 33597393
I updated my Intel driver and enabled WMM on my Windows 7 machine. The speed fluctuates from 48mbps to 54mbps now.. if only it would go up :)
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 6

Assisted Solution

by:Nuttycomputer
Nuttycomputer earned 1500 total points
ID: 33597524
It's under Wireless and Advanced Settings near the very bottom. I've attached an image from my setup.


Capture.PNG
0
 
LVL 3

Author Comment

by:eturpin
ID: 33597590
I can't seem to locate WMM on the advanced settings in wireless. Here's what I see.
ddwrt.png
0
 
LVL 6

Assisted Solution

by:Nuttycomputer
Nuttycomputer earned 1500 total points
ID: 33597618
Hmm... Looks like we have different versions then ;) WMM is also a Quality setting. Does your version have a QOS section it may be hiding under?
0
 
LVL 3

Author Comment

by:eturpin
ID: 33597655
I looked in QoS first and couldn't find it there either. I'm still tinkering around with settings though so maybe I'll find something.
0
 
LVL 6

Assisted Solution

by:Nuttycomputer
Nuttycomputer earned 1500 total points
ID: 33597807
Yeah the information is a little sketchy and unfortunately I don't have the version your running. I did find this but it shows it in roughly the same location:

http://www.linksysinfo.org/forums/showthread.php?t=47262

It's possible that WMM isn't supported by your router which could be why it's not in your version of the software.
0
 
LVL 3

Author Comment

by:eturpin
ID: 33599777
I switched back to the default Buffalo firmware for the router and I can confirm that it does have WMM support. Buffalo actually starting using DD-WRT for this router: http://www.buffalotech.com/press/releases/buffalo-and-dd-wrt-collaborate-to-create-the-most-comprehensive-consumer-and-small-business-wireless-offering/

So now I'm running Buffalo's version of DD-WRT. Still having the same issue though.
0
 
LVL 3

Accepted Solution

by:
eturpin earned 0 total points
ID: 33600099
So after installing Buffalo's DD-WRT Version I am having no trouble at all! My Windows 7 laptop connects to the n signal. My older laptop connects to g. Everything is working great!

Nuttycomputer, thanks for your help, I am not very good with E-E, but I will try to award you some points for your help here in a second.
0

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question