Solved

Port forwarding on ASA 5505

Posted on 2010-09-03
4
449 Views
Last Modified: 2012-05-10
Hello,

I am out of my country setting up a customer who moved. I changed the outside interface IP information and the gateway address. also changed the external IP in the firewall rules to the new one. Still port forwarding from outside to inside doesn't work. Anything wrong with config below?

: Saved
:
ASA Version 7.2(2)
!
hostname host
domain-name domain.local
enable password WwTrbQHSc43pU1OY encrypted
names
name 192.168.1.10 ares
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 ospf cost 10
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 213.164.10.18 255.255.255.252
 ospf cost 10
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
 ospf cost 10
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd WwTrbQHSc43pU1OY encrypted
banner exec All unauthorized connections are traced to this SNMP server
banner login Please login to this Print queue
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns server-group DefaultDNS
 domain-name degraffpurchase.local
object-group network inside-network
 network-object 192.168.1.0 255.255.255.0
access-list outside_access_in extended permit tcp any host 213.164.10.18 eq 3389
access-list outside_access_in extended permit tcp any host 213.164.10.18 eq pop3
access-list outside_access_in extended permit tcp any host 213.164.10.18 eq imap4
access-list outside_access_in extended permit tcp any host 213.164.10.18 eq smtp
access-list outside_access_in extended permit tcp any host 213.164.10.18 eq https
access-list outside_access_in extended permit tcp any host 213.164.10.18 eq www
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list TPCEUVPN_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.96 255.255.255.224
access-list inside_nat0_outbound extended permit ip any 192.168.2.96 255.255.255.224
access-list tpceutunnel_splitTunnelAcl standard permit any
pager lines 24
logging enable
logging buffered debugging
logging trap informational
logging asdm informational
logging from-address asaeu@parkerinternational.eu
logging recipient-address asyed@parkerinternational.com level errors
logging facility 22
logging host inside ares
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool bigpool 192.168.2.100-192.168.2.120 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 213.164.10.18 ares netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 213.164.10.17 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server ASA-PARKEREU protocol radius
aaa-server ASA-PARKEREU host ares
 key cisco123
 acl-netmask-convert auto-detect
group-policy tpceutunnel internal
group-policy tpceutunnel attributes
 dns-server value 192.168.1.10
 vpn-tunnel-protocol IPSec
 group-lock value tpceutunnel
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value TPCEUVPN_splitTunnelAcl
 default-domain value parkerinternational.eu
username admin password NkscWVh.EV3rwhO7 encrypted
http server enable
http 192.168.1.2 255.255.255.255 inside
http 192.168.1.0 255.255.255.0 inside
snmp-server host inside ares community public
snmp-server location Amsterdam
snmp-server contact asyed
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group DefaultRAGroup general-attributes
 address-pool bigpool
tunnel-group tpceutunnel type ipsec-ra
tunnel-group tpceutunnel general-attributes
 address-pool bigpool
 authentication-server-group ASA-PARKEREU LOCAL
 default-group-policy tpceutunnel
tunnel-group tpceutunnel ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group tpceutunnel
telnet ares 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.150 inside
dhcpd dns 195.68.0.2 195.68.0.1 interface inside
!
vpnclient server ares
vpnclient mode client-mode
vpnclient vpngroup TPCEU password ********
vpnclient username user password ********
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
  inspect icmp error
!
service-policy global_policy global
smtp-server 192.168.1.10
prompt hostname context
Cryptochecksum:ee272a8dafa7b466334a2ea80a21ab7e
: end
asdm image disk0:/asdm-522.bin
no asdm history enable

0
Comment
Question by:Encaps
  • 3
4 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 33597503
0
 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
ID: 33597568
change the IP  on your access lists to "interface outside "

like

access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any interface outside eq pop3
access-list outside_access_in extended permit tcp any interface outside eq imap4
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq www

get rid of this

no static (inside,outside) 213.164.10.18 ares netmask 255.255.255.255

then create a static for each port


static (inside,outside) tcp interface 3389 192.168.1.x 3389 netmask 255.255.255.255
static (inside,outside) tcp interface pop3 192.168.1.x pop3 netmask 255.255.255.255
static (inside,outside) tcp interface imap4 192.168.1.x imap4 netmask 255.255.255.255
static (inside,outside) tcp interface smtp  192.168.1.x smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.x https netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.x www netmask 255.255.255.255
0
 

Author Closing Comment

by:Encaps
ID: 33597699
Great, thanks a lot, time to find my hotel now :)
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 33602270
>>Great, thanks a lot, time to find my hotel now :)

LOL story of my life :)

ThanQ
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now