Running jar file from command prompt

When i run my program from netbeans, everything works well. But when i try to run it from the command prompt using java -jar JavaApplication3.jar i get the following errors:

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/logging/
LogDomains
        at com.sun.appserv.security.ProgrammaticLogin.<clinit>(Programmatic
Login.java:85)
        at demo.Main.main(Main.java:31)
Caused by: java.lang.ClassNotFoundException: com.sun.logging.LogDomains
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 2 more

What do i need to do to make it run from commandline?
/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */
package demo;

import com.sun.appserv.security.ProgrammaticLogin;
import java.util.Hashtable;
import javax.naming.InitialContext;
import javax.rmi.PortableRemoteObject;

/**
 *
 * @author js
 */
public class Main {

    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {

        Hashtable env = new Hashtable();
        env.put("java.naming.factory.initial", "com.sun.enterprise.naming.SerialInitContextFactory");
        env.put("java.naming.factory.url.pkgs", "com.sun.enterprise.naming");
        env.put("java.naming.factory.state", "com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl");
        //env.put("org.omg.CORBA.ORBInitialHost", "127.0.0.1");
        env.put("org.omg.CORBA.ORBInitialHost", "10.10.22.106");
        env.put("org.omg.CORBA.ORBInitialPort", "3700");

        ProgrammaticLogin pm = new ProgrammaticLogin();
        String user = "dummy";
        pm.login(user, "dummy"); //user and password of a user mapped to admin role

        

        InitialContext ctx;
        try {
            
            ctx = new InitialContext(env);

            javax.swing.JOptionPane.showMessageDialog(null, "Attempting to lookup");
            Object ref = ctx.lookup("demo.SB3Remote");
            javax.swing.JOptionPane.showMessageDialog(null, "Ey looked up!");
            //Object ref = ctx.lookup("java:global/HelloBean/Login2-ejb");
                        
            SB3Remote calc = (SB3Remote) PortableRemoteObject.narrow(ref, SB3Remote.class);            
            javax.swing.JOptionPane.showMessageDialog(null, " " + calc.Hello(user));

        } catch (Exception ex) {
            ex.printStackTrace();
        }        
    }
}

Open in new window

endasilAsked:
Who is Participating?
 
endasilConnect With a Mentor Author Commented:
Found the problem, i needed to add the appserv-deployment-client.jar to the project. Strange that it worked from the ide without this.
0
 
Gurvinder Pal SinghCommented:
you need to add the classpath to the following command
java -jar -cp <path of jar file with classes required in classpath> filename.jar

for reference
http://download.oracle.com/javase/1.4.2/docs/tooldocs/windows/java.html

download the jar file from here
http://www.findjar.com/jar/javax/xml/jaxrpc-api/1.1/jaxrpc-api-1.1.jar.html?all=true
0
 
objectsCommented:
you need to either add the relative location of the dependent jars to your manifest

or specify them on the command line

 java -cp JavaApplication3.jar;a.jar;b.jar demo.Main
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
karthi_bvCommented:
FInd program dependent jars and set the class path like below and run the program

set classpath=.;c:/yourjars

0
 
endasilAuthor Commented:
i tried setting the classpath to the dist/lib directory where netbeans copy the libs i add to the project, but no difference.  
0
 
chatarosCommented:
in the manifest file set the executable class
take a look at ANSWER:
1
http://www.captain.at/programming/java/executable-java-application.php
0
 
objectsCommented:
So where is it find the classes now?
0
 
endasilAuthor Commented:
Under dist/lib  as earlier. And i have no idea how it could have worked earlier from netbeans when i did not have appserv-deployment-client.jar added. If i delete any other lib from the project it wont run, but it seem to run fine without that jar when starting from  netbeans. That is still a mystery for me.
0
 
endasilAuthor Commented:
Should also add that it was able to find libraries under the lib folder automatically, so setting class path was not an issue in this case. But thank you all For trying to help! Really appreciated.
0
 
endasilAuthor Commented:
Should also add that it was able to find libraries under the lib folder automatically, so setting class path was not an issue in this case. But thank you all For trying to help! Really appreciated.
0
 
objectsCommented:
Check the manifest in your jar file, sounds like the jar is specified in there
0
 
objectsCommented:
> Should also add that it was able to find libraries under the lib folder automatically

only jars in ext directories get found automatically :)
0
 
endasilAuthor Commented:
Ah right,  netbeans adds a manifest to the jar when building  that contains lib/ as a classpath. That explains how it finds the files i added there.  I can find out that by extracting the files in the jar file with jar -xf javaapplication3.jar. But if i remove the  appserv-deployment-client.jar in netbeans, do a rebuild the manifest in the jar file contains no reference to appserv-deployment-client.jar. But it is still able to run it from netbeans.

I searched under my application3 directory for additional .mf files but the only one that exisit is a manifest.mt under the .\build\ direcotry that contains contains:
"
Manifest-Version: 1.0
X-COMMENT: Main-Class will be added automatically by build
"

So how does it find things from that jar when inside netbeans?
0
 
objectsCommented:
check your projects build path
0
 
endasilAuthor Commented:
Hmm, That should be the build directory under Application3 that i mentioned earlier? It only  contains an "empty" manifest.mf file and the .class files. No other manifest.

C:\Users\js\Documents\NetBeansProjects\JavaApplication3\build>dir /s /w
 Volume in drive C has no label.
 Volume Serial Number is 5E3A-BF8F

 Directory of C:\Users\js\Documents\NetBeansProjects\JavaApplication3\build


[.]                    [..]                   built-jar.properties
[classes]              [empty]                manifest.mf
               2 File(s)            185 bytes

 Directory of C:\Users\js\Documents\NetBeansProjects\JavaApplication3\build
\classes

[.]    [..]   [demo]
               0 File(s)              0 bytes

 Directory of C:\Users\js\Documents\NetBeansProjects\JavaApplication3\build
\classes\demo

[.]               [..]              Main.class        SB3Remote.class
               2 File(s)          2 408 bytes

 Directory of C:\Users\js\Documents\NetBeansProjects\JavaApplication3\build
\empty

[.]  [..]
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.