Force a printer on a Terminal Server to be your default printer?


We have some business partners that connect to a Server remotely via an SSL connection and then with Remote Desktop Connection.

The connection is working fine; but, the users need to use a specific application on this Server(that is they they are remotely  connecting to us).  Then if one would like to print from that application one needs to manually change the default printer to be 'printer1', when they logon to the Terminal Server.  

The problem is that the users need to change their default printer to be 'printer1' every time they logon to the Server.  Currently when they connect the remote PC's actual default printer is set as the default printer, in the user’s terminal logon session.  That is why the user needs to manually change the default printer to be ‘printer1’ every time they logon.  

Shouldn’t the default printer stay with the user account settings?  In this case the user account that is used to logon to the Terminal Server.  Is there a way to force it to remember the default printer 'printer1' for the next time they logon?
PkafkasNetwork EngineerAsked:
Who is Participating?
Krzysztof PytkoConnect With a Mentor Senior Active Directory EngineerCommented:
I would souggest to set up new GPO and configure Termian Services node for them.

Read this article

and look for section "Do not set default client printer to be default printer in a session", then server's default printer takes effect.

This is computer setting, so apply it to OU with your server
Are you using a Active Directory? If so, you can create an Organizational Unit and put all of your users there, then create a policy and apply a logon script to do that.

Script should look like this (test.vbs)

Dim wshNetwork
Set wshNetwork = CreateObject("WScript.Network")

wshNetwork.SetDefaultPrinter "PrinterName"
PkafkasNetwork EngineerAuthor Commented:
This Server is not part of our Windows Domain.  It is a stand alone server in a workgroup.  It is connected to via IP address.
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Krzysztof PytkoSenior Active Directory EngineerCommented:
OK then, set it in gpedit.msc on that server instead of GPO in domain
If it is already mapped the gpedit.msc will do, if not the startup script
PkafkasNetwork EngineerAuthor Commented:
OK, I will try it on Tuesday.
PkafkasNetwork EngineerAuthor Commented:
Do you mean make a batch file for the start up script?

The printer is locally installed.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.