Link to home
Start Free TrialLog in
Avatar of onetoomany
onetoomany

asked on

WAMP LOCALHOST Browser Refresh

Working in Dreamweaver CS3 and WAMP localhost, page refrsh in any browser (FF, Chrome, IE8, safari) doesn't work... the only way I can see the updated page is to open it directly from a folder or load a new version.

I could be wrong but after installing some software and uninstalling it I believe there was some message about windows clear cache dll or reg or smg is missing and I think this is at the time when the problem started. I running windows 7 and the problem works with both html and php pages static and dynamic pages.

I did a Norton IS 2010 scan with no viruses found.

Really appreciate any pointers.

Thanks.
Avatar of Jason C. Levine
Jason C. Levine
Flag of United States of America image

Are you doing a simple F5 refresh or a shift-refresh to force the browser to not used the cached page?
Avatar of onetoomany
onetoomany

ASKER

Thanks for the reply... tried both - ctrl f5 only works once... but doesn't update after sub sequent changes.
any ideas?
Should be shift, not control?  Is this with all browsers?
Yes, all browsers... shift and ctrl and shift+ctrl + prayers... nothing.
Okay, so you create/update the page in DW.  You save the file, presumably.  Is the DW local folder the same as WAMP's public web root or do you have to publish it to a new location?
yes, using WAMP non default directory... no error or problems loading pages.. just refreshing...

So if I pen a html page direly (file:///...) edit and save then refrsh.. page is refreshed.. but when open in localhost, changes are not refreshed until the page is reloaded.

>> changes are not refreshed until the page is reloaded.

And reloading consists of closing the browser, then reopening and browsing back to the page in question, right?
nope... just refreshing.

so if same page is open in browser - 1st is through localhost, 2nd fileopne (file///)

In dreamweaver, edit page > save > browser refresh and repeat.

localhost page does not refresh. directly open page does.

Doesn't matter if only one is open etc. Ofcourse remote pages like this one work fine.

It's definitely some sort of caching issue and probably in the WAMP settings somewhere.  It could also be due to Norton paranoia over the http://localhost/ (whereas file:/// is considered "safer")

Try this:

1) Disable Norton to see if that improves the situation
2) If not, download XAMPP instead of WAMP and try that.  The settings are tweaked a little differently and I find XAMPP to be the easier of the two to deal with.
not norton - trying xampp.. while I'm doing that - easy way to set root dir in xampp?
It's in the configuration pages of XAMPP when you first run it.  Can set the public web root from there.
Jason - Thanks for your help... but even with Norton Disables.. WAMP uninstalled and XAMPP installed.. pages will still not refresh when viewed through local host.
Just as a trouble-shooting option, what if you update the page, then stop/start XAMPP and then try to reload the page.  That would at least let us know if the caching is happening in the browser or in the web server.
ASKER CERTIFIED SOLUTION
Avatar of onetoomany
onetoomany

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
(... In the process of trying to resolve, I came across my new favorite toolet - xrefresh server and xrefresh FF extension.. the perfect revenge for browser refresh. recommend...)
You might also look at setting the HTTP headers for last modified and expires to force the browser to use HTTP headers to always reload the pages. Are you writing dynamic pages in PHP?  Try this on a page at the very top before any other content, template, etc is loaded to test.  
<?php
header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
header("Expires: Sat, 26 Jul 1997 05:00:00 GMT"); // Date in the past
?>  
Info from: http://php.net/manual/en/function.header.php
ofcourse.. but that's not the problem as remote web server pages refresh properly.