Solved

Cisco Networking

Posted on 2010-09-03
47
404 Views
Last Modified: 2012-05-10
Hello Experts,

I am testing some network configurations and i am stuck at one point.

I have made a router-on-a-stick using a catalyst 2900 and a 2600 series router.
I also have a Linksys that is used to to connect to my moedm and the internet.

so the outline looks like this:

Modem --> Linksys Router --> Catalyst -->Router-on-a-stick

I have made a Vlans, each Vlan has a computer connected to it.
Vlan 50 and Vlan 60

The computers can communicate with each other just fine.
The issue: I cannot get the internet on the computers.

If i plug everything into the default (VLAN1) i get the internet on both the computers.
If i plug the computers into their respective VLAN's i get no internet.

I have a few theories, but they are not solid.
Can anyone shine a light on this?

Thank you,

gmWindows
0
Comment
Question by:gmwindows
  • 21
  • 18
  • 5
  • +2
47 Comments
 
LVL 6

Expert Comment

by:joopv
ID: 33599833
Please post the configuration of the 2600 router.  (remove the passwords and public IP address)
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33599876
There is no Public IP on the router.
Current configuration : 490 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 50
 ip address 10.10.5.2 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 60
 ip address 10.10.7.2 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router#

Open in new window

0
 
LVL 4

Expert Comment

by:keith_opswat
ID: 33599921
You need either a static route
ip route 0.0.0.0 0.0.0.0 ip_address_of_next_hop_to_internet

or possibly

ip default-gateway ip_address_of_next_hop
0
 
LVL 6

Expert Comment

by:joopv
ID: 33599955
- The reason that pc's in the default vlan get internet access is that they don't use the 2600 router at all.
-  the 2600 router has no IP connectivity in the default vlan 1, alas no internet connectivity.
- There is no routing defined between vlan 50 and 60 and vlan 1
- There is no NATtting defined between vlan 50 and 60 and the internet gateway

First, put an IP address on fa0/0.  Which IP address depends on the linksys internet router config.  Take a look at the IP adresses and gateway that the PC's use.
0
 
LVL 4

Expert Comment

by:keith_opswat
ID: 33599959
Sorry should've given more information to help you understand why instead of just how.

Right now you have the interfaces configured for each computer that's plugging into it but their default gateway is set to the IP address of the interface. So once the packet gets to that interface it has no idea where to go next. You need to tell the router that any IP address it doesn't know coming from any location to send it out the port the internet is connected to.

Also, what is running your NAT & DHCP?

And lastly, I would do the command: no ip http server

The http server is VERY easy to gain admin access to the device by someone who shouldn't have it. I won't go into details on it, but you can read around and see I'm not the only one saying to disable it.
0
 
LVL 4

Expert Comment

by:keith_opswat
ID: 33599971
Lol. You beat me by a couple seconds. Well done.
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33600043
At the moment I am putting in Static addresses.
Although, the Linksys has DHCP enabled. But I am not really using it.

I know i need NAT to get from internal network to the Internet, but I'm not sure how it should be configured.

The Http server is turned off. Thank you for the warning.
0
 
LVL 4

Expert Comment

by:keith_opswat
ID: 33600088
Well my guess is that the linksys router is running nat. You just need to make sure that your devices are on the same IP subnet that your linksys is configured for.

However, you do need to just set a static route like I said.

I don't believe you HAVE to set an IP address on E0/0 as long as you're static route instead of being to the IP address of the router is like this

ip route 0.0.0.0 0.0.0.0 e0/0

That would tell the router to send any traffic it doesn't no where it goes out e0/0 and then the linksys will handle it from there.
0
 
LVL 4

Expert Comment

by:keith_opswat
ID: 33600096
I don't believe you can configure NAt on the 2600 router because you only have 1 real IP address and it's being used by the linksys. For NAT to work you would either need to get rid of the linksys, or have multiple routable IP addresses from you ISP.
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33600135
The Linksys is plugged into the switch and not the Router
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33600138
you need and can run NAT on the 2600, and you can only run NAT if you have the feature set in the IOS. Can you post:

show version

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33600171
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(13), RELEASE SOFTWARE (fc3)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 30-Jan-02 22:19 by kellythw
Image text-base: 0x80008088, data-base: 0x80CED5D8

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Router uptime is 4 hours, 39 minutes
System returned to ROM by reload
System image file is "flash:c2600-is-mz.121-13.bin"

cisco 2620 (MPC860) processor (revision 0x101) with 53248K/12288K bytes of memor
y.
Processor board ID JAB033505R1 (3008041898)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Router#
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33600207
yes, your router supports NAT, what is the IP and Subnet Mask for the LAN of the linksys router?
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33600222
The LAN IP is 10.10.4.1 255.255.255.0
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33600250
what is the vlan number for the port that the lInksys LAN is connected to?

Or better yet, add descriptions to the interfaces on the switch and send us a show run from the switch.

show run
show vlan id
show int trunk
show int status

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33600343
I have reloaded the router and switch.
It will be easier to just start from scratch.

This is my goal:

Have my default VLAN 1.
Configure another VLAN. Let's call it VLAN 10
Have VLAN 10 talk to VLAN 1
Have VLAN 1 and VLAN 10 be able to go to the internet.

What I have:
I have a Catalyst 2970, 2621 Router (which is going to be on a stick) and a crapy Linksys router. The Linksys router is receiving the WAN from the modem and has been plugged directly into the Catalyst switch.

What do you guys suggest for me to make this happen?

Thank you in advance!
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33600545
what ports are connect to what and where on the 2970?
0
 
LVL 24

Accepted Solution

by:
rfc1180 earned 500 total points
ID: 33601184
well, I am sure you can figure it out, a basic config would look something like this:

update the interfaces with your real interfaces

interface FastEthernet0/0
description Cisco 2970:Fast1/2
 no ip address
 duplex auto
 speed auto
 no shut
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40 native
 ip address 10.10.4.2 255.255.255.0
 ip nat outside
 no shut

interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 10.10.5.2 255.255.255.0
 ip nat inside
 no shut
!
interface FastEthernet0/0.60
 encapsulation dot1Q 60
 ip address 10.10.7.2 255.255.255.0
 ip nat inside
 no shut

ip route 0.0.0.0 0.0.0.0 10.10.4.1

ip nat inside source list 1 interface FastEthernet0/0.40 overload

access-list 1 permit 10.10.5.0 0.0.0.255
access-list 1 permit 10.10.7.0 0.0.0.255



switch:

vlan 40
name Internet GW

Vlan 50
name net1

vlan 60
name net2

interface fast1/1
description to linksys:LAN
switchport mode access
switchport access vlan 40
spanning-tree portfast
no shut

interface fast1/2
description to 2621:fast0/0
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allow vlan 40, 50, 60
switchport trunk native vlan 40
no shut

int vlan 1
shut

int vlan 40
ip address 10.10.4.3 255.255.255.0
no ip directed-broadcast
no ip route-cache
no shut

and of course assign a vlan to other ports for vlan 50 and 60:

interface fast1/10
description to server1
switchport mode access
switchport access vlan 50
spanning-tree portfast
no shut

interface fast1/11
description to server2
switchport mode access
switchport access vlan 60
spanning-tree portfast
no shut

etc, etc.


Billy
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 33606105
you dont need to configure the ip address on both the vlan 40 and interface f0/0.40
just one is enough
also make sure the port connected between the catalyst and the Router on stick is configured as trunk
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33606644
>you dont need to configure the ip address on both the vlan 40 and interface f0/0.40
just one is enough

The SVI that has the IP address is on the switch, there is no SVI on the router. The interface vlan 40 on the switch is for management. So I am not sure what you are referring to.


Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33620624
Thank you guys,
I can ping everything but the Linksys from the Cisco Router.
I think that there are still some issues with this.
I don't know what they are tho.

Any ideas?
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33621339
After some Testing i have a question.
The issue that I am having now seems to be (i believe) in this area:

ip route 0.0.0.0 0.0.0.0 10.10.4.1

When I run show ip route
I get:

Gateway of last resort is 10.10.4.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.5.0 is directly connected, FastEthernet0/0.50
C       10.10.7.0 is directly connected, FastEthernet0/0.60
C       10.10.4.0 is directly connected, FastEthernet0/0.40
S*   0.0.0.0/0 [1/0] via 10.10.4.1
Router#

Notice how it says S* 0.0.0.0/0 [1/0] <-- WHY 1/0 via 10.10.4.1

When I run the command:

ip route 0.0.0.0 0.0.0.0 fastethernet 0/0 10.60.4.1

It doesn't show up at all when I run show ip route.

Can it not forward information from the same port it receives it from?

Any ideas?
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33630870
Do i need to be running some kind of Routing Protocol as well?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 24

Expert Comment

by:rfc1180
ID: 33630960
>Do i need to be running some kind of Routing Protocol as well?
Not to get it working you don't; but I believe that the linksys does support RIP. You will however, need static routes for the 10.10.5.0/24 and 10.10.7.0/24 on the linksys router via 10.10.4.2:

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33631036
You have been a great help so far Billy.
I seem to have (what i think) some kind of routing problem.

The Cisco Router cannot ping the Linksys router.
The Cisco Switch can ping the linksys router but not the Cisco router on VLAN 30.
This is why i am lead to believe that there is some routing issue.
I have the exact configurations that you have placed earlier.
I've been trying to get this thing to work most of yesterday and the better part of today :(
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33631080
please upload the config for the switch and router; also please ensure there are descriptions on the interfaces.

Also, on the switch, please output:

show interface status
show vlan
show ip int bri

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33631269
SWITCH:

Switch#show running-config
Building configuration...

1d04h: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1722 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface GigabitEthernet0/1
 description to 2621 Router:Fast0/0
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 30
 switchport trunk allowed vlan 30,40,50
 switchport mode trunk
!
interface GigabitEthernet0/2
 description to linksys:LAN
 switchport access vlan 30
 switchport mode access
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
 description to WHITE Laptop
 switchport access vlan 40
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
 description BLACK LAPTOP
 switchport access vlan 50
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface Vlan1
 ip address dhcp
 no ip route-cache
 shutdown
!
interface Vlan30
 ip address 10.60.5.3 255.255.255.0
 no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
 no login
line vty 5 15
 no login
!
end

I Pinged the linksys from the switch.
It works.
When i ping the switch from a laptop that is plugged into the Linksys, it works.

Switch#ping 10.60.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.60.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1006 ms
Switch#

ROUTER:
Router#show running-config
Building configuration...

Current configuration : 845 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
 description Cisco 2970:Gigabit 0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.60.5.2 255.255.255.0
 ip nat outside
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.60.6.2 255.255.255.0
 ip nat inside
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 10.60.7.2 255.255.255.0
 ip nat inside
!
ip nat inside source list 1 interface FastEthernet0/0.30 overload
ip classless
ip route 0.0.0.0 0.0.0.0 10.60.5.1
ip http server
!
access-list 1 permit 10.60.6.0 0.0.0.255
access-list 1 permit 10.60.7.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
end

Pinging the 2960's IP address

Router#ping 10.60.5.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.60.5.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

When i ping anything from the 2620 it doesn't work
Pinging the Switch Interface (vlan30):

Router#ping 10.60.5.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.60.5.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Pinging the Linksys Router:
Router#ping 10.60.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.60.5.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router#

SHOW COMMANDS
Switch#show interfaces status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/1     to 2621 Router:Fas connected    trunk      a-full  a-100 10/100/1000Ba
seTX
Gi0/2     to linksys:LAN     connected    30         a-full  a-100 10/100/1000Ba
seTX
Gi0/3                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/4                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/5                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/6                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/7                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/8                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/9                        notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/10                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/11                       notconnect   1            auto   auto 10/100/1000Ba
seTX

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/12                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/13    to WHITE Laptop    notconnect   40           auto   auto 10/100/1000Ba
seTX
Gi0/14                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/15    BLACK LAPTOP       connected    50         a-full a-1000 10/100/1000Ba
seTX
Gi0/16                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/17                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/18                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/19                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/20                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/21                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/22                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Gi0/23                       notconnect   1            auto   auto 10/100/1000Ba
seTX

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/24                       notconnect   1            auto   auto 10/100/1000Ba
seTX
Switch#

Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/3, Gi0/4, Gi0/5, Gi0/6
                                                Gi0/7, Gi0/8, Gi0/9, Gi0/10
                                                Gi0/11, Gi0/12, Gi0/14, Gi0/16
                                                Gi0/17, Gi0/18, Gi0/19, Gi0/20
                                                Gi0/21, Gi0/22, Gi0/23, Gi0/24
2    VLAN0002                         active
30   Integrated_GateWay               active    Gi0/2
40   WHITE                            active    Gi0/13
50   BLACK                            active    Gi0/15
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
40   enet  100040     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
50   enet  100050     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Switch#

Switch#show ip int bri
Interface                  IP-Address      OK? Method Status                Prot
ocol
Vlan1                      unassigned      YES DHCP   administratively down down

Vlan30                     10.60.5.3       YES manual up                    up

GigabitEthernet0/1         unassigned      YES unset  up                    up

GigabitEthernet0/2         unassigned      YES unset  up                    up

GigabitEthernet0/3         unassigned      YES unset  down                  down

GigabitEthernet0/4         unassigned      YES unset  down                  down

GigabitEthernet0/5         unassigned      YES unset  down                  down

GigabitEthernet0/6         unassigned      YES unset  down                  down

GigabitEthernet0/7         unassigned      YES unset  down                  down

GigabitEthernet0/8         unassigned      YES unset  down                  down

GigabitEthernet0/9         unassigned      YES unset  down                  down

GigabitEthernet0/10        unassigned      YES unset  down                  down

GigabitEthernet0/11        unassigned      YES unset  down                  down

GigabitEthernet0/12        unassigned      YES unset  down                  down

GigabitEthernet0/13        unassigned      YES unset  down                  down

GigabitEthernet0/14        unassigned      YES unset  down                  down

GigabitEthernet0/15        unassigned      YES unset  up                    up

GigabitEthernet0/16        unassigned      YES unset  down                  down

GigabitEthernet0/17        unassigned      YES unset  down                  down

GigabitEthernet0/18        unassigned      YES unset  down                  down

GigabitEthernet0/19        unassigned      YES unset  down                  down

GigabitEthernet0/20        unassigned      YES unset  down                  down

GigabitEthernet0/21        unassigned      YES unset  down                  down

GigabitEthernet0/22        unassigned      YES unset  down                  down

GigabitEthernet0/23        unassigned      YES unset  down                  down

GigabitEthernet0/24        unassigned      YES unset  down                  down

Switch#

There is all the information you have asked for.

Thank you again for the help, I'm relatively new at this.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33631975
Something is up with the Trunk:

Also can you post an output from the switch:

show int trunk

Thanks
Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33636124
Here is the Trunking information from the switch:

witch#show interfaces trunk

Port        Mode         Encapsulation  Status        Native vlan
Gi0/1       on           802.1q         trunking      30

Port      Vlans allowed on trunk
Gi0/1       30,40,50

Port        Vlans allowed and active in management domain
Gi0/1       30,40,50

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       30,40,50
Switch#
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33636562
what about from the PCs, are you able to ping their default gateways" 10.60.6.2 and 10.60.7.2

The configs look fine from what I can see; however, I have never actually come across of actually doing a router on a stick with nat inside and outside statements on the sub-interfaces. Logic states is should work, but you could also be running into a bug.

What able the ports, can run through all the ports to ensure they are in forwarding:

on the switch report
show spanning-tree inconsistentports
show spanning-tree vlan 30
show spanning-tree vlan 40
show spanning-tree vlan 50
show mac address-table vlan 30
show mac address-table vlan 40
show mac address-table vlan 50


Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33636671
Switch#show spanning-tree inconsistentports

Name                 Interface              Inconsistency
-------------------- ---------------------- ------------------

Number of inconsistent ports (segments) in the system : 0

Switch#show spanning-tree vlan 30

VLAN0030
  Spanning tree enabled protocol ieee
  Root ID    Priority    32798
             Address     0013.60d6.1580
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     0013.60d6.1580
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1            Desg FWD 19        128.1    P2p
Gi0/2            Desg FWD 19        128.2    P2p

Switch#show spanning-tree vlan 40

VLAN0040
  Spanning tree enabled protocol ieee
  Root ID    Priority    32808
             Address     0013.60d6.1580
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32808  (priority 32768 sys-id-ext 40)
             Address     0013.60d6.1580
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1            Desg FWD 19        128.1    P2p

Switch#show spanning-tree vlan 50

VLAN0050
  Spanning tree enabled protocol ieee
  Root ID    Priority    32818
             Address     0013.60d6.1580
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32818  (priority 32768 sys-id-ext 50)
             Address     0013.60d6.1580
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1            Desg FWD 19        128.1    P2p
Gi0/15           Desg FWD 100       128.15   Edge P2p

Switch#show mac
Switch#show mac
Switch#show mac add
Switch#show mac address-table vlan 30
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  30    0100.0ccc.cccc    STATIC      CPU
  30    0100.0ccc.cccd    STATIC      CPU
  30    0180.c200.0000    STATIC      CPU
  30    0180.c200.0001    STATIC      CPU
  30    0180.c200.0002    STATIC      CPU
  30    0180.c200.0003    STATIC      CPU
  30    0180.c200.0004    STATIC      CPU
  30    0180.c200.0005    STATIC      CPU
  30    0180.c200.0006    STATIC      CPU
  30    0180.c200.0007    STATIC      CPU
  30    0180.c200.0008    STATIC      CPU
  30    0180.c200.0009    STATIC      CPU
  30    0180.c200.000a    STATIC      CPU
  30    0180.c200.000b    STATIC      CPU
  30    0180.c200.000c    STATIC      CPU
  30    0180.c200.000d    STATIC      CPU
  30    0180.c200.000e    STATIC      CPU
  30    0180.c200.000f    STATIC      CPU
  30    0180.c200.0010    STATIC      CPU
  30    ffff.ffff.ffff    STATIC      CPU
  30    0020.78c7.e422    DYNAMIC     Gi0/2
  30    0030.806d.3e60    DYNAMIC     Gi0/1
Total Mac Addresses for this criterion: 22
Switch#show mac address-table vlan 40
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  40    0100.0ccc.cccc    STATIC      CPU
  40    0100.0ccc.cccd    STATIC      CPU
  40    0180.c200.0000    STATIC      CPU
  40    0180.c200.0001    STATIC      CPU
  40    0180.c200.0002    STATIC      CPU
  40    0180.c200.0003    STATIC      CPU
  40    0180.c200.0004    STATIC      CPU
  40    0180.c200.0005    STATIC      CPU
  40    0180.c200.0006    STATIC      CPU
  40    0180.c200.0007    STATIC      CPU
  40    0180.c200.0008    STATIC      CPU
  40    0180.c200.0009    STATIC      CPU
  40    0180.c200.000a    STATIC      CPU
  40    0180.c200.000b    STATIC      CPU
  40    0180.c200.000c    STATIC      CPU
  40    0180.c200.000d    STATIC      CPU
  40    0180.c200.000e    STATIC      CPU
  40    0180.c200.000f    STATIC      CPU
  40    0180.c200.0010    STATIC      CPU
  40    ffff.ffff.ffff    STATIC      CPU
Total Mac Addresses for this criterion: 20
Switch#show mac address-table vlan 50
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  50    0100.0ccc.cccc    STATIC      CPU
  50    0100.0ccc.cccd    STATIC      CPU
  50    0180.c200.0000    STATIC      CPU
  50    0180.c200.0001    STATIC      CPU
  50    0180.c200.0002    STATIC      CPU
  50    0180.c200.0003    STATIC      CPU
  50    0180.c200.0004    STATIC      CPU
  50    0180.c200.0005    STATIC      CPU
  50    0180.c200.0006    STATIC      CPU
  50    0180.c200.0007    STATIC      CPU
  50    0180.c200.0008    STATIC      CPU
  50    0180.c200.0009    STATIC      CPU
  50    0180.c200.000a    STATIC      CPU
  50    0180.c200.000b    STATIC      CPU
  50    0180.c200.000c    STATIC      CPU
  50    0180.c200.000d    STATIC      CPU
  50    0180.c200.000e    STATIC      CPU
  50    0180.c200.000f    STATIC      CPU
  50    0180.c200.0010    STATIC      CPU
  50    ffff.ffff.ffff    STATIC      CPU
Total Mac Addresses for this criterion: 20
Switch#

Everything seems to check out :(
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33636685
I can ping the Default Gateways from the PC's.
I can also ping PC1 from PC2 and vice-versa.
The only thing that i cannot ping is the damn linksys router, or the vlan 30 address.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33638030
hmm, maybe this is it:


on the router, I believe you have to tell it that vlan 30 is the native vlan

interface FastEthernet0/0.30
 encapsulation dot1Q 30 native

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33638069
It won't let me do that.
It returns the following:

Router(config-subif)#encapsulation dot1Q 30 native
                                                                  ^
% invalid input detected at  ' ^ ' marker

Is there another way to do this?
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33638398
what is your IOS version on that 2620?
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33638408
sorry you did already; looking
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33638507
where is the ^ sign under, the dot1q, 30, or native. It is hard to tell.

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33638520
Under the Native
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33638634
yeah, you will need to upgrade the IOS, you do really have an old image. Give that a shot and I believe that should resolve the issue.
 

Any traffic on vlan 30 that was leaving a switch would be untagged. Any traffic arriving untagged would be assumed to be on vlan 30.

There is only one native vlan per trunk. This must match on both ends of the trunk and is responsible for all of the untagged traffic.

Or to test:

on the switch:

interface GigabitEthernet0/1
no switchport trunk native vlan 30

no interface vlan 30

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33638806
When i do that i am able to ping eveyrhting.
But i still get no internet connection.
Why can't i get the internet?
Is it the IOS problem or is it something else?
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33638830
DIsregard the above comment.
I got the internet now.

I believe that this sir is a working network prototype :)

So the whole issue was with the native vlan 30?
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33639042
>So the whole issue was with the native vlan 30?
Correct, the default is vlan 1
if you want to manage the switch, you will need to add an IP to vlan 1 so that the default vlan 1 is untouched or update the IOS.

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33639095
Where would i go to download the appropriate IOS?
This is older equipment that i have and I am using whatever came pre-loaded onto it.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33639165
The only place I know is cisco.com;

The image I am using is c2600-ik9o3s3-mz.123-26.bin

you can use your favorite browser to find other sources, but that would not be legal

Billy
0
 
LVL 2

Author Comment

by:gmwindows
ID: 33639212
Thank you very much Billy!
You have been a great help on answering all my questions.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33639223
u bet!
0
 
LVL 2

Author Closing Comment

by:gmwindows
ID: 33639276
You rule Billy!
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now