Sharing a USB Printer from a Windows 7 Machine over a SBS 2008 network

Hi All,

I am trying to share a USB printer, Model Brother HL2040, from a windows 7 machine over a network. All machines installed on the network are Windows 7. I have the correct driver install for the printer and setup the printer as shared over the network. I have file and printer sharing, network discovery and port 445 open on the firewall. We also have a SBS 2008 server that is trying to share it via a login script and GPO. We have a very similar GPO setup for another printer so I would assume the gpo itself is correct due to the fact the only thing that changed is the printer name.

Even if I manually try to add the printer from another Windows 7 workstation (same setup in regards to firewall) I can't connect to it. I can see it in the list of network printers when I try the wizard but can't connect to it. The other weird thing is I can't browse to the computer \\computername. It just gives me the lovely generic "Windows cannot access \\computername". When I diagnose it, windows recommends to open up port 445 which I have done on all computers in the network.

Is there something else that needs to be configured?


Who is Participating?
RLComputingConnect With a Mentor Author Commented:
I am able to broswe to the computers now. I enabled UDP ports 137,138,445 and TCP ports 137, 445 in the firewall.
if you can see the printer in the browser right click on it and choose connect. This sometimes lets me connect when the add printer routine wont work.
hope this helps
Are you running any 3rd party antivirus/firewall?  Both trend and symantec have additional firewalls you may have to open up.
Are the computers joined to a domain and if not are they all in the same workgroup? I had a similar problem with one of my clients (who did not have a domain controller) and it turned out the Win7 PC sharing the printer was not in the same workgroup and once I put it on the same as all the rest we could then see, add, and print to the printer in question.
RLComputingAuthor Commented:
Just opening those ports did the trick. I rebooted and the GPO's kicked down. Thanks!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.