Group policy not applying Server 2008 Terminal Server

I'm having issues with GPOs on a 2008 R2 Terminal server on a 2008 domain.
I have 2 GPOs at the Terminal Server OU level. These have user configuration settings, and they apply ok.
I have added another GPO at the users Ou level. This has some user configuration settings enabled.

WhenI I check the applied GPOs using gpresult, there is no mention at all of the new GPO. It's not showing as applied or filtered.
Any ideas?
lineonecorpAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike KlineCommented:
So you have loopback enabled?   Do you have it set using merge or replace?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lineonecorpAuthor Commented:
Loopback is enalbed on the Default Machine Policy, which is linked to the terminal server OU. It's set to replace.
However GPresult shows this GPO as filtered out for users:

The following GPOs were not applied because they were filtered out
-------------------------------------------------------------------
    Local Group Policy
        Filtering:  Not Applied (Empty)

    Default Machine Policy
        Filtering:  Disabled (GPO)
0
lineonecorpAuthor Commented:
Hang on, I think I've got it now.
The Default Machine policy scope was for Authenticated users only.
When I removed this security filtering, it seemed to work.
I would have thought the user counted as an authenticated user, seeing as they logged on successfully?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Mike KlineCommented:
You removed it and what did you add, just authenticated users should have been ok
0
lineonecorpAuthor Commented:
I didn't add anything. So the security filtering section is now blank.
My understanding is that it will apply to all users if no filtering is present?
0
Greg JacknowCommented:
Yes having authenticated users on a policy that you wanted to have apply to machines might be an issue.  As the machine section is not per user it authenticates per login as the computers account.
0
Mike KlineCommented:
Authenticated users does include computers.

Check the ACL on the GPO to see what the exact permissions are.

Thanks

Mike
0
lineonecorpAuthor Commented:
Hi Mike,
I checked the ACL, and authenticated users is added with read access. They are added authomatically when i add auth users to the security filtering.
However, I still get
 Default Machine Policy
     Filtering:  Disabled (GPO)

Any ideas? I would prefer to get it working logically as it should, rather than using work arounds.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.