Microsoft Dynamics CRM 4.0 - The specified Microsoft Dynamics server is not available when configuring Outlook client.

Hi Guys

I have noticed a few articles listed here with people experiencing similar issues but the fixes did not help me unfortunately.

I have installed Dynamics CRM 4.0 on a Windows Server 2008 R2 server with Update Rollup 12 using the guidelines provided by Microsoft in this article: http://support.microsoft.com/kb/950100

I am able to to view the CRM website (on port 80) from any machine on the network and it functions without issue. However when trying to configure the CRM client for Outlook from any machine on the network I get the following error:  The specified Microsoft Dynamics CRM server is not available. Make sure that the URL is correct. To test the URL, try opening it in Internet Explorer.

So far I have run the IFD configuration tool to make sure all the settings are correct and have looked at all IIS permissions etc, but not sure why the web interface will work but the client not.

I should also add that CRM will only be used internally at this stage, eg on-premises.

Any advice to assist me in resolving this issues will be greatly appreciated! This is the last hurdle to getting CRM working 100%.

Thanks
J
crm-error.JPG
systemnetAsked:
Who is Participating?
 
stacko111Connect With a Mentor Commented:
Have you looked at the potential issues that are suggested in that error message?

Also you could try a reinstall of CRM but this time create a new website instead of connecting to the default one. I always install CRM on port 5555 so there are no other web services working on the same port.
0
 
stacko111Commented:
Can you post the URL, the error code is blocking it in the image. Sometimes putting the domain in works i.e. http://servername.domain:portnumber
0
 
systemnetAuthor Commented:
Hi Stacko

I did not want to reveal the names of the servers for privacy reasons (as it reveals the name of the company), but I did try all the variations such as:

http://servername
http://servername:80
http://servername.domain.local
http://servername.domain.local:80

I am not sure if the following provides a hint, but this is logged in IIS logs when trying to connect:

#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2010-09-05 06:55:16
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2010-09-05 06:55:16 ::1 POST /MSCRMServices/2007/AD/CrmDiscoveryService.asmx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4952) 401 2 5 124
2010-09-05 06:55:42 ::1 POST /MSCRMServices/2007/AD/CrmDiscoveryService.asmx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.4952) 401 2 5 0

Any advice will be appreciated!

Thanks
J

0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Feridun KadirPrincipal ConsultantCommented:
Check this article out:  http://support.microsoft.com/kb/947423

Sometimes I've found I've needed to update values in the CRM databases to take into account host headers and port numbers.

0
 
systemnetAuthor Commented:
Hi Feridun

Thanks a lot of the suggestion. I have just run through every step in the KB article you referenced above, but unfortunately there has been no change. I am still unable to connect using the Outlook CRM client.

While I am to successfully connect using the web interface it seems like it is just the CRM Discovery Service portion that fails. If I put the URL that the CRM Client is trying to connect with directly in to Internet Explorer, I get the following error: HTTP Error 401.2 Unauthorised (due to invalid authentication headers). Please see attached screenshot. I strongly suspect something dodgy is going on with my IIS permissions.

Anything else you can suggest I try?

Thanks again
J
crm-iis-error.JPG
0
 
Feridun KadirConnect With a Mentor Principal ConsultantCommented:
I think you need to check out the settings of the CRM web site in IIS.

When you test the URL in IE are you asked for a user name and password? You shouldn't be.

Anonymous authentication shouldn't be enabled on the web site unless you have run the IFD tool. In which case could you post a screenshot of the IFD settings please?

Integrated Authentication is correct. Have you added the CRM URL to the Intranet or Trusted sites zone in Internet Explorer?

0
 
systemnetAuthor Commented:
Hi Guys

I covered off all the suggestions you made and double and triple checked all the settings and made no progress. I unfortunately had no choice but to completely remove CRM, uninstall IIS etc and start from scratch. The CRM installer created a new website and the only difference this time is that I selected the site to be created with a default port binding on 5555. So really not sure what went wrong the first time round. However, I am sure if time allowed and we persisted we may very well have found the issue. I will therefore split the points between both of you guys.

Thanks for you help and assistance!
J
0
 
systemnetAuthor Commented:
The answers were all good and if time allowed no doubt we would have found a solution. Unfortunately there was too much pressure to resolve the issue quickly and had to reinstall the product.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.