?
Solved

Security settings in IE won't load secure files???

Posted on 2010-09-03
13
Medium Priority
?
780 Views
Last Modified: 2012-05-10
I have no idea how to fix this or if it can be fixed. If I hit the page with https or a secure js file directly, it won't load the page or js with the security settings set to HIGH. I get a "Your current security settings do not allow this file to be downloaded" or the page loads partially. If I change the Internet security settings to Medium-High it loads fine. Is there any way to resolve this on my end so a user doesn't have to change their settings in IE?
0
Comment
Question by:894359
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
  • +1
13 Comments
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 33601696
For what it's worth, Medium-High is the default setting.  Most users will have that.
0
 
LVL 1

Expert Comment

by:jcw20
ID: 33601731
Chose medum after you chose customize  then click reset click okk on all screens . make sure your using at least IE 7 or better . I would download java machine from sun.com it free.
security.jpg
0
 
LVL 1

Expert Comment

by:jcw20
ID: 33601737
I  gues if you could change what zone it loads in or put the page behind a ssl certificat.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 1

Expert Comment

by:jcw20
ID: 33601741
the other thing you could is sighn your application  not sure how you do that.
0
 

Author Comment

by:894359
ID: 33602092
I appreciate the feedback but I'm trying to figure out how to resolve this problem without changing the browser settings. My QA dept. tests at a high security setting. One thing that didn't occur to me is that the secure code is served from a different sub domain. Would it make a difference if the code was moved to the same sub domain?
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 33602137
If you mean page from a domain and javascript from another or a subdomain, I can see that being that blocked.  Move it and find out.
0
 

Author Comment

by:894359
ID: 33602240
FYI...If you want to see what I'm talking about go to https://profile.ea.com/ that page contains references to our Omniture js code.

https://ssl.resources.ea.com/omniture/s_code_remote_v02.js
https://ssl.resources.ea.com/omniture/omniture_wrapper.js
0
 
LVL 3

Expert Comment

by:Tony Gimenez
ID: 33603087
Change "File Download" setting to "Enable" in the security settings.
0
 
LVL 3

Expert Comment

by:Tony Gimenez
ID: 33603150
Disregard above comment.
0
 

Author Comment

by:894359
ID: 33608649
Can anyone tell me why I would get this issue from the pages I posted I don't have any idea why or what the high security setting constitutes?
0
 
LVL 83

Accepted Solution

by:
Dave Baldwin earned 2000 total points
ID: 33608676
Maybe this will help: http://blogs.technet.com/b/steriley/archive/2008/09/16/internet-explorer-security-levels-compared.aspx

I notice that all cookies are disabled in 'High'.
0
 

Author Comment

by:894359
ID: 33608976
Thanks Dave... that article is very helpful!
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 33609078
You're welcome.  Thanks for the points.
0

Featured Post

Enroll in August's Course of the Month

August's CompTIA IT Fundamentals course includes 19 hours of basic computer principle modules and prepares you for the certification exam. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After uninstalling Opera browser (for example ver. 10.63), your attempts to open a web page by clicking on a URL link may fail with an error message.  The error is "This operation has been canceled due to restrictions in effect on this computer. Ple…
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…
Suggested Courses
Course of the Month14 days, 4 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question