Solved

Terminal Services Gateway problem with self-created certificate

Posted on 2010-09-03
6
2,713 Views
Last Modified: 2012-06-27
The set is like that:

Server 2008 R2 Enterprise has 4 virtual servers installed:
1. Testing server
2. Engineering server
3. Domain Controller (not yet created)
4. TS Gateway
In a testing environment all worked well. TS Gateway had self-signed certificate and a copy of it was installed on client PCs. Connection was flawless.

On the day host server moved into client's domain environment all was good, too:
1. All servers were assigned proper IP addresses to fit present network.
2. Domain controller role was installed and added to present domain.
3. All servers including host and guests were added to domain.

After that the test connection via TS Gateway was done with external access to TS Gateway (dyndns.org name created and port 443 forwarded to TS Gateway server on the main router). All works as it should. But as soon as I try to connect from external client there comes a delay, then remote connection client window freezes and an error message pops up saying:

"Your computer can't connect to the remote computer because the Remote Desktop Gateway server's certificate has expired or has been revoked. Contact your network administrator for assistance"

External client used has windows 7 Ultimate. Before servers were moved into domain, connection from the same client but different certificate (to fit testing office's dyndns.org name) was used successfully.

The only changes that occurred  on TS Gateway server are:
1. Changed for new self-created sertificate to match dyndns name.
2. Deleted server's certificate (created initially for server itself), but leaving newly created certificate only.

Just to mention - it doesn't matter the self-created certificate for now - we install it's copy in the root certificate authority folder on client's PC and it proved to work ok as a temporary solution.
0
Comment
Question by:sycamoresrv
  • 3
  • 3
6 Comments
 
LVL 4

Expert Comment

by:evilsi
ID: 33603081
Hi,

From what you have described the issue lies with the deletion of the old certificate. It would appear your new certificate doesnt have the components that your original certificate did. Did you create the new cert from the same template as the original one? Try requesting the TS gateway certificate again using the http://servername/certsrv and installing it.

hope this helps

Si.
0
 

Author Comment

by:sycamoresrv
ID: 33603467
Yes, I deleted all certificates to make sure I don't mess with the old ones and create a new one right from the management menu of TS Gateway.
I went even further - reinstalled the whole virtual TS Gateway server from scratch to make sure everything to be intact there but same result.
What I want to stress is that I am capable to connect using Gateway's dynamic name from any PC connected internally (even so I unchecked the option to avoid Gateway for local addresses). I have a strong suspicion my RV042 router does not pass through on port 443, although the port range forwarding rule is implemented.
0
 
LVL 4

Expert Comment

by:evilsi
ID: 33603610
you seem to have covered the bases for the TS gateway then.. Does that router have to capability to have remote management or SSL VPN services (like Draytek routers).. If so you may have to disable those router services..

Si.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:sycamoresrv
ID: 33604061
no, i checked many times - there are no settings for VPN services being active on it. Thinking of swapping it with some other working model for tests.
0
 
LVL 4

Expert Comment

by:evilsi
ID: 33604070
Can you rdp to the server from outside as a test with port forwarding of 3389?
0
 

Accepted Solution

by:
sycamoresrv earned 0 total points
ID: 33604702
Yes, in fact rdp port forwarding works fine but port 443 does not. I searched through internet on RV042 problems and found many references concerning problems with SSL port forwarding, even if you have the latest firmware.
I installed another working router that was tested in the office here and it proved to blame RV042 as there are no problems with connection for TS Gateway anymore.
Thank you evilsi for advises.
0

Featured Post

ScreenConnect 6.0 Free Trial

Check out the updates in one game-changing release, ScreenConnect 6.0, based on partner feedback. New features include a redesigned UI that improves session organization and overall user experience. See the enhancements for yourself!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question