No Exchange email on iphones

I just installed windows SBS 2003 on a new server, and exchange mail works for all clients, but some users have iphones. I cannot get exchange to actually work on iphone 4.0. I ran ExRCA and got the results below...

      ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name mail.beachchurch.org in DNS.
       Host successfully resolved
       
      Additional Details
      Testing TCP Port 443 on host mail.beachchurch.org to ensure it is listening and open.
       The port was opened successfully.
      ExRCA is testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps

I've tried to follow the KB on installing a cert, but it still fails on the certs validation checks. This is worth 500 points as I have to have this up and running by Sunday.
Houston BlancettAsked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Please have a read through my Exchange 2003 / Activesync article, check your IIS settings, run the test on the test site and resolve any errors that the test site throws up.
You don't need a 3rd party SSL cert for SBS 2003 to make Activesync work, it just has to be named correctly (e.g., mail.yourdomain.com). The iPhones will just about accept any SSL certificate (as long as they are named properly). If the cert is not named properly, just re-run the connect to the internet wizard and change nothing until you get to the certificate part, then just create a new SSL certificate with a name that resolves to your server's IP Address, then complete the wizard, changing nothing else, re-check your IIS settings (because they will change) and then test again.
When running the test on the test site, it is important to tick the "Ignore Trust for SSL" check box unless you have a 3rd party certificate.
My article:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.htmlIf my article cannot get you working - then only a call to Microsoft will !!

0
 
nwtechdeskCommented:
SSL certs will fail unless you pay an extortionist rate to Network Solutions or Comodo or some other company for an annual cert.  For iphones, I find I set it up, let it error but it still saves the settings.  Then edit the settings to turn off SSL.  Alternatively, if you have a self-installed cert, turn on SSL and when it checks, you must accept the cert.
0
 
khurram008Commented:
I suggest to install an certificate from authorized certificate authority on exchange server and then test IPhone Active Sync. You can go for free  trial certificate from www.RapidSSL.com It will work for 30 days. Please get the certificate, install it on exchange and then test Active Sync using SSL.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Alan HardistyCo-OwnerCommented:
A 3rd Party SSL certificate is not a requirement for Activesync to work with an iPhone. If you have Windows Mobile Phones, then you have to install the self-issued certificate on the phones, but the iPhones only care about the name on the certificate matching the FQDN entered for the servername (e.g., mail.yourdomain.com).
3rd Party SSL certificates can make the process easier all round and the cheapest 3rd Party SSL certs are usually found at GoDaddy (www.GoDaddy.com) - only a single name certificate is required. You could always visit my GoDaddy Reseller account at www.exchange-certificates.com too) ; )
I have customers with SBS 2003 servers with self-issued certificates working 100% happily with iPhones and Windows Mobile phones.
0
 
Alan HardistyCo-OwnerCommented:
It is also worth noting that there is a bug with the early release of iOS4 and if you don't have iOS 4.0.2 at least, then you will need to download a fix:
http://alanhardisty.wordpress.com/2010/07/02/apple-ios4-issues-with-iphone-4-3gs-3g-and-exchange/ 
0
 
evilsiCommented:
hi,

Please check you have exchange 2003 sp2 installed. Even if you have all the configurations correct without sp2 the iphones wont collect mail.

Apart from that alanhardisty has covered most of the bases.

regards
si.
0
 
Alan HardistyCo-OwnerCommented:
@evilsi - SP2 is covered in my article ;)
0
 
Houston BlancettAuthor Commented:
The first part cleared everything up. I simply needed to install service pack 2 for exchange. Excellent article!
0
 
Alan HardistyCo-OwnerCommented:
Thanks musicmd - glad my article helped resolve your problem and glad you liked the article.  Did you vote for the article too : )
 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.