?
Solved

Netware DNS / Web server not working after ISP change

Posted on 2010-09-04
6
Medium Priority
?
748 Views
Last Modified: 2012-06-21
Hello, I need help with this configuration problem that have.  

I have a Netware eDir network, with integrated DNS.  The lan is 10.0.0.0 / 255.0.0.0.  The DMZ range is x.x.x.151 – x.x.x.156.  I have a virtual Netware 6.5 SP4 DNS server / web server in the DMZ, called NS1, which runs 2 websites.  Website A is .153 and website B is .156.  This server was the public name server for the domain, and they had a couple of AT&T DNS servers as NS2 & NS3.  This server also only resides in the DMZ; it does not have a card connecting it to the lan.  NS1 does not appear in the tree.

In addition to the public nameserver, I have 3 DNS servers in the lan.

Today we moved from AT&T internet to a new provider.  I logged in to the Sonicwall (pro 3060) and I changed the wan & dmz settings, and reconfigured the address groups and objects.  

Once this was done I was able to connect to the internet again.

I then proceeded to edit the settings on NS1.   I initially did this manually in the text file, because I didn’t realize it would cause the server to fail.  After getting the warning that the server detected a change and would not run the config, I then went to inetcfg and entered the address.  I put in the IP for the server itself, which is x.x.x.153.  I thought I was supposed to have a second binding on this card for the x.x.x.156 address, but when I put that in, the server would not load the board.  So I did something wrong there.  I removed that .156 entry and right now that site is offline.

Next I went to the DNS / DHCP applet and added the new zone.  I created the in.addr.arpa zone and added the www and my 2nd website which is offline.  Saved the zone to NDS.  I deleted the old AT&T zone, refreshed the tree.

I then went back to NS1 to troubleshoot the .156 problem, but discovered that named.nlm would not load.  I get this error:

“Starting eDirectory integrated DNS server
Critical:  registration with IP management framework failed -1
Critical:  loading configuration:  failure
Critical:  exiting (due to fatal error)
DNS server has unloaded successfully
DNS server exiting”

I attempted to find the problem but I came up with nothing.  So at the end, I changed nameservers to network solutions, created the records for the www and mx there, and thought the www would be working by now.  (The mail server hasn’t been changed yet, I’m waiting to fix this first)  I still cannot load the website at .153, and right now the server isn’t answering a ping either.  I thought this may be due to the Sonicwall configuration, but I have so little experience with this setup that I don’t know where to start.

I have also noticed that my internal DNS servers now say,

“Unable to set journal, log attribute, or SOA sr. no.  with error 25.
 unable to update the SOA record for domainname.org.zenworks with error 25”

I don’t know when they started returning that error.  I didn’t look at them until the end.
I would like to return the DNS back to the NS1 machine, but I am at a loss now.

So my questions are,

**How do I configure the NS1 to listen on both of those IP addresses?

**Is there somewhere other than httpd.conf and inetcfg, where I would have to add the public IPs for those 2 sites?

**What in the world happened to the DNS and how do I fix it?

I inherited this setup so unfortunately I don’t know all of the logic behind it.

Thanks
0
Comment
Question by:Christine5550
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
6 Comments
 
LVL 33

Expert Comment

by:digitap
ID: 33603787
I haven't been in eDir in over three years.  I'll do some research while waiting for some more experienced Novell experts to chime in.
0
 

Author Comment

by:Christine5550
ID: 33603808
Ok here's an update.  I was able to get the mail server working through the DMZ so I know the firewall is ok.

I discovered this morning I had the gateway wrong on NS1.  So when I corrected the gateway on NS1, I received a different DNS error.  I tried to correct it by re-entering all of the info, and I am back to the framework error.  So maybe this has more to do with tcp/ip on ns1 than it does the DNS.  I can't ping the server either, nor can the server ping out.  

Maybe I should blow away the whole configuration and re-enter it.    

I also still have to figure out how to add the IP for the other web site.  
0
 

Accepted Solution

by:
Christine5550 earned 0 total points
ID: 33808770
Hello, to update you on the solution to this, I had several issues:

1.  I blew away the tcp/ip, reinstalled networking components, reconfigured.  That took care of the weird dns / named error.

2.  I use public DNS for SOA on the domain names, and use private DNS internally.  No more DNS in the DMZ on its own tree.

These 2 steps solved 99% of my problems.

Thanks :-)
0
 
LVL 33

Expert Comment

by:digitap
ID: 33808994
OK...so no research was done, but I'm glad you got it resolved.  Thanks for posting back your solution.
0
 
LVL 60

Expert Comment

by:Kevin Cross
ID: 34387552
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

Enroll in August's Course of the Month

August's CompTIA IT Fundamentals course includes 19 hours of basic computer principle modules and prepares you for the certification exam. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is intended as an extension of a blog on Aging and Scavenging by the MS Enterprise Networking Team. In brief, Scavenging is used as follows: Each record in a zone which has been dynamically registered with an MS DNS Server will have…
There have been a lot of times when we have seen the need to enter a large number of DNS entries in a forward lookup zone. The standard procedure would be to launch the DNS Manager console, create the Zone and start adding new hosts using the New…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses
Course of the Month11 days, 19 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question