Solved

Bundling links Cisco routers

Posted on 2010-09-04
8
760 Views
Last Modified: 2012-05-10
I read in a book that you can bundle links.  Example:  2 routers are connected directly to each other, each with 2 interfaces, all in the same subnet.  Example:  

R1                                                R2
F0/0:  172.18.0.1 /16  =====  F0/0 172.18.0.3 /16
F0/1:  172:18.0.2 /16 =====   F0/1  172.18.0.4 /16

It said you must enable EIGRP first, or it will give you an interface error.  I tried this and could not get this to work.  If this can be done, can anyone explain to me how to do this?  Thanks.
0
Comment
Question by:B1izzard
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 24

Expert Comment

by:rfc1180
ID: 33604848
>I read in a book that you can bundle links
What book?

what is it that you are trying to do?

There are several technologies in which you can bundle links:

multilink ppp (Typically for ISDN, T1s, etc)
Etherchannel LACP/PAgP (Ethernet)

>I tried this and could not get this to work.
you tried this what? Can you please post the commands that you tried?

Billy
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 33606061
Am sure you did read in the book that you can bundle links, however if it was a ciscopress book are you sure it said that all interfaces should be in the same subnet?

Here how your network will be

R1                                          R2
F0/0:  172.18.0.1 /16  =====  F0/0 172.18.0.2 /16
F0/1:  172:19.0.1 /16 =====   F0/1 172.19.0.2 /16

Configure the ip addresses on the interfaces, then enable EIGRP, this is the proper order
Try the above setup, and you will have a working solution
0
 

Author Comment

by:B1izzard
ID: 33607366
I am doing this only for learning purposes.  It's good to know in case I do come across it somewhere else in the future.  

The book is by Todd Lammle.  It's CCNA Study Guide for exam 640-802  page 436.  It says regarding bundling links:  Eigrp can allow us to do this without any extra configuration.  He then uses 2 routers and states that both links will have all interfaces within the same subnet.  Here is his configuration.

Corp#int s0/0/0
Corp(config-if)#ip address 10.1.2.1 255.255.255.0
Corp#int s0/0/1
Corp(config-if)#ip address 10.1.2.4 255.255.255.0

R1(config)#int s0/0/0
R1(config-if)#ip address 10.1.2.2 255.255.255.0
R1(config)#int s0/0/1
R1(config-if)#ip address 10.1.2.3 255.255.255.0
R1(config-if)#do show run | begin interface
interface Serial0/0/0
description 1st Connection to Corp router
ip address 10.1.2.2 255.255.255.0
interface Serial0/0/1
description 2nd Connection to Corp router
ip address 10.1.2.3 255.255.255.0

It also says "To make this fabulous configuration work, EIGRP positively must be enabled first.  If not, you'll get an error on your router that the addresses overlap".  

I tried setting up 2 routers with:
router eigrp 100
network 172.18.0.0
Then tried adding the interfaces.  I could get 2 to work, but the third would always give me an address overlap error.
0
[Live Webinar] The Cloud Skills Gap

As Cloud technologies come of age, business leaders grapple with the impact it has on their team's skills and the gap associated with the use of a cloud platform.

Join experts from 451 Research and Concerto Cloud Services on July 27th where we will examine fact and fiction.

 
LVL 24

Expert Comment

by:rfc1180
ID: 33607570
very interesting and is a cool feature; I was not aware that you could do this. You really do learn something new everyday.

I can not find any Cisco documentation that covers this feature; so I am not sure if the limit is only 2 interfaces. You could be running into a bug if you have 2 already bundled and adding a third one gives you a address overlap error. It seems like there would be a limit of how many interfaces could be bundled, but not sure what that limit is. I would think just ensure that the third interface you are adding is part of 172.18.0.0 and not part of any other interfaces.

Billy
0
 
LVL 24

Accepted Solution

by:
rfc1180 earned 500 total points
ID: 33607662
I was able to add the 3rd link:


Router1#show ip
*Mar  1 00:06:29.935: %SYS-5-CONFIG_I: Configured from console by consoleroute
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Serial0/0
                    is directly connected, Serial0/1
                    is directly connected, Serial0/2

Router1#show ip int bri | inc up
Serial0/0                  192.168.1.1     YES manual up                    up
Serial0/1                  192.168.1.3     YES manual up                    up
Serial0/2                  192.168.1.5     YES manual up                    up

Router2#show ip int bri | inc up
Serial0/0                  192.168.1.2     YES manual up                    up
Serial0/1                  192.168.1.4     YES manual up                    up
Serial0/2                  192.168.1.6     YES manual up                    up

Router1#show ip eigrp nei
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.1.6             Se0/2             14 00:05:37   56   336  0  33
2   192.168.1.4             Se0/1             11 00:06:23  520  3120  0  30
0   192.168.1.2             Se0/0             13 00:07:10   53   318  0  31



what I did was:

Both routers:

router eigrp 100
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary

Router 1:

inter serial0/0
ip address 192.168.1.1
no shut
inter serial0/1
ip address 192.168.2.1
no shut
inter serial0/2
ip address 192.168.3.1
no shut

Router 2:

inter serial0/0
ip address 192.168.1.2
no shut
inter serial0/1
ip address 192.168.2.2
no shut
inter serial0/2
ip address 192.168.3.2
no shut

Once all neighbors formed, is when I then changed the IP addresses on the interfaces:

Router 1:

inter serial0/1
ip address 192.168.1.3

inter serial0/2
ip address 192.168.1.5


Router 2:

inter serial0/1
ip address 192.168.1.4

inter serial0/2
ip address 192.168.1.6

Billy

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 33610949
It's a cool feature, no doubt.

But if you're studying this in prep for the CCNA exam, you're wasting your time. This feature isn't covered on the exam and it could be in conflict with the technologies that are covered on the exam.




0
 
LVL 24

Expert Comment

by:rfc1180
ID: 33611538
>This feature isn't covered on the exam
Nope, I have never seen it on any material even on the CCNP; not sure about any CCIE material.

Billy
0
 

Author Comment

by:B1izzard
ID: 33633587
That worked.  My problem was that I only added one network into eigrp, and not both.  That is apparently what it takes to get it working.  I'm actually starting to work on a CCNP, but it's been 2 years since I took the CCNA, so I'm going through it for a refresher.  To me I'm more interested in learning regardless of whether or not this is in the scope of any exam.   Thanks everyone for the feedback.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month7 days, 3 hours left to enroll

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question