Solved

iMac Start-Up Troubles - must use work-arounds to boot to internal HD

Posted on 2010-09-04
28
936 Views
Last Modified: 2012-08-13
Hello Experts:

FIRST:
MY SYSTEM
_________________________________________
Model: iMac8,1, BootROM IM81.00C1.B00, 2 processors, Intel Core 2 Duo, 3.06 GHz, 4 GB, SMC 1.30f1
Graphics: NVIDIA GeForce 8800 GS, NVIDIA GeForce 8800 GS, PCIe, 512 MB
Mac OS 10.6.4 Snow Leopard
HD: Hitachi : Capacity:      750.16 GB (750,156,374,016 byte
 Model: Hitachi HDS721075KLA360    
____________________________________________


MY ISSUE: I have recently seen a slow degradation in my system's start-up actiion - for which I have  utilized various "fixes" that I know of from my own experience and tech reading ( run Applejack [the new Snow Leopard version]; run ONyx, find bad pref files and delete them, run a system Restore using Super Duper, run a Full System Restore using Time Machine and OS X Disk utility) - all of which have become, one-by-one, ineffective.

The history of the issue is as follows : ever since accepting the "10.6.4" Apple Update, i noticed that startup began to run slowly. Ok, no big deal  - the machine still started up, eventually! ( after a delay of, maybe, 30 seconds...which grew progressively longer to about 60 sec's ). Then the problem got worse: no starup at all. When trying to startup, my screen progresses to the grey before-the-Apple-logo screen, then it  fills up with lots of baffling text. A few issues which I saw repeatedly on this grey screen were something like :  "no de-bugger found," "Panic...." and many other lines of text that, I'm sorry, I did not record!

Curious,  i searched Apple Forums for a similar problem, but found nothing.So I set off on my own to see what I could do.

A run of Onyx found 4 corrupt Pref. files. I deleted them. That was good for one good startup. Then, back to where I was....slow, then NO startup!    .  

I have an install of Drive Genius 3 (which often seems to find false positives - which I ignore), and I remembered that one frequently  repeating DG3 message I had been getting lately was "There are 2 bad sectors on your HD. Please erase HD and run Scan to repair" As I said, I tend to ignore these DG3 nags because previous experience has proven that, in fact after a scan, the app fails to find these "false positive" bad sectors. But in this case, since i was definitely having a serious problem, I ran DG3's "Extended Scan" on my system Drive (without wiping my drive - no way, man!). **Amazingly, the scan took a very long time to complete - seven full days, 24/7 [I have a 768 GB HD]" - AND IT DID  FIND AND REPAIR 2 BAD SECTORS! Wow! I thought. I'm back in business. I noticed a real speedup of my system after using DG3!

But. just like with Onyx, that fix was good for one free good bootup - then back to the "grey screen of death text.

Still, Applejack was always able to ride to the rescue and boot me up ok. But I know that that's not normal - I shouldn't need Applejack everytime I startup!

As mentioned above, I have an install of Super Duper - which I highly recommend to everyone! I twice restored an earlier "good" system from my Super Duper external disk to my HD. But after exiting Super Duper and trying to bootup to my HD, no go. Same old "grey screen of death text. (I can run the machine fully functional from a Super Duper backup on the external, so it's not as if I can't use my machine at all.)

Next, I tried a full system restore from Time Machine - which worked perfectly for me once before - but this time, even though I restored to a time *before* 10.6.4, no difference. Still no good startups! I used Super Duper to go back to the more recent 10.6.4.

And then, today, even Applejack would not boot me up - it returned a screen of its text,  part of which mentioned, like before, "no debugger found," and "panic..."

At this point I am up and running after having left the power cord disconnected for several hours, and then  running a "deep" Applejack checkup. Hmm.

Oh, also..one more clue....many of the "successful" startups (not all of them!) have thrown an Error window-after starting up ok - (see attached "Error".jpg) that I am completely unfamilar with, which asks ;"Where is System Restore?"  and gives me a browser window - to find it, I guess. When i browse I can't find "System Restore" anywhere on my system.
So...where I stand right now is, I am up and running (without having found System Restore as requested) but otherwise running perfectly. All apps work. Speed is good. Everything appears normal. I'm not going to shutdown the machine until I get a solution to the startup problem. I'm afraid that sooner or later nothing will get me back up!

Can anyone help?


Tx
jbm4

 "Where is System Restore?" error
0
Comment
Question by:jbm4
  • 13
  • 10
  • 3
  • +1
28 Comments
 
LVL 53

Expert Comment

by:strung
Comment Utility
If you run "Verify Disk" using Disk Utility, does it report errors?

Also, what does Disk Utility show as the S.M.A.R.T. status?

Also, have you run "repair prermissions"?
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
Also run the Apple Hardware Test:  http://support.apple.com/kb/ht1509
0
 

Author Comment

by:jbm4
Comment Utility
Hello Strung,

Sorry, I should have mentioned : "Verify Disk" finds no problems. Disk Utility ( and Onyx) report S.M.A.R.T  status good.

Yes, have repaired permissions with each attempt to fix.

Have not tried the Apple Hardware Test. Was not aware of it. Will do this later today or possibly early tomorrow - have to run for now, many things to do.
Will report back here with those results asap!
Wow, thanks. you were fast!

jbm4
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
Check with Disk Utility and make aure your partition map is set to GUID and not Apple Partition Map.
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
0
 
LVL 15

Expert Comment

by:roylong
Comment Utility
Sounds like a hardware fault causing this.  Have you got the original install DVDs?  Run the AHT (apple hardware test) which is on one of the disks.  It will tell you in small print on the disk.. ..also tells you how to start it, I think it's the C key while booting, or a combination of two keys.  I'll check once I'm up and about - if you put the DVD in and boot holding the Alt/Option key this should give you the boot manager and the AHT will show up as a boot option.

Once booted, run all tests (full tests) and report back.  If nothing is found then I would check components like memory, if you have some spare to swap out?

It could be a processor or mainboard issue - I've seen that causing kernel panics before.  Do you have access to any apple engineers?
0
 
LVL 15

Expert Comment

by:roylong
Comment Utility
By the way two bad disk sectors would not cause this kind of issue and should not require an erase of a disk.  Bad sectors get marked as such by apple's disk utility and not used.  Most S.M.A.R.T. these days will tell the OS not to use these sectors anyway.
0
 
LVL 13

Expert Comment

by:maximus5328
Comment Utility
To eliminate or confirm the possibility of bad hard drive you should try booting to external drive. It needs to be FireWire, though.
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
Intel Macs will boot from external USB drives. Not necessary to use firewire.
0
 

Author Comment

by:jbm4
Comment Utility
Hello maximus5328 & strung:

I have booted sucsesfully multiple times to an external firewire disk. That is where i keep my Super Duper backups. Boots just fine.

Am about to run the AHT now. Will soon report on that.

jbm4


0
 
LVL 53

Expert Comment

by:strung
Comment Utility
If you can boot fine from an external but, not for the internal, that indicates a problem with the internal drive.

The first thing I would do is to check to make sure the internal drive partition map is GUID and not Apple Partition Map. You can check this by pulling down the Apple Menu to About this Macintosh, then select More Info. If necessary, expand the hardware category and look under Serial-ATA. Let us know what it says under "partition map type".
0
 

Author Comment

by:jbm4
Comment Utility
Hello strung, again:

The Extended Apple Hardware Test found "No Problems."

re: "make sure the internal drive partition map is GUID and not Apple Partition Map" my partition map type is set to  GUID. Have attached sceenshot of that info [see:"serial ata.jpg] for you to confirm.

A few new details:
Overnight I ran a full virus scan, using Intego Virus Barrier X6. It found an infected .dmg file on one of my external disks, where I store apps. (This file was never executed).I deleted the file - sorry, I didn't take the trouble to get the name of the "virus." <(if that's what it was!)

The restart-and-boot-to my OS X disc 1 to get to the AHT took 3 attempts. My own fault on that, because I only remembered to disconnect all peripherals right in the middle of the first boot attempt. So I quickly powered-off in the middle of that first boot. Then the next boot attempt - natch -  threw that grey screen of death at me again. This time around, I took some time to read over all the text on that screen. I did not understand any of it. But I have saved a few "key words & bits & phrases" that I thought might be  meaningful to you:

  • "panic.......registers"
  • CRO: {incomprehensible data here-thru-#5}
  • EAX:
  • CR22:
  • EFC:
  • "Debugger ..??..(panic)"
  • "Kernel extensions in backtrace (with dependencies)" {followed by a long list of "dependencies"}................
  • "Kernel version {a date and some numbers}" "waiting for remote debugger conncection."For


To make sure to get a good boot-up this (the third) time, I used Applejack again. It's "deep" scan. I took the trouble again in Applejack to try to record some "key words & bits & phrases"
that are meaningless to me, but may be meanginful to you:

  • "Disk had no errors"
  • "All supporting devices are not loaded" "Let's mount startup file system for write access"
That's all i managed to grab, as Applejack flies by so fast, it's hard to follow it.

At this time I am up and running from my internal HD smoothly, but I fear re-starting again until I hear anything helpful back from you guys!

jbm4


Serial--ata.jpg
0
 

Author Comment

by:jbm4
Comment Utility
I dunno what all that stuff appearing above my file attachment is in last comment! Weird!
jbm4
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 53

Expert Comment

by:strung
Comment Utility
Try looking through the console logs (/Applications/Utilties/Console.app) to see if that sheds any light.
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
Also try a safe boot  by booting holding down the shift key.  Then check to see what start up items are set in your user account. It is possible that you have some out of date software trying to boot.

Also, do you have any haxies installed, like WindowshadeX or anything of the sort? You will find them in the "other" category of your system prefs.
0
 

Author Comment

by:jbm4
Comment Utility
strung:

Have checked Safe Boot - nothing there looks suspicious. All up to date apps.

re:"haxies": do you count any of the following as haxies? :
  • FinderPop
  • Deja Vu
  • MailFX Pro
  • Emppty Trash
  • Cuckoo
  • Default Apps
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
Could be. Check to make sure they are all up to date.
0
 

Author Comment

by:jbm4
Comment Utility
strung: have assured all above pref. apps are up to date.

HERE'S SOMETHING : at your suggestion, I was checking back through Console messages to early today - when I was having so much trouble starting up. There is a long series of entries about "kernel........."Disk 7:0X3e8. UNDEFINED". [se attached "console entries re:disk 7"] Does this indicate some disk malfunction?

I'm nearly at wit's end with this damn thing! We've been all over it, haven't we?

console-entries.jpg
0
 
LVL 13

Expert Comment

by:maximus5328
Comment Utility
you should replace the disk
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
I am puzzled as to what Disk 7 is. Your internal hard drive should be Disk 0.  Do you have any other drives attached to your computer?
0
 

Author Comment

by:jbm4
Comment Utility
strung:

I have two externals : 1 Western Digital 1.5 Tb USB, and 1 Iomega 500 Gb Firewire


maximus5328:

All tests of the internal HD (AHT, Disk Utilities, Drive Genius, etc.) report "No Problems" with it. Is that what you are referring to in "you should replace the disk"? cause that just wouldn't make sense.
Or are you referring to the mysterious "Disk 7 "? I don't know what "Disk 7" is!

BTW: after having left the power cord detached overnight, my Mac booted almost perfectly this morning! It still threw up that "Where is System Events" browser box. I just clicked "Cancel" to make that go away, and I am now cooking with gas!

(One Apple Genius once told me that a lengthy disconnection from power source is often a "magic fix" for a Mac. As goofy as it sounds, this has worked more than once for me. Have you guys ever heard of this?) Of course, the test will be to see how the next 24 - 48 hours of use go. One good startup does not a Total Fix make!

In regards to that "Where is System Events" error, strung, i think it was you yesterday who provided a link to an Apple Forum discussion on this topic. That forum came to no clear understanding of the event at all. Since then, I have browsed  other mentions of it in other forums, and it seems to be a total mystery everywhere to everyone, even to Apple techs themselves! Various people have posed different theories about it, but so far I haven't found any proven solution to it. Go figure! Do you think it could in some way be responsible for bad startups?

Anyways, as I said above, the next 24 - 48 hours of use will hopefully elucidate this issue. At that point, I would hope to be able to award points to someone for all of your time and energy spent on this.

Is there an established protocol on EE for awarding points on a long, difficult issue like this, if, say, I feel you have provided a partial solution, or perhaps only provided some good education to me? Or if I get a "Magic Spontaneous Apple Fix" as described to me by that Apple Genius once, can you still get rewarded just for effort? I want to handle this right.
Please advise.

Barring any other bright ideas from you guys, i will report back in 48 hours on this issue.

jbm4
0
 
LVL 53

Accepted Solution

by:
strung earned 500 total points
Comment Utility
When you get the Where is System Events error, click on the BROWSE button on the error dialogue box and locate it at:

System/Library/CoreService/System Events.app

Select it in the dialogue box and the message should not re-appear the next time you boot.

You could also try an SMC reset:  http://support.apple.com/kb/HT3964?viewlocale=en_US


0
 

Author Comment

by:jbm4
Comment Utility
hi strung:

Funny, when I was working on this issue yesterday, I cud swear I tried to find System/Library/CoreService/System Events.app and couldn't find it - and other people in forums were reporting they couldn't find it too!  I'll check using Finder right now to see if I can locate it... YES, there it is! Is it possible that that error box browser treats it as invisible??
And I noticed something odd about that file just now: I wanted to color/bookmark it for easier finding next time - but the location was paled-out and would not accept any color. What's that about?

0
 
LVL 13

Expert Comment

by:maximus5328
Comment Utility
In my experience a disk can fail without any indication or warning from disk testing apps. The fact that you are able to boot and run normally from external HD is reason enough for me to suspect the internal HD. My next step would be to replace the internal disk.
0
 

Author Comment

by:jbm4
Comment Utility
Hello maximus5328

The thing is, today the machine successfully booted itself up in the morning (to the internal HD), and I have had occasion this morning to log-out/in and restart numerous times already without any problems!

Is it too surreal to invoke that "Magic Spontaneous Apple Cure" that I mentioned above? ("Leave the power disconnected for a good length of time, and your Mac will bounce right back"). i know it sounds hokey - but a real Apple Genius told me this once. And I have seen it work several times. Maybe this is another time!

I'd be honestly appreciative of your informed opinion on this, as I too - at my  Intermediate tech level - find "The Magic Apple Cure"  irrational and dubious. (except that it seems to work!..mebbee it's some kind of hypnotism?)


jbm4
0
 
LVL 53

Expert Comment

by:strung
Comment Utility
What you did probably had the effect of re-setting the SMC.
0
 

Author Closing Comment

by:jbm4
Comment Utility
Hi strung , roylong, & maximus:
Sorry to be so long awarding points on this issue. Have just returned from a visit with my iMac to the local Apple Genius Bar, where I got a fresh new install of OS X.6- The fault was a corrupted kernel file.

So....Ultimately, although strung did not _specifically_ identify the kernel problem (How could he, without being here to see the grey failed start-up screen?), he did go for all kinds of system issues which logically would suggest themselves. And strung provided me the most accurate system info  re: "Where Is System Events?" -
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

In this article we discuss how to recover the missing Outlook 2011 for Mac data like Emails and Contacts manually.
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now