Solved

Excel Row Autofit Not Working Properly

Posted on 2010-09-04
8
1,522 Views
Last Modified: 2012-05-10
Whenever I set a Row to Autofit, it leaves a additional height (extra space) at the top portion of the row that does  not go away.  I have gone into the cells and checked for returns or extra spaces, no dice.  Anyone know how to fix this problem?  Some of the Columns are also set to Wrap Text.  It works on some rows, but not on others, and there is no consistency or pattern.

Thanks,
Cody-
0
Comment
Question by:codyvance1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 50

Accepted Solution

by:
Ingeborg Hawighorst earned 500 total points
ID: 33605645
Hello Cody,

my experience shows that if the cell content goes very close to the right edge of the cell, the autofit can stuff up and add an additional row, even though it is not required. Making the width of the column just a little bit wider will often help the problem.

I guess it may have to do with Excel calculating the inner margin of the cell and arriving at the insight that it does not all fit in the allotted height, although the eye says it does.

See screenshot for examples of cells with one, two and no rows too close to the edge.
cheers, teylyn
autofit.png
0
 
LVL 10

Expert Comment

by:etech0
ID: 33605646
Try dragging the rows smaller (less than you need), then doing autofit by double clicking between rows. You can do both of these to all rows by doing ctrl-a first
0
 
LVL 50

Expert Comment

by:Ingeborg Hawighorst
ID: 33605655
etech, what are the chances that we post in exactly the same minute, hours after the question has been asked. LOL.

I find your suggestion does not work, though. In the example of the above screenshot, the autofit will bounce back to the too high rows.

cheers, teylyn
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 10

Expert Comment

by:etech0
ID: 33605678
Really? It worked for me. I guess we have to see what Cody says...
0
 
LVL 92

Expert Comment

by:Patrick Matthews
ID: 33606154
:)

Several variables go into this, including the "active" printer driver, so it is certainly possible that behavior seen by one user will differ from behavior seen by another...
0
 
LVL 50

Expert Comment

by:Ingeborg Hawighorst
ID: 33606182
etech,

the point is that with a situation like I posted above, the autofit will add empty spaces, even though the text seems to fit in the cell. Changing the row height manually and then using autofit again does not resolve the problem.  Excel will put in an extra blank row if the text is too close to the right hand border of the cell.

Patrick, I find this has nothing to do with the printer driver. The example above has been created on just one machine.

The text fits in the cell, but autofit row height will add a blank line, if the text is too close to the right hand cell border.

The crucial issue really is: What is "too close"?  Have a play with some sample text, like I did in the sample above, and see. Move the cell border to the right or left just a  pixel or so and see that the autofit will insert an empty line in the cell, even if the text does not require a line break.

As far as I'm concerned, this is an Excel bug. WYSIWYG is not working.

cheers, teylyn
0
 

Author Comment

by:codyvance1
ID: 33655024
Anyone know if there is a way to adjust the Excel cell margins maybe?  Not sure if this would fix it or not..
0
 
LVL 50

Expert Comment

by:Ingeborg Hawighorst
ID: 33655206
Hi Cody,

as far as I know, you can only increase the cell margins with the indent settings of the formatting dialog, but you can't reduce them.

You could try out a slightly smaller font size. For example, if you're using Arial 10, try Arial 9.5 instead. You won't be able to select that font size from the drop-down, but you can enter it manually in the font size box. Excel accepts font size increments of 0.5.

cheers, teylyn
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This code takes an Excel list of URL’s and adds a header titled “URL List”. It then searches through all URL’s in column “A”, looking for duplicates. When a duplicate is found, it is moved to the top of the list. The duplicate URL’s are then highlig…
In Part II of this series, I will discuss how to identify all open instances of Excel and enumerate the workbooks, spreadsheets, and named ranges within each of those instances.
This Micro Tutorial demonstrate the bugs in Microsoft Excel for Mac with Pivot Charts.
This Micro Tutorial will demonstrate the scrolling table in Microsoft Excel using the INDEX function.

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question