Solved

SBS exchange server settings

Posted on 2010-09-04
13
432 Views
Last Modified: 2012-05-10
i need to know how to change the email setup for all users in exchange 2007 SBS. When the server was configured it would not let me change the email to .com it kept it as .local. Email routes out but unless i can change the users email address to .com no email will route in. i need to get this resolved before monday if possible. The system is a SBS 2008 server running exchange 2007. As it stands now all user email addresses are (username@domain.local) and they need to be (username@domain.com). Any help will be appreciate.
0
Comment
Question by:bmic
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +2
13 Comments
 
LVL 8

Expert Comment

by:Emptyone
ID: 33605715
The best is to run the Internet Configuration Wizard, which should take care of you mail domain as well, but you can also do it manually through Exchange Management Console. Under Organization Configuration, go to Hub Transport, be sure to add domain.com as Accepted Domain. Set it to authorative if this is the only server for this mail domain. Then go to E-mail Address policies tab, and then you can either add a new policy, or just change the one that is there. Add domain.com, and addjust that so it is equal to domain.local except for the domain name and be sure to set it as Reply. Apply this and you should be fine
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33605716
Have you completed the Internet address wizard in the SBS Console?

Alternatively in Exchange Management Console under Organisation Configuration you should see Accepted Domains tab, check that your .com domain is listed and is authoritative.

Then under the email addresses tab check your default policy what is specified here?

Will it let you add a new policy?
0
 

Author Comment

by:bmic
ID: 33605814
I've made the changes that you noted in your post but still no email is routing in. What else might i check on the recieve tab under server config under hub i have 3 connectors a client, default, and SBS FAX all enabled. just FYI
0
Turn Insights Into Action

You’ve already invested in ITSM tools, chat applications, automation utilities, and more. Fortify these solutions with intelligent communications so you can drive business processes forward.

With xMatters, you'll never miss a beat.

 
LVL 22

Accepted Solution

by:
chakko earned 250 total points
ID: 33605835
Can you send locally using the new/correct domain name email addresses?  If you check the user account has the email address been updated with the new domain already?

On the network side, are your settings configured properly for inbound email?
1.  MX record created and correct IP address
2.  Router/Firewall is configured so that SMTP (port 25) is routing to your mail server


0
 

Author Comment

by:bmic
ID: 33605839
Not sure about mc record will hve to check in the morning gone home for tonight. Will u be available in the morning ?? Where r u located Iean state
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 33605846
Also check on the Default Receive connector that anonymous is allowed access
0
 
LVL 22

Expert Comment

by:chakko
ID: 33605850
Try this website, maybe it will help show where the problem is.
 
https://www.testexchangeconnectivity.com/
 
 
0
 

Author Comment

by:bmic
ID: 33605851
Ok will do and will get back to you
0
 
LVL 6

Assisted Solution

by:Gary Stevens
Gary Stevens earned 250 total points
ID: 33605854
The .local is the standard 'internal' domain. This setting for each User is normal. (UserName@mydomain.local)
It is recommended you run 'Internet Configuration Wizard' and this will setup all the functionality you require and, if the SBS box has been setup correctly, each User will then also get the required 'UserName@MyDomain.com) additional to the .local one.
Internet Configuration Wizard actually works and us boffins hate that. We think we know better. Yeah right!
Don't forget port 25 on your router.
Use MXToolBox.com to test all your connectivity and server security. You can use telnet (your IP) :25 but that needs to be done from another IP.
Cheers
GS
0
 

Author Comment

by:bmic
ID: 33605859
Didn't run the wizard where is that Iust have missed it during the setup
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33605865
With SBS you should always use the wizards.  It's when we don't use the wizards that things stop working.

You will find all the wizards in the SBS Console (should be a shortcut on the desktop)

Run through them all in order and it should set everything up for you.
0
 

Author Comment

by:bmic
ID: 33605867
Thank will give it a go an get back to u in the morning
0
 

Author Closing Comment

by:bmic
ID: 33613010
Thanks Great job. created mx record which i forgot to do and that solved the problem. Thanks again
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question