Solved

Access files on C Drive from IE8

Posted on 2010-09-05
11
699 Views
Last Modified: 2012-05-10
I have an internal application where I read the contents of the desktop and present list to user, who can then click on a link to that file.

Problem is that only files that are on the network are launched, not those on the C drive.

I know that this is a security setting in IE but can't find it ...

I also understand the security risks, but this is a trusted site.

Peter
0
Comment
Question by:pambrose1
11 Comments
 
LVL 8

Expert Comment

by:tskelly082598
ID: 33606373
typing in  C: opens on my computer with no security setting changes.

It displays file:///c:/
0
 
LVL 3

Expert Comment

by:Neurom
ID: 33606592
Perhaps this option you're looking for: IE Tools --> Internet Options --> Advanced --> Security --> Allow active content
to run in files on My Computer

Anyway to open a local file, just put "file:///" before the path of the file you want to open, without no security setting changes, as said tkelly.

Example: "file:///C:/document.txt"

Hope this help
0
 

Author Comment

by:pambrose1
ID: 33606832
Hmmm ... seems to ring a bell ... changed the security setting, but still, when I click on the link, nothing happens  ...

I can read the contents, so looks like I have access to read, but it's the click that fails
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:pambrose1
ID: 33606837
Screenshot showing filelist but no clicking works!
untitled.JPG
0
 
LVL 3

Expert Comment

by:Neurom
ID: 33606841
So probably the error is in 'application that builds links to local files on your desktop. You can see the HTML source to find links that generates by the application?
0
 

Author Comment

by:pambrose1
ID: 33606956
Nope - it works absolutely fine with files located on the windows server - just those on the local machine-  I've seen this before but can't remember how to fix it...
0
 

Author Comment

by:pambrose1
ID: 33606960
0
 
LVL 3

Expert Comment

by:Neurom
ID: 33606987
0
 

Author Comment

by:pambrose1
ID: 33607101
Have had a look at this - the iexplore.exe in the registry is already set to 1 so don't think that's the problem - its a security setting in IE I seem to recall...
0
 
LVL 4

Expert Comment

by:ErwindeVries
ID: 33611280
Its seems that internet explorer is not the problem if the site is added to trusted sites then IE is not the problem. This application shows the files but clicking them does nothing. So its either the apllication or the rights on the files. Please make sure the rights have been set appropriate. Maybe compare them with the rights on the server. Cause they work on the server the same settings might fix the problem on the local level. If its not that it must be the application.
0
 

Accepted Solution

by:
pambrose1 earned 0 total points
ID: 33643763
Its a registry security setting that you need to set; even putting the documents in the trusted zone will not work with local files any more.

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Lockdown_Zones\0\2101

Set 2101 to 0 (the default value being 3)
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question